Sonos Arc power cord is loose

  • 18 December 2020
  • 10 replies
  • 304 views

Hi,

 

My brand new Arc is driving me nuts because any time someone touches the TV console the power cord gets shaken loose and the speaker setup stops working!!

 

Has anyone else had this issue? Can you please suggest how I can get the cord replaced as it must be covered under warranty?


10 replies

You possibly need to push it in harder. Is the disk on the power cord completely flush with the Arc housing?

Userlevel 7
Badge +21

If it is really hard to push a bit of DRY silicone lube on the outside of the plug can help.

Hello and thank you for your responses.

The cable is completely flush with the housing, the socket is simply too large to hold the cord in place.

I can probably use blu-tac or something to hold it in place but obviously having spent 800 pounds on it I would prefer for Sonos to replace what appears to be a faulty part!

Appreciate any further help!

 

 

I’d probably take a digital picture of it, and then call Sonos Support directly to discuss it.

When you speak directly to the phone folks, there are more options available for them to assist you than are available le either here or in chat. 

I have the same issue.  The connection that the power cord has with the speaker is almost nonexistent, I think it is fair to say that the connection is loose   

 It constantly disconnects due to the minor vibration that the speaker makes.  
I contacted Sonos regarding the issue.  They sent me a different power cord that is longer in length….but the fitting at the end of the new cord is exactly like the original?   Very disappointed in this purchase.  

Badge

I have the same issue, Sonos have promised to send a new cable but after calling to chase up still has not arrived - having said that based on the last post sounds like it won't make a difference!

Prior to finding this issue I had been linked to a thread regarding intermittent sound, now I realise why it was intermittent ie due to the power cable connection.

You have to keep pressing it in then lightly take your fingers away, then stay well clear as the lightest disturbance causes it to pop out.

Can you post a picture of it? Based on the amount of force required with my two Arcs, I continuue to wonder if the cord isn’t seated properly, and is just barely hanging in there with the connection. 

Badge

Thanks for response Bruce, my power lead came and it’s a better fit than the original so problem solved

Badge

I have the same issue, Sonos have promised to send a new cable but after calling to chase up still has not arrived - having said that based on the last post sounds like it won't make a difference!

Prior to finding this issue I had been linked to a thread regarding intermittent sound, now I realise why it was intermittent ie due to the power cable connection.

You have to keep pressing it in then lightly take your fingers away, then stay well clear as the lightest disturbance causes it to pop out.

New cord received, better fit and no further issues 

New cord received ….did not solve my issue.  The cord is still extremely loose and becomes disconnected whenever sound is turned up or music with lots of bass.   Very disappointed 

Reply