sonos arc+ lg c1 arc/earc issues

  • 22 November 2021
  • 12 replies
  • 112 views

Badge

Hi

Since i bought my LG OLED c1, impossible for me to get sonos arc work properly when i open the TV ( i have to revert to internal speakers then select hdmi arc to have the sound go back)

But the worse is that i couldn't have earc: when i toggle earc in the menu it reverts automatically to internal TV speakers

I'm using a ultra Hugh speed hdmi câble certifiée between the two devices, sonos arc and LG c1 up to date, i've tried all the settings possible on the TV ( passtrough, auto, bitstream, simplink, hdmi deep color etc)

Is it sonos related?

 

 


12 replies

Userlevel 7

Redo the TV Setup process in the Sonos app:

Disconnect everything from your TV and unplug the TV and Arc from power for a couple of minutes. Plug the TV and Arc back into power but keep everything else disconnected. Be sure Simplink (CEC) is enabled on the TV. Run the TV Setup process in the Sonos app and connect the Arc to the TV when the app instructs you to using the HDMI cable that came with the Arc. When the Arc has been successfully connected, connect your other devices to your TV.


Set your TV settings to this:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Auto

eARC support: On

Badge

Indeed with the official hdmi cable everything works liké it should

Thanks a lot!

 

Hi,

 

I'm having similar issues, but when using the original HDMI which came with the Arc, I was getting a glitch loop where the sound output was switching between TV speakers and wired speaker (Sonos Arc). 

 

I've just replaced the HDMI cable for a 2.1 8K one, and I'm now getting a different issue: no sound. Once I enable eARC, sound output is changed to TV speaker.

 

Should I try the above instructions? 

 

I'm yet to setup TV in the Sonos App, not sure what that is.. 

 

Many thanks 

Rob

Userlevel 7

Hi,

 

I'm having similar issues, but when using the original HDMI which came with the Arc, I was getting a glitch loop where the sound output was switching between TV speakers and wired speaker (Sonos Arc). 

 

I've just replaced the HDMI cable for a 2.1 8K one, and I'm now getting a different issue: no sound. Once I enable eARC, sound output is changed to TV speaker.

 

Should I try the above instructions? 

 

I'm yet to setup TV in the Sonos App, not sure what that is.. 

 

Many thanks 

Rob

Yes, try the above instructions. TV Setup can be found under the Arc settings in the Sonos app.

Thank you for your reply. 

 

I tried what you suggested, however when I enable the eARC function in the TV I get the glitch loop again. 

 

I initially tried it with the after market HDMI which could not be found by Sonos, then when I used the Sonos supplied HDMI it connected the Arc to the TV fine. The minute I enabled the eARC function, it glitches again between TV speaker and wired speaker via HDMI.

 

Any other suggestions please? 

Userlevel 7

@RobDee What model TV do you have? Did you enable CEC on the TV? Do you have any external devices connected to the TV?

@RobDee What model TV do you have? Did you enable CEC on the TV? Do you have any external devices connected to the TV?

I have LG55 C1 2021, I enabled CEC on the TV and have no devices connected.. 

Userlevel 7

@RobDee What model TV do you have? Did you enable CEC on the TV? Do you have any external devices connected to the TV?

I have LG55 C1 2021, I enabled CEC on the TV and have no devices connected.. 

Make sure the Arc is connected to the TV’s HDMI eARC port and set your TV to these settings:

Sound Out: HDMI ARC

HDMI Input Audio Format: Bitstream

Digital Sound Out: Auto or Pass Through

eARC: On

Auto Device Detection: On

You Simplink: On

Auto Power Sync: Off

My Sonos Arc works in Arc mode, I am connected to the Arc/eARC socket 3 on the back and have all of the settings as suggested. 

 

Please see video of the loop glitch: Video

I've spoken with LG and they have offered to replace the connection board on the back. I've only had it 2 months so the TV came with this fault.

 

Thank you for your help.

 

Edit: I should add, it's only when I enable eARC that I get the problems. 

 

It seems I'm getting Atmos OK, just not uncompressed. 

Userlevel 7

 

It seems I'm getting Atmos OK, just not uncompressed. 

FYI… you are only going to get lossless Dolby Atmos via Dolby TrueHD from a Blu-ray or UHD disc or from an external media device that supports Dolby TrueHD like an Nvidia Shield.

 

It seems I'm getting Atmos OK, just not uncompressed. 

FYI… you are only going to get lossless Dolby Atmos via Dolby TrueHD from a Blu-ray or UHD disc or from an external media device that supports Dolby TrueHD like an Nvidia Shield.

That makes sense, thank you! 

I shouldn't really bother pursuing this then until I test it with those formats. 

 

Thanks so much. 

Reply