Answered

Sonos Arc crackling during 7.1 TrueHD/Atmos

  • 10 October 2021
  • 6 replies
  • 248 views

Setup:

  • Sonos 5.1 surround system (Arc + Bass + 2x One SL)
  • TV (LG OLED65CXPUA) via the HDMI eARC and a Monoprice High Speed HDMI
  • 2019 Nvidia Shield Pro with Plex for video playback

Problem: Whenever I play videos with 7.1 audio tracks (including TrueHD/Atmos), I hear crackling from all speakers intermittently. It seems to correlate with high bass times, but it reproduces in similar parts of all videos I’ve tested with.

 

This does NOT happen if the source is 5.1 (even if it’s 5.1 Atmos, such as a “E-AC-3+Atmos / E-AC-3” audio channel).

 

I’ve specifically also tested with the Dolby test files available here: https://thedigitaltheater.com/dolby-trailers/, and for these two versions:

Nature's Fury (Dolby Digital Plus ATMOS): plays fine

Nature's Fury (Lossless - ATMOS): crackles

 

Any ideas?

icon

Best answer by Defenestrator 10 October 2021, 06:36

View original

6 replies

Userlevel 7

Have you tried using the HDMI cable that came with the Arc rather than the Monoprice cable?

Yep, I was using the included Sonos HDMI cable and it had the same issue since I got the Sonos (months ago). I actually just swapped to the Monoprice cable today to try it out since I read cables can sometimes be the culprit, and it experiences the same problem as the official cable.

Aaaand I fixed it, I had to switch audio out from Auto to Passthrough.

 

Specifically, on my LG OLED65CXPUA, Settings → All Settings → Sound → Additional Settings → Digital Sound Out must be set to Pass Through (it was originally Auto).

Strange that I’m getting the same issue, even in Passthrough.  And I have the CX (55), as you do. 

All Lossless material has an abnormal rumble/crackle (and sometimes a pop) from my center speaker in bass heavy sequences, but all lossy material sounds pristine.  I’m wondering if my Arc is faulty.  

 

Hello @Defenestrator,

I have a Sonos Arc + TV LG OLEDG1, when I watch a series (with Dolby Atmos sound) on Netflix or Amazon Prime I have “Dolby Atmos” on the Arc, everything is fine but when I play an MKV file (via integrated LG player or via Plex) things go bad, 2 cases:
- if the sound is encoding in "EAC3 Dolby Digital Plus with Dolby Atmos" it’s ok I have “Dolby Atmos” on the Arc soundbar (the Sonos app show me “Dolby Atmos” on the screen).
- if the sound is encoding in "MLP FBA Dolby TrueHD with Dolby Atmos" it’s not ok I have "Dolby 5.1 multichannel PCM" which is displayed on the Sonos app (see screenshot) and not Dolby Atmos as in all other cases.

Do you have any idea about this problem ?

Thx a lot 

 

@Defenestrator 

When you play a “Dolby TrueHD with Dolby Atmos" file do you have “Dolby Atmos” displayed on the Sonos app ? 

Reply