Sonos app skips to next song before the current one has finished playing



Show first post

413 replies

Userlevel 7
Badge +20
Same issue - Diagnostic report 1652874966

From happening occasionally, now a song will play for maximum of 2 minutes then skip to the next on the playlist.

Simply infuriating!

Stephen Weaver


Hi Stephen,

Please try disabling auto-lock on your iOS device by changing the option in your device's settings menu under Display & Brightness. Also, you can try disabling AirPlay on non-Sonos device on your network. We'll update this thread when we have more to share on this issue.
877421476
Same here. Was working fine before adding the bridge. Have sense removed and still skipping. Have changed wireless from 11 to 6. I have two play1. Before I could bearly connect to it. Would have to spend half an hour trying to connect.
This might be the time to spend $300 for the Apple speaker and know that it will work when screen is locked and that it won’t have all of these issues.
In the same boat here as well.. The moment the updates occurred is when the skipping started. It has to do with the auto-lock but I use my phone all day, I can't just leave the auto-lock turned off, It would kill my battery more.
Same here. I have two expensive Sonos products and now I effen regret having bought them. Everything was working fine for over a year when I purchased them. When the latest updates took place all when down hill not to say when to Ssss.... I use an apple iPod to play music not an iPhone and it does the same same obviously because of the auto lock issue and I feel bad for those with iPhone that have to keep it unlocked. SONOS TEAM wake up and fix this ASAP! You are going to lose and have so many angry and disappointed customers that it will start being taken to social media and I guarantee you this will kill your company. Wake up and FIX it ASAP or give me my money back, I will gladly send you back your junk. That's what you turned it to to my eyes.
I've just turned off my Sky Q Airplay feature and this issue went away... Maybe worth a try.
Thanks@Shortware. Can you direct us as to how to do that?
On the Sky Q boxes (all of them), Home > Settings > Setup > Music. there is a setting called "Allow music to be sent to this box" which is set to ON as default. Turn it off. When you've done all of the your Q boxes (and minis), go into the iPhone SONOS app and More > Settings > Advanced Settings. Choose RESET CONTROLLER. Then close the app and go back in and select "Connect to an Existing SONOS". Everything worked fine on mine when I did this. Good luck!
OK... you might have been answering someone else. I do not have nor was I speaking about a SKY box. I was referring to general use of a SONOS product and trying to playback music through them. Thanks anyway.
@HRD. I commented saying what I’d done to stop the issue I was having where the end of tracks were being cut short. I specifically said I had disabled my Sky Q AirPlay and you asked how I did that. I answered... I would suggest phoning the tech support team. They know their stuff.
Userlevel 7
Badge +20
877421476
Same here. Was working fine before adding the bridge. Have sense removed and still skipping. Have changed wireless from 11 to 6. I have two play1. Before I could bearly connect to it. Would have to spend half an hour trying to connect.
This might be the time to spend $300 for the Apple speaker and know that it will work when screen is locked and that it won’t have all of these issues.


Hi there,

When using a mesh system like the Ubiquiti one, we recommend using a BOOST setup. By wiring in one Sonos unit to your main router you should be able to isolate the Sonos mesh network and increase stability. If this isn't the case for you, it would be best to have our phone team take a look at things live. Please give us a call, our number is found here.
Userlevel 1
After sitting back in this thread for a couple months while I spent hours upon hours going through this thread with a fine tooth comb, I am now adding my voice to the multitude of unhappy Sonos customers.

I have this problem too. ?

My Sonos system (with four Play 1 speakers) ran flawlessly for a couple years until just like everyone else, my Sonos system started cutting off songs and randomly jumping to others in the playlist. This mind numbing problem started after the latest round of updates that hit the Sonos app earlier this year.

I have spent many MANY hours on this frustrating problem, reading this thread from beginning to end, trying EVERY suggestion given as well as reading all help links given and absolutely nothing suggested has worked.

The answer for all of us is most definitely NOT changing to a new channel (I tried that) or making sure that they are close enough (all 4 speakers are within eye shot of each other), nor is it any other suggestion that I’ve painstakingly tried, including resetting the system from scratch like everyone else is saying. I even hard wired one of the speakers to the router instead of using wireless for it, making sure it was at least 3ft away from the router. That didn’t work either, it still skipped all over the place.

This problem is NOT affecting just an isolated few who just need a tweak with their settings or channels. This is THOUSANDS of us customers having this headache. All one has to do is search online regarding this Sonos problem and you can see Sonos is getting dragged through the mud not coming up with a workable solution on this.

BUT, FOUND A POSSIBLE SHORT TERM FIX which is actually Sonos’ latest suggestion in this thread:

Having this issue with Sonos means that I simply have stopped playing music around the house but today I got dragged back to this issue getting totally frustrated as once again our Sonos system started skipping mid song etc when i attempted to get 10 good minutes out of it while doing dishes. With still no clue as to what in the actual heck is going on and how to fix it I came back here to this thread to see the latest suggestion by Sonos Reps saying to try TURNING OFF screen AUTO-LOCK. So I started testing.

It would seem the TEMPORARY answer (for an Apple iphone user like me) is to TURN OFF AUTO-LOCK under “Display & Brightness” in the iPhone “Settings”.

And it works. So far. Whether it’s sticks and keeps working is another matter, but after running several playlists for a couple hours and no skipping or issues I’m guessing this is the short term fix. I’ll report back with another not so long post if it starts skipping again.

In the meantime DEAR SONOS TEAM: asking us to TURN OFF our “AUTO-LOCK” Apple screen time out feature and just leave our screens to just stay on IS NOT THE ANSWER. Something in your Sonos App has changed to cause this. Can you PLEASE sort this out so that we can keep our screen time out feature left on? That would be GREATLY appreciated.

And of course I will report back if the problem starts up again. Though I hope it doesn’t, obviously.

Sorry for the long post but after spending all these hours on this I had a lot to share, including frustration. ?
oh no I don't use an iphone and I get this problem as well. Just submitted an email query. Reading all these comments doesn't fill me with hope. £500 worth of equipmenr not usable. Certainly will not be buying a playbar for the tv.
Not a good time to have bought shares if this gets around.
Userlevel 7
Badge +20
2nd Class Android user.oh no I don't use an iphone and I get this problem as well. Just submitted an email query. Reading all these comments doesn't fill me with hope. £500 worth of equipmenr not usable. Certainly will not be buying a playbar for the tv.
Not a good time to have bought shares if this gets around.


What is the source of the audio that's cutting out? Does this happen on all sources? Please reproduce the issue then submit a diagnostic report, reply with the confirmation number, and I'll look at it for you.
Userlevel 1
[quote=Jeff S]

What is the source of the audio that's cutting out? Does this happen on all sources? Please reproduce the issue then submit a diagnostic report, reply with the confirmation number, and I'll look at it for you.
Hi Jeff S, the source is my phone. I haven't noticed tracks being cut short on my computer or NAS.
I don't see what use reproducing the issue will do. I tried playing some tracks again last night and the second track didn't complete the third didn't play the player skipped to the 4th track.
I gave up trying to listen at that point.
So why submit a diagnostic report?
I have already raised an email query and I would like to continue down that route.
Though I don't hold out much hope of SONOS finding a fix for this, as this thread seems to demonstrate.
It happens everytime I use my android phone an LG 400M.
Thanks,
Martin Jachnik.
Diagnostic #270594215
Cannot turn auto lock off on iPhone as ha e exchange email for work.
Skipping started when lost sonos on lock screen. Please put back
Don’t apologize for the long post @Webspinur , I appreciate the help as I too have spent many frustrating hours on this problem. Touch wood, the no auto lock has been working but agree this is not the solution. Not a good experience for $750 in speakers. Definitely makes me think twice about getting the Playbar.
My sonos has recently started stopping, slowing and skpping songs when playing from Iiphone 8. i have read others with similar issue. I have rebooted everything, changed wireless channels to avoid interference. is there a solution in the offing. I only use the phone for playback. don't have an NAS or laptop. Have 2 connects and 2 play 1.s all over the house. Please help this is very annoying. Why all the updates that take us BACKWARD?

Moderator note: Merged from new topic.
Add me to list as well. Trying to play songs off of iPhone to Play One and Playbar. Songs play for a short time and then skip to the next one. This was not happening before the most recent update. Sent diagnostics. Confirmation number is 696590066.
Just bought a Play 3 about an hour ago, I was really excited to get a setup for my entire home and make a substantial investment. Got home and went to play some music on my iPhoneX and what do you know? Skips to the next song before the previous one finished, but only when my phone is locked! Quick Google search turned this topic up. Has Sonos even acknowledged this issue and said they’re working to fix it? Honestly I think I’m just going to return it. Way too much $ to spend to have problems right out the gate with such a basic setup.
Same problem here. My dad's setup is a Connect Amp to wifi

Using iPhone 8 on latest software

Diagnostic : 80674176
Having this same problem. Currently using Apples Airport Expresses in the house for WiFi. Can I get a Sonos tech to look at my system diagnostics?
Userlevel 7
Badge +21
You certainly can but for that to happen first you must submit a diagnostic from your system and then you must provide Sonos with the nature of the problem and the diagnostic number.

Sonos ignores diagnostics sent in, too little information in them to be useful without the user's input to go along with the internal data.
Userlevel 7
Badge +20
Hi everyone,

Today we released an update that has some bug fixes which should help with issues streaming music from iOS devices, among others. Please update your systems and test things out. You can read more about the update here.
Diagnostic #: 836518244
I have a Sonos One playing music from an iPhone 8. Auto-lock turned off and the problem still occurs. Just updated this morning (both devices), please advise or I will have to return this speaker.
Userlevel 7
Badge +20
Diagnostic #: 836518244
I have a Sonos One playing music from an iPhone 8. Auto-lock turned off and the problem still occurs. Just updated this morning (both devices), please advise or I will have to return this speaker.


Hi there,

Thanks for sending in the diagnostic report. I see that there is some wireless inteference causing communication issues with your speaker., leading to connection errors with Spotify This is likely due to the high number of wireless networks in close range. In particular, there's a wireless network coming from a HP printer nearby that's running on the same wireless channel as your own. If you have access to this printer, please try changing its wireless channel to 1 or 6 and see if that helps.

It may also help to look around your Sonos speaker and router for any other third party wireless devices that could be interfering. Common sources of interference include cordless phones, wireless security cameras, wireless baby monitors and wireless printers.
We have the same problem. Was fine up to about 5 months ago now won’t play any songs on our playlists to the end. Very very annoying. Diagnostic number 1876462644

Reply