Sonos app skips to next song before the current one has finished playing



Show first post

413 replies

Same issue here.... has anyone figured out how to resolve this? I have tried all the channels to switch things, upgraded everything, got a new router, increased the internet speeds, and more.

Diagnostics: 1574892644

And its continuing to happen as I type this....
Same problem Also sonos refusing to run diagnostic "at this time" just to add to the annoyance. I have no clue how to fix this
Same with me. Wow! I can’t believe that Sonos actually released a product that can’t do something fundamental like play a song. It beggars belief. I’m stunned by this. I’ve spent a long time resetting routers, assigning static ip addresses to the device, changing Wi-fi channels etc. but nothing works! Can someone tell me how I raise a diagnostic?
Userlevel 7
Badge +20
Same problem Also sonos refusing to run diagnostic "at this time" just to add to the annoyance. I have no clue how to fix this

Hi Fanatic,

If your system can't submit a diagnostic report it's being blocked from accessing the internet. Most of the time this is due to out of date network information from your router, or from other network conflicts. Please try rebooting your router and each Sonos unit to update the network information. Then, try submitting a diagnostic report again if any issues continue.
Userlevel 7
Badge +20
Same issue here.... has anyone figured out how to resolve this? I have tried all the channels to switch things, upgraded everything, got a new router, increased the internet speeds, and more.

Diagnostics: 1574892644

And its continuing to happen as I type this....


Thanks for sending in the diagnostic report. The communication between your Sonos components and network look okay. It looks like the connection between your iPhone and network is the weak spot. Are you getting any playback errors when playing from other sources, such as an online music service?

How far is your iPhone from your router when you are streaming? Are you leaving your phone unlocked when playing?
Userlevel 7
Badge +20
Hi folks,

When the Sonos system stops playing a track before it is over it is similar to when a video on YouTube, for example, stops to catch up to the buffer. There are many different reasons this could happen. Most of the time it is due to wireless interference causing the streaming audio to slow down too much and exceed the buffer. Please try the steps in this guide to help with these audio cut outs.

If that doesn't do the trick, send in a diagnostic report and reply here with the confirmation number and I'll take a look.
Same with me. Diagnostic no: 1560223129. Cheers!
Userlevel 7
Badge +20
Same with me. Diagnostic no: 1560223129. Cheers!

Your speaker is losing connection to your wireless access point from time to time. It may help to change your network's wireless channel from 11 to 1 or 6 to reduce interference. Also, it looks like you're streaming from your iOS device. Does this happen when your phone locks? Try playing while leaving your phone unlocked, does the issue return?
Same with me. Diagnostic no: 1560223129. Cheers!

Your speaker is losing connection to your wireless access point from time to time. It may help to change your network's wireless channel from 11 to 1 or 6 to reduce interference. Also, it looks like you're streaming from your iOS device. Does this happen when your phone locks? Try playing while leaving your phone unlocked, does the issue return?


I’ve tried changing the Wi-fi channel several times now, but this doesn’t help and the issue remains the same. The song plays for a few minutes and then skips to the next track about a minute from the end. So annoying! My IPhone always locks after a few seconds when songs are playing so yes, the issue happens when my phone is locked but I’m unaware of how to stop it locking. This is standard iOS design. Please advise a solution.
Userlevel 7
Badge +20
Same with me. Diagnostic no: 1560223129. Cheers!

Your speaker is losing connection to your wireless access point from time to time. It may help to change your network's wireless channel from 11 to 1 or 6 to reduce interference. Also, it looks like you're streaming from your iOS device. Does this happen when your phone locks? Try playing while leaving your phone unlocked, does the issue return?


I’ve tried changing the Wi-fi channel several times now, but this doesn’t help and the issue remains the same. The song plays for a few minutes and then skips to the next track about a minute from the end. So annoying! My IPhone always locks after a few seconds when songs are playing so yes, the issue happens when my phone is locked but I’m unaware of how to stop it locking. This is standard iOS design. Please advise a solution.


You can disable auto locking of your iPhone by going into settings, then Display & Brightness, then set your Auto Lock preference. Also, if you have other AirPlay devices on your network you can disable that service to work around this.

We're looking into this issue now, and will update you when we have more to share.
Having the same problem with Sonos only playing half a song or less. Confirmation # is 1880405373.
Userlevel 7
Badge +20
Having the same problem with Sonos only playing half a song or less. Confirmation # is 1880405373.

Hi timdan2,

It looks like you're playing from your iOS device. Is your device going into auto lock while playing? If so, do the audio issues happen at that point or before? You can disable auto locking of your iPhone by going into settings, then Display & Brightness, then set your Auto Lock preference. Also, if you have other AirPlay devices on your network you can disable that service to work around this.
Can you check mine? 43425039 First 3 songs skipped and then 4th song played all the way thru.
I just upgrade to google wifi, I have a play 5 within a few feet of an access point and it still skips songs, my computer is on the same network, it skips songs also. Why doesn't everyone have this issue? I have a play1 ,3 and 5. Any fixes? Please sonos, please please fix this. Diag #1246880644
I’m having the same issue as everyone else. Skipping before the songs over to the next song. It was fine for years until the Sonos updates about sometime this year. One of your dev must have screwed up some of the WiFi or maybe buffering code and everyone is having issues now. We also have tried everything from resetting router, changing channels, and I even did a fully factory reset of the Sonos 1 to start from scratch but it still does it. Many times it will play the first song fully but when it gets to the 2nd song, it will skip before it’s finished to the next song and keeps doing that over and over.

Diagnostic id# 154518478
Sorry. Forgot to say we tried what was in your recommendation https://support.sonos.com/s/article/305#mobiledevice and it still does it. Even changing the audio compression to compressed only didn’t work either. It still skips to the next song before it’s over.
I’m having the same issue as everyone else. Skipping before the songs over to the next song. It was fine for years until the Sonos updates about sometime this year. One of your dev must have screwed up some of the WiFi or maybe buffering code and everyone is having issues now. We also have tried everything from resetting router, changing channels, and I even did a fully factory reset of the Sonos 1 to start from scratch but it still does it. Many times it will play the first song fully but when it gets to the 2nd song, it will skip before it’s finished to the next song and keeps doing that over and over.

Diagnostic id# 154518478


Update: upon further testing, we noticed it’s 99% of time skipping to the next song when using the iPhone app and the phone lock screen turns on or goes to sleep. If you keep the iPhone and Sonos app open at all time and screen active, it does not skip.
Diagnositic report 1584112634. Same as everyone else on this thread, jumping to next track continually. Tried reserved IP addresses but to no avail. Hoping diagnostics report will be able to help someone provide a solution.

Thanks.
Userlevel 1
After sitting back in this thread for a couple months while I spent hours upon hours going through this thread with a fine tooth comb, I am now adding my voice to the multitude of unhappy Sonos customers.

I have this problem too. ?

My Sonos system (with four Play 1 speakers) ran flawlessly for a couple years until just like everyone else, my Sonos system started cutting off songs and randomly jumping to others in the playlist. This mind numbing problem started after the latest round of updates that hit the Sonos app earlier this year.

I have spent many MANY hours on this frustrating problem, reading this thread from beginning to end, trying EVERY suggestion given as well as reading all help links given and absolutely nothing suggested has worked.

The answer for all of us is most definitely NOT changing to a new channel (I tried that) or making sure that they are close enough (all 4 speakers are within eye shot of each other), nor is it any other suggestion that I’ve painstakingly tried, including resetting the system from scratch like everyone else is saying. I even hard wired one of the speakers to the router instead of using wireless for it, making sure it was at least 3ft away from the router. That didn’t work either, it still skipped all over the place.

This problem is NOT affecting just an isolated few who just need a tweak with their settings or channels. This is THOUSANDS of us customers having this headache. All one has to do is search online regarding this Sonos problem and you can see Sonos is getting dragged through the mud not coming up with a workable solution on this.

BUT, FOUND A POSSIBLE SHORT TERM FIX which is actually Sonos’ latest suggestion in this thread:

Having this issue with Sonos means that I simply have stopped playing music around the house but today I got dragged back to this issue getting totally frustrated as once again our Sonos system started skipping mid song etc when i attempted to get 10 good minutes out of it while doing dishes. With still no clue as to what in the actual heck is going on and how to fix it I came back here to this thread to see the latest suggestion by Sonos Reps saying to try TURNING OFF screen AUTO-LOCK. So I started testing.

It would seem the TEMPORARY answer (for an Apple iphone user like me) is to TURN OFF AUTO-LOCK under “Display & Brightness” in the iPhone “Settings”.

And it works. So far. Whether it’s sticks and keeps working is another matter, but after running several playlists for a couple hours and no skipping or issues I’m guessing this is the short term fix. I’ll report back with another not so long post if it starts skipping again.

In the meantime DEAR SONOS TEAM: asking us to TURN OFF our “AUTO-LOCK” Apple screen time out feature and just leave our screens to just stay on IS NOT THE ANSWER. Something in your Sonos App has changed to cause this. Can you PLEASE sort this out so that we can keep our screen time out feature left on? That would be GREATLY appreciated.

And of course I will report back if the problem starts up again. Though I hope it doesn’t, obviously.

Sorry for the long post but after spending all these hours on this I had a lot to share, including frustration. ?
Userlevel 1
Yet another "Me too" post.

Have been playing directly from iphone for years without problem. This is a new annoyance.

I still seem to be getting the problem with auto-lock set to never on my phone.
Userlevel 1
Yet another "Me too" post.

Have been playing directly from iphone for years without problem. This is a new annoyance.

I still seem to be getting the problem with auto-lock set to never on my phone.


That is worrying. So yours still skips around even with your AUTO-LOCK set to “never”?? ? I guess it’s just a matter of time then before mine does that as well because I’ve set mine to AUTO-LOCK the other day as I mentioned above and so far I’m good ?? but your report doesn’t fill me with any hope.

This whole experience is quite disheartening after spending so much already on getting the 4 speakers. I was planning on spending another £1500 or so including getting the Sonos Playbase & Sub plus other items. But that is not going to happen until this issue gets sorted once and for all. There is no point in buying anything else till that happens.
Userlevel 1
Yes. More testing last night and it doesn’t seem any more reliable with auto lock never. I hope you have more success.

I do have some sympathy with Sonos. I have a clever car that can show messages on the dashboard but that stopped working a few iOS upgrades ago. Still works with android. So it’s possibly due to Apple moving the goalposts.

But of course that doesn’t help us. The direct play facility is about all I use so this really hurts.
Userlevel 1
Yes. More testing last night and it doesn’t seem any more reliable with auto lock never. I hope you have more success.

I do have some sympathy with Sonos. I have a clever car that can show messages on the dashboard but that stopped working a few iOS upgrades ago. Still works with android. So it’s possibly due to Apple moving the goalposts.

But of course that doesn’t help us. The direct play facility is about all I use so this really hurts.


I’m about ready to give up and sell these Sonos paperweights and move on myself. I haven’t seen a single person come back and say “Yay! Sonos helped me fix it! It don’t skip anymore!” Not a single person. And this has been going on for quite some time apparently. I don’t think Sonos has any clue or if they did they would put out some kind of an announcement saying something like “we hear you, we are working toward a fix, we understand that this is a problem on our end and NOT on the users end so bare with us while we sort this out.” If we heard that posted by Sonos I MIGHT be inclined to wait it out, but with complete silence on this except to suggest the same “fixes” that don’t work over and over again to each new person who complains, I suspect they just don’t know what to do. And that stinks. These things are not cheap. And now I’ve got to go out and get something that actually works. Not happy in the slightest.
Same issue - Diagnostic report 1652874966

From happening occasionally, now a song will play for maximum of 2 minutes then skip to the next on the playlist.

Simply infuriating!

Stephen Weaver
Userlevel 7
Badge +20
Yes. More testing last night and it doesn’t seem any more reliable with auto lock never. I hope you have more success.

I do have some sympathy with Sonos. I have a clever car that can show messages on the dashboard but that stopped working a few iOS upgrades ago. Still works with android. So it’s possibly due to Apple moving the goalposts.

But of course that doesn’t help us. The direct play facility is about all I use so this really hurts.


Hi there,

If disabling auto lock doesn't do the trick, and you've also tried disabling AirPlay on non-Sonos devices, your issue is likely not related to the main topic. There are other things which could cause audio skipping, the most likely of which is wireless interference. Please submit a diagnostic report after this happens and reply with the confirmation number, I'll take a look.

Reply