Sonos app skips to next song before songs are done

  • 16 November 2018
  • 7 replies
  • 478 views

Badge
I have two refurbished Sonos Play 1s connected as stereo. They were working great for a few weeks but now whenever I play from my library the songs skip to the next song before the songs are over. It fades out on one song and then the next song begins. Minutes are still left in the playing song when this happens. What can I do?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

See here. Setting up a Sonos Music Library would make the issue go away. If you don't own a PC or Mac, then you might consider purchasing a NAS.
Badge
See here. Setting up a Sonos Music Library would make the issue go away. If you don't own a PC or Mac, then you might consider purchasing a NAS.

I set up a NAS using my Apple Time Capsule and it was even worse than my phone. I want to use my phone. Are you saying Sonos speakers cannot work properly with phones?
Userlevel 7
Badge +20
See here. Setting up a Sonos Music Library would make the issue go away. If you don't own a PC or Mac, then you might consider purchasing a NAS.

I set up a NAS using my Apple Time Capsule and it was even worse than my phone. I want to use my phone. Are you saying Sonos speakers cannot work properly with phones?


We're investigating an issue that causes playback errors when streaming from the storage on iOS devices while there are non-Sonos AirPlay devices on your network and your phone goes to sleep or into auto lock. While we're investigating this, you can get streaming working by disabling AirPlay on any non-Sonos devices on your network, or by disabling auto lock in your iOS device's settings menu under display and brightness, preventing your iOS device from going to sleep.

For this reason, the suggestion of moving your library off your phone and onto a computer or NAS drive will bypass the streaming errors entirely.
Badge
See here. Setting up a Sonos Music Library would make the issue go away. If you don't own a PC or Mac, then you might consider purchasing a NAS.

I set up a NAS using my Apple Time Capsule and it was even worse than my phone. I want to use my phone. Are you saying Sonos speakers cannot work properly with phones?


We're investigating an issue that causes playback errors when streaming from the storage on iOS devices while there are non-Sonos AirPlay devices on your network and your phone goes to sleep or into auto lock. While we're investigating this, you can get streaming working by disabling AirPlay on any non-Sonos devices on your network, or by disabling auto lock in your iOS device's settings menu under display and brightness, preventing your iOS device from going to sleep.

For this reason, the suggestion of moving your library off your phone and onto a computer or NAS drive will bypass the streaming errors entirely.


I have an Android phone. So there is no AirPlay enabled and I don't believe my Android device has an auto-lock feature. Have you identified the same issue with Android?
Userlevel 7
Badge +20
See here. Setting up a Sonos Music Library would make the issue go away. If you don't own a PC or Mac, then you might consider purchasing a NAS.

I set up a NAS using my Apple Time Capsule and it was even worse than my phone. I want to use my phone. Are you saying Sonos speakers cannot work properly with phones?


We're investigating an issue that causes playback errors when streaming from the storage on iOS devices while there are non-Sonos AirPlay devices on your network and your phone goes to sleep or into auto lock. While we're investigating this, you can get streaming working by disabling AirPlay on any non-Sonos devices on your network, or by disabling auto lock in your iOS device's settings menu under display and brightness, preventing your iOS device from going to sleep.

For this reason, the suggestion of moving your library off your phone and onto a computer or NAS drive will bypass the streaming errors entirely.


I have an Android phone. So there is no AirPlay enabled and I don't believe my Android device has an auto-lock feature. Have you identified the same issue with Android?


If you're using an Android phone the issue is likely wireless interference or poor network connections. Please see this guide for help in troubleshooting audio drops.

If the steps in that guide don't help, please submit a diagnostic report and reply with the confirmation number.
I have an Android phone. So there is no AirPlay enabled and I don't believe my Android device has an auto-lock feature. Have you identified the same issue with Android?
Turn all power saving options off. When the phone goes into sleep mode, then the "WiFi energy saving mode" may be activated - as a result the connection to the Play:1s drops.
Badge
I was able to fix the problem by doing a clear cache, clear storage, uninstall, reinstall of the Sonos app. It now works as it should. Thanks all.