Question

Sonos app saying "Unable to connect to Sonos"


Hello everyone - help please; I have tried everything I know but reached a dead end!

 

I have a Sonos Connect Amp that is connected wirelessly to our BT router in the next room. The router isn't new, been moved or any passwords changed; likewise for the amp.

 

To play music I use an iPad fixed in one location [this iPad connects fine to the amp and can play music using the S1 app]. However, my iPhone X [running latest software] using S1 app has just suddenly, for no apparent reason, started saying “unable to connect to Sonos. Learn More”. I have tried my work iPhone as well in case it was just my personal mobile acting out but that won't connect either and I get the same message.

I have tried:

  1. Resyncing the phone by pressing the mute and + button on the amp. Going to the app and connect to existing system. I then get a popup on the app saying “connected to Sonos system. This Sonos app is now connected to your Sonos system”. However, when I click done it takes me straight to the screen asking me to setup a new Sonos system or connected to an existing system”… I then go round in circles.
  2. Unplugging the amp and connecting it directly to the router via ethernet cable and doing that whole process… but no joy!
  3. Resetting the app
  4. Uninstalling the app
  5. Turning the router off, unplugging the amp, turning the router back on and then wait and then plug the amp back in.
  6. Turning phone off and on.
  7. Checked I am running latest app version.

I think I have about exhausted everything so if anyone has any suggestions please let me know.

Many thanks


3 replies

Try disabling “Private address” on the IPhone:

https://support.apple.com/en-us/HT211227

Also ensure app permissions have been granted:

https://support.sonos.com/s/article/3092?language=en_US

ClausN I am so grateful. Turning off private address worked straight away! I have music in my life again - thank you!!

ClausN - another issue has now occurred. After a few hours both mobile devices now return to saying “unable to connect to Sonos. Learn More”… but the iPad still works. Nothing has changed with the router but if I turn it off and on the iPhone then picks up the Sonos Amp again. Baffling! 
 

I’ve  checked and all the permissions seem ok. Maybe something to do with the latest S1 app update? Any help would be greatly appreciated. Thanks 

Reply