Sonos App Locks up on Android Since September 2021

  • 19 November 2021
  • 22 replies
  • 230 views

Badge

My sonos apps on all (5) of my phones has stopped working since the September update to Sonos in 2021.   
 

It does, however, work on the PC and on an older, unsupported version of android on an old tablet.

 

I have contacted support (5) times and they escalate to tier two, and that is where the support ends.  They promise they will call or email me but… well, its almost Thanksgiving.

 

Oddly, the widget to control a single speaker will work from the phones to fast forward and pause and unpause music, but that is it.

After looking at the last 60 scathing reviews of the app I can see I am not alone despite what technical support has been telling me.

 

So, what gives, is Sonos just done as a company, are they actively working on correcting this and I can keep my system or do I just need to abandon it and move on?  

Please advise.

FYI, I have taken the following steps before its recommended:

  1.  factory reset all speakers
  2. uninstall/reinstall the app
  3. everything is updated
  4. hardwiring speakers
  5. running a single speaker

Thanks in advance,

Kirk


22 replies

Which model phone are you using? Which version of Android? What are the error messages, if any?

For the record, I’m not having issues on my Samsung Galaxy S20 FE 5G running Android 11.

I also have no problem with three Android phones.  If even a vanishingly small percentage of Android users were having this problem the forum website would have crashed by now under the weight of complaints.  So this is clearly not a general problem that Sonos need to ‘fix’.

But that does not help you resolve your issue, which is clearly significant for you.  If you answer @buzz ‘s questions then it may be that someone on here can help.

Badge

No longer work after Sonos2 app updated in September, Version 13.3

Moto G7 running Android v 10

Pixel 4 running Android v 12

Pixel 3a running Android v 11

Galaxy A10e running Android v 11

Moto G Power running Android v 10

LG v35 running Android v 11

Galaxy Tab A7 Running Android v 11 (tablet)

 

Still working

Galaxy Tab S2 running Android v 7 (tablet)

Windows based Sonos , PC app v 13.4 (windows 10 and 10 Pro)

Widgets for Sonos on any phone.  The widget only allows you to pause/play and skip to the next song

 

 

The system has been working perfectly fine from May until September with no changes except Sonos Updates and Android updates.  No network changes were made and no speaker changes were made.

 

As for error messages, it just says Sonos has stopped responding  (wait, close, send feedback).  Essentially what happens is after 2-3 seconds, the app just stops responding.  You can uninstall, reinstall, etc.  Once you connect to the system it locks up after 2-3 seconds of time.

I have rebuilt the system (2) times already, one speaker at a time (factory reset, etc) and it repeatedly happens.

Hope that helps.

Thanks. Please give some info about your router and network.  Any mesh network?  Extenders or access points?  Dual band.

Do you have any form of VPN installed on the phones?

Do you have a Sonos device wired to your network or are you fully WiFi?

Is your system on v13.3 as well as the apps?  (It would be best to get apps and system on to the latest 13.4 now anyway)

Badge

Netgear Orbi Mesh.  2 nodes.  I had shut them down previously with tech support and it did not correct the issue.

Yes, broadcasting both bands 2.4 and 5ghz 

No VPN

I had hardwired some of my speakers per tech support request and it did not correct the issue.

Sorry, I added an edit regarding the version the system is on as opposed to the apps.  Could you post a screenshot of the ‘About my Sonos System’ screen from your PC controller please?

Badge

Thanks for your help.

Just as an FYI, the Netgear Orbi can not separate the 2.4 from 5 ghz channels since they took away telnet a while back.  I suspect you may want me to try separating them but that is unfortunately no longer possible.

I can reduce the 5ghz power output to like 25% but that is not a perfect diagnostic tool.

 

Please let me know if you need to see the rest of the Sonos Devices from this list.

Below is a second PC also running the Sonos app.

 

Badge

Also, I do not want to throw you off but the tablet that does work is also connecting via 5 ghz as are all of the phones.

All Sonos products, including the Move, are on 2.4 ghz

I can move them all to wired if need be, would just take a while to set up all of the cables and move them.  Should be enough room on the network switch.

 

Thanks for info.  A few more questions I’m afraid…...

  1. Do the Orbis connect to an ISP router?  If so, how?
  2. Is that router broadcasting a SSID in addition to that of the Orbis?
  3. What type of switch is it and how does it connect?
  4. Do the mobile phones on which the controllers are currently failing have IP addresses in the range 192.168.1.XXX? 
Badge

No problem asking more info here:

 

  1.  The gateway for my ISP has the wifi shut off and is set to blind passthrough
  2. No, the gateway modem has the wifi turned off. 
  3. The switch is a D-Link unmanaged 24 port switch.  The DGS-1024D in case it matters.  It is plugged directly into the orbi on port 1 and all other connections are hooked up to the switch.
  4. All phones are on the same subnet as you described.  I have tried reserving and not reserving their IPs but for simplicity I switched them and all sonos speakers to DHCP

 

Apologies for the delay, I am having to spend a little more time doing my dayjob but I do work from home, which helps.

You have clearly approached the troubleshooting methodically and knowledgeably.

There are a couple of things (at least!) that are really baffling me.  The main one is the nature of the failure.  The app freezing is very odd.  If the problem were to do with different subnets of wifi bands then I would expect an error message saying ‘cannot find Sonos system’ or ‘cannot connect’.  I would not expect the app to quietly refuse to cooperate.

The other baffling thing is that a controller running Android 7 is OK.  I thought Android 7 was not even partially supported on S2, but maybe I’m wrong (I will check)

Badge

You are correct, Android 7 says on it “not supported” but it works flawlessly.

I suspect this to be an app specific problem while it polls/scrapes the individual speakers but that is just a guess.

I can try a new subnet or alternate wifi (specifically one with only a 2.4 ghz band) as a test but it would be a shame to have to get a different wifi system just to accomodate a glitch.

What puzzles me is that this happened the moment that patch in September hit me.  Prior to that I had zero issues.

I am 99% certain if I could roll back the app and use it everything would work.


The only other troubleshooting I can think of to test is this:

  1.  Try a different wifi router to test.
  2. Remove all speakers and create a new Sonos system adding 1 speaker at a time every few days in case just one of them has a botched update or something on it (say, caused from packet loss).

I truly appreciate your time investment on this and I apologize for starting out harsh but I felt abandoned by the Sonos support team--and they are not all created equal.  I did reach an individual and I wish I recalled his name but he provided stellar support and did not suggest I just go out and purchase all brand new speakers.

I would love an error of some kind but I can try and monitor if it has a memory bleed or something but that bit of information won’t let me fix it but it would give me another clue what is going on.

Please would you try one further thing? Please connect just one Sonos speaker to the switch.. Uninstall the app on one of the phones then re download from Play Store and connect to existing system.

Badge

Can do.  By the way, do you care which speaker I use?  I did this in the past and it worked until I exceeded 4 speakers.  I will keep it to just one this time.

Also, after uninstalling app I “forget” the local network and reconnect to it after reinstalling the Sonos app just to limit the variables.

As another precaution I will unplug all of the other speakers prior to making a system of (1) speaker. 

I may not get to it until Saturday (due to work) but I will get it done.

 

It wouldn't do any harm to dial down the power on the 5GHz band as you suggested. Then connect phone while in another room from the router. (In theory this shouldn't make any difference.  But none of this makes sense!)

Badge

I have a sonos system up and running with just (1) speaker.  It works.  I can do what I did the last two times, and slowly build it back 1 speaker at a time.  But I will wait so I do not throw off your thinking/diagnosing.

After I get enough speakers on it locks up.  

As a guess, perhaps is the 5ghz cross-talk to each other that causes a problem with too many of them that causes the app to lock up.  But why would it have only done it after a patch.

So current position is one wired speaker controlled by one device / app? If so.…

Stick with the one app. Leave the first speaker wired. Power up additional speakers one at a time, wirelessly.  After each one is powered on, check in About My System. The speaker should have WM=0 next to it not WM=1.

Hopefully all speakers will add  and work. If so, then on each of your other phones uninstall the app, reinstall and connect to existing system. 

Let us know how it goes.

Further note. If you have any Move or Roam speakers, they will always have WM=1.

Badge

Thanks for the advice.  I have rebuilt the system as you suggested.

  1.  Started with the very first speaker hardwired.   All future speakers were added wirelessly
  2. All speakers are on WM:0  with the exception (thanks for mentioning it) the Move which is WM:1
  3. I ran a test of having all (10) speakers running a different station for 15 minute which scrolling around in the app.  
  4. I currently only have (1) phone and (1) pc connected to the new system to isolate any issues.  The current phone connected is one that had problems in the past.

    I suspect the next step would be to add other phones, 1 at a time and see if everything works unless you have a different attack plan in mind. 

That is good news. In fact the last step I have already suggested is to try adding the apps on your other phones to the system. Out of an excess of caution I have suggested uninstalling the app then reinstalling it and connecting to existing system. 

At the risk of jinxing things, I cannot think of any way in which adding further controllers can damage what you have already. The apps are just remote controls for the system and adding one should have no impact on the system itself.

But let's try it and see.

Badge

Just an update here.  I had a stable system for 2-3 days.   Then, every once in a while the app would lock up.  However, this time after dumping the cache and stored info from the app I could reconnect after a few minutes.  This only happened on the phones.

The PC and older android tablet never experienced this issue.

The other issue that has arisen is when you go to load the list of speakers (the middle button on the phone app) it would be blank for 10-50 seconds and then populate.  This is a new behavior---as if it was repopulating the speakers.  Sometimes a few of the speakers will drop off but they will continue to play any music they were streaming until you physically hit the pause button.

 

It seems that what is happening is the speakers do not populate for the app sometimes but they have not lost their connection to the internet or streaming service that began.

Despite the issues I am experiencing this is still a more stable system than I have had in 2 months so thank you for your help.  I think what I will try next is to build a system with only hardwired speakers (not possible for all locations) and see if the problems completely go away.

In summary, I am better off now than I was 11 days ago.  Thanks again.  I will update this thread once I have collected more relevant data.

I am pleased that there has been some progress. although it is clearly not how it should be.

The app is just a remote control and just shows you what is there in the system.  So the apps are clearly having problems at times getting that info over the network.

I think it would be worth your running a system diagnostic immediately after one of these events, using the phone app affected, then contacting Sonos Support with the confirmation number.  At least the apps are now working sufficiently for this to be possible.

Reply