Sonos App Hangs and Crashes Won't Control Device Over Apple Time Capsule Router

Very unhappy with the Sonos Play:1 that I have tried to set up repeatedly. I am using an iPad Air 2 over a Time Capsule router. I installed the app and set up seemed to work until I tried to actually play music over the device. The app crashed. When I restart the app it hangs saying it's connecting and of course it doesn't. I reinstalled the app and set everything up again. It worked until again crashing when I went to actually play music.

A post online said that if you switched the Time Capsule from 5.0/2.4GHz to just 2.4GHz that would solve the problem. I tried it and that did not work for me. So basically the Sonos is not working and the app is useless as it either crashes or works but does not present any options for a solution. The help line is not available today. I'm more than a little frustrated, does anyone have any ideas? My Sonos doesn't work and I don't seem to have any options to make it work.

5 replies

Does the iPad have a cellular connection too? If so try disabling "Wi-Fi Assist".
ratty wrote:

Does the iPad have a cellular connection too? If so try disabling "Wi-Fi Assist".

No it's WiFi only.
Hmm, that's odd, as it's exactly the same setup I used to have (before my Time Capsule's wifi card went south)

Have you tried connecting the speaker directly to the Time Capsule with an ethernet cable for the setup process? You can disconnect it once it's set up properly. The only reason I could think of that the app would crash is that it can't find a Sonos system to connect to, although that's suspect, as mine on my iPad Air 2 just tells me it can't find a system to connect to.

One other thing I'd recommend. Delete the app from the iPad. Do a hard reboot the iPad, and then go back to the store and download the app again. There's a minor possibility that this will help.
Thanks for the replies, guys. I think the problem can be traced back to Minecraft. I hate that app. My kids play it all the time and it seems to take over / destroy our iPad. The real solution to this problem is probably to delete that app! I factory reset the Sonos and rebooted my iPad and reinstalled everything and we're good now. Happy listening, all.
You aren't the only one. It crashes each time there is an update needed.


    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)