Question

Sonos app doesn't connect to second (bridged) router

  • 4 December 2016
  • 6 replies
  • 289 views

Here is the situation. I have 2 Connect:Amps and 1 Connect. All are physically located in my living room. The amps drive built in speakers in my master bedroom and rooftop. The connect powers living room speakers (through receiver). My primary router (Google OnHub) is also in the living room. Everything works great when I (and my iPhone) are physically in the living room. However, my Wi-Fi was very weak in the bedroom (furthest location from the router) so I bought another OnHub router, put it in bridge mode, and plugged it into my home Ethernet network. All Wi-Fi enabled devices work fine and easily switch between routers, HOWEVER if I'm in my bedroom and my phone is connected to the bridged router, the Sonos app cannot connect to my wireless network (even tho my phone is on my Wi-Fi network). Is there anything I can do to my networked routers or Sonos to fix this? Do I need to buy new equipment to ensure that Wi-Fi and Sonos is usable from all corners of my house? Thanks

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

When in your Living Room, check the iPhone's IP address. Then do the same when it's attached to the bedroom OnHub. Do the first three numbers match between the two locations?

How is the bedroom OnHub connected back to the main router? Is it in fact a run of Ethernet cable?
Hi Ratty, I will check IP addresses when I get home. But to answer your other question, my modem is located in a central room in my house. Router also used to be there, but many rooms did not get Wi-Fi coverage. So, I went out and bought Netgear Power line Network adapters. My modem plugs into one power line adapter in the central bedroom and then I plug the routers into other power line adapters in the living room and bedroom. This was my only option because I cannot move my modem to another room.
I've removed my earlier reply about Netgear Powerline adapters having questionable compatibility with Sonos, because I've just noticed something you said:
My modem plugs into one power line adapter in the central bedroom and then I plug the routers into other power line adapters in the living room and bedroom.

If this is true, your Powerline is on the WAN side of your main router. If the bedroom router is in bridge mode I'm not entirely sure what kind of addresses it will be assigning. But either way the devices in the living room which are hung off the router there will be uncontactable via the Powerline.
Ok, thanks for what if I get rid of the powerline adapters and onhub routers all together and get a multiple access point solution like Google Wifi or Eero?
Ok, thanks for the info. Wish I knew that before buying the Netgear. What if I get rid of the powerline adapters and onhub routers all together and get a multiple access point solution like Google Wifi or Eero?
Eero can evidently be made to work with Sonos.

However, assuming your 'modem' is indeed a modem (not a router) you could probably do what you want by:
- moving the living room router to the central room and wiring its WAN port to the modem
- wiring that router's LAN port to the Powerline adapter
- getting a new OnHub for the living room and putting it into bridge mode

You say the other bedroom OnHub is already in bridge mode.

At least that would put everything on the same IP subnet. At the moment it doesn't appear to be.

There have been reports of problems with Netgear Powerline adapters but IIRC they were in situations where Sonos units were wired together via the Powerline.

----

Before making another OnHub purchase you could in fact temporarily move the bridged bedroom OnHub to the living room, connect Sonos to it, and check that your phone can see the living room Sonos when the phone's attached to the router OnHub in the central room.

That would at least test out the Powerline connection, plus the use of the OnHub in bridge mode.