Sonos App crashes daily

  • 13 October 2021
  • 5 replies
  • 73 views

Every day, multiple times a day, our Sonos app crashes.

We have three sonos play 1 speakers.  We have WiFi, it’s a small office, 1600 sq. ft.

We have tried Spotify, Pandora, and the awful Sonos music.  

Every day, crash, freeze, not working.  Often times the pop up “Pandora is offline” or “Spotify is offline” appears, even though we have paid subscriptions, no other users, it’s just garbage. 

 

No one at Sonos can help.  We’ve has our IT service adjust the router several times.  We’ve done all the things.  Nothing works.  This app has been tried on multiple devices, anndroid, apple, desktop and the result is the same.  Crash crash and more crash.   

 

I’m throwing my hands up.  The speakers are great, the software is trash. 


5 replies

Userlevel 7

What model router are you using in the office? Are there a lot of WiFi networks around you? Have you tried unplugging all of your speakers from power for a couple of minutes and rebooting your router? You might also try deleting and re-installing the Sonos app on your devices.

Netgear80 router.

We deleted and reinstalled the software on multiple machines as you say.  This is a dental office so we have some fairly serious firewalls and protection.  Everyone seems to think it’s a setting on the router.  But I’m super annoyed that we can’t figure it out.  Sonos has been no help whatsoever.  They are uselss

Userlevel 7

Is it possible to wire one of the speakers directly to the router with an ethernet cable? This will create SonosNet, a dedicated mesh network for just your Sonos speakers. If this isn’t possible, you might consider getting a Sonos Boost which pretty much does the same thing. You might also try disabling QoS on the router.

I can’t remember the last time I saw a Sonos App crash, personally speaking, but if putting the speakers over to SonosNet, as suggested by @GuitarSuperstar, then ensure you set its channel via the App, so it is at least 5+ channels away from your router channel. Ideally ‘fix’ the router’s 2.4Ghz channel to either 1, 6 or 11 too, as they are non-overlapping.

QOS and Airtime Fairness on the router are best set ‘disabled’ and/or if using WiFi/wired network, then ensure any managed network provides support for the Spanning Tree Protocol (See link for additional info).

Are there any error messages?

Reply