Answered

Sonos and Google WiFi

  • 8 January 2018
  • 43 replies
  • 59515 views

Having an issue with google and Sonos.
First on the network I have several devices connected (hardwired) to the router. I have 2 Play 1's and a Connect hooked up. The Connect is hardwired to the router.
I turned off the WiFi on the router and connected the google WiFi mesh with 3 stations. All of my other devices connect fine.
The only way I can get the Sonos devices to work is to hard wire one Sonos into the google WiFi eventually all the systems connected.

Now the pone and computer running Sonos cannot connect to the Sonos network but my tablet can? Can someone help?
icon

Best answer by John B 12 January 2018, 00:27

The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

43 replies

The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.
Userlevel 1
John B and edmountain...
Tried your tips once more.. deactivated both wireless bands and put the existing GET router in bridge mode FIRST...
Followed by cabel from one of my connect boxes to Google WIFI and changed wifi settings to GW.
Since then; Sonos and GW works, (as edmontain so correctly put it) perfectly together. Thanks from Norway!!!
The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.


hi John,
Well Explained! Planning on my router upgrade, so please humor me!
So in this scenario if I am using sonos net and android controller, I have to connect to a separate sonos net network and not google mesh wifi network?
First, I would now recommend leaving DHCP on, on the original router, but that goes alongside turning off the wireless and wiring only the primary Google puck.

As far as the controller device is concerned, no, it can connect to the Google wifi network. You have the option with an Android device to connect to SonosNet, but this is not a requirement. The controller can talk to a Google puck, which can pass data to the primary Google puck (if it isn't the primary anyway) which passes the data over Ethernet to the wired Sonos device, and thereafter via SonosNet to any wireless Sonos devices. It isn't fundamentally different from how controllers talk to Sonos devices when the wifi is a 'traditional' type.

I would generally recommend using SonosNet mode rather than wifi only, although people have got it to work either way.
Userlevel 1
BIG challenge when introducing Google wifi to my established 12 Sonos Components over 3 floors.
After one intensive week trying to Connect Sonos to to GW, reading pretty much everything on Sonos community related to the topic, -
I resign, - reset all sonos products to factory settings,
establish a Brand new sonos account,
and reconnect all my sonos components to my «old» wireless network ( Get/ Norway).
Seems GW works well with all other devices with no connection to music streaming.
Returning GW products to my supplier and try Asus Mash.

Br
Halvor - Oslo
In Settings/About My Sonos System. WM:0 means SonosNet (or wired), otherwise it's WiFi.

If a system is intended to be used in SonosNet mode, any stored WiFi credentials should be removed to avoid instability.
After a week the large system at home (15 Sonos devices) seems to be stable after I reset everything.
Factory reset the whole system? FWIW you should never need to do this, unless of course you're selling it. I have a larger system, 10+ years old, that's never been reset in its entirety.

In Settings/About My Sonos System - what does the OTP setting indicate? Does that mean it is wired?
One Time Programmable
Ignore it. It's just a microcode version on some controller or other. Some devices don't show anything in About, some show "OTP:" with a blank.

As for determining remotely whether a unit is wired, there are one or two arcane methods but the most accessible is probably the Network Matrix at http://x.x.x.x:1400/support/review, where x.x.x.x is the IP of any player (not a BOOST or BRIDGE). The coloured cells in the matrix body indicate active wireless tunnels, so wired connections can be inferred therefrom.
Hi. Lots of people have made this work, but you will have a much better chance if you wire one of your speakers to a Google puck so that SonosNet is running.
Hi. Lots of people have made this work, but you will have a much better chance if you wire one of your speakers to a Google puck so that SonosNet is running.

Thanks.

I've got it working now, but had to factory reset every Sonos device, and build my rooms anew.

Transitioning the Sonos setup from a normal Wifi setup to the Google mesh setup was definitely not smooth. I was essentially stuck in limbo.
Notwithstanding rlj61's comments I ought to just point out that it should never be necessary to factory reset everything, simply to change the network or SSID to which a Sonos system is connected. Power all the units off, wire one Sonos device, power them up again. A new SSID can then be configured into the system if required.

As for connecting a Sonos system in 'wireless' mode to a meshed WiFi over which one has no control in terms of channel allocations, it's simply not advisable. Sonos' recommendation is that where there are multiple access points they should all use the same channel, in order to optimise interconnection in groups (and stereo pairs, a special kind of group). Where different Sonos units 'home' onto different access points, on different channels, it can cause problems, as various reports here will confirm.
Google Wifi 3 node mesh and new Sonos owner here. The issue I am having is similar. I have discovered that if my phone is connected to a different access point (same SSID) in the mesh than the Sonos One speakers the app "can't find" my speakers. If we are all on the same AP its all good. Really sucks as this limits their usefulness and I may have to return the speakers

I seem to have the same issue here.

My Sonos setup broke down when I switched the Wifi network of the system to the Google Wifi mesh. I have two access points, with same SSID (network name and password), but the speakers are split across the two access points. Other speakers I have lost entirely. I can only control the speakers connected to the Google Wifi AP that my phone is actually connected to.

Has anybody verifiably set up a multi room Sonos system using multiple Google Wifi access points?

Worse, it now seems quite impossible to get back to the old Wifi network. No way of hardwiring a Sonos unit allows me to use Settings -> Advanced -> Wifi Setup.
Badge
This thread was extremely helpful for me. My setup is Spectrum modem -> Google Wifi -> Netgear switch -> Sonos Connect (ZP90). I then have a Sonos Connect:Amp (ZP100) and Play:1 in separate rooms. My previous setup had the ZP90 hardwired and the other two players on the wifi (not SonosNet). I was having problems discovering the two wireless players which I figured was due to them being on the Wifi. I initially tried removing the wifi network settings from the Sonos app but it took me several attempts to do this, and finally succeeded by wiring the Play:1 to the switch and then removing the wifi setting. I had to factory reset the ZP90 and ZP100 to get them onto SonosNet but eventually all three were functioning without the wifi connection (confirmed by seeing WM:0 in the About page for each player). One other thing I did which I'm not sure helped or not, was to ring Spectrum and ask them to disable Wifi on my modem.

Finally with this setup, I was able to do what I'd originally intended - discover all of my speakers in the Harmony Hub app so I could set up an activity to turn on my Pioneer Amp connected to the ZP90 and play music across all my speakers through my Echo using the command "Alexa, turn on Sonos". Only took a couple of evenings to get to this point.
After adding a Google mesh network, I too struggled getting my Sonos Play:5 speakers back working on my network. Like tickletikkel, the path of success was to start over. I factory reset the two speakers and from my android app, had to remove my current sonos network. That last step was key. I didn't do that at first.

From searching in the help, the Sonos community and other sources online, I had several failed attempts to try to get the speakers setup on the network. Things did not come together until I did the two most important steps: (a) factory reset each speaker and (b) remove my current sonos network via the mobile app. Then, everything worked.

BTW, per John B's recommendation, I did try disabling my router's Wifi and DHCP, but that didn't work either. Besides, I have some computers in the house on wired connections so I need the DHCP enabled on the router. After I did the full factory reset and creating a new sonos network, with everything working, I re-enabled the older Wifi on my router and no issues. That makes sense, as now the speakers and the sonos network are associated with my google mesh network.

My lesson learned: start from scratch and stop fighting trying to get the speakers to be recognized from your prior setup.
Userlevel 2

The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.

Spot on! Had to wire a play 1 speaker to the google router pod before the whole thing worked. 

Userlevel 7
Badge +20
Hi

Is your Google Wi-Fi 2.4 or 5GHtz, Sonos only support 2.4? If your Connect is wired to your Router, it will try to connect via the Sonos Net and not your Wi-Fi. Is your Google Wi-Fi wired to the same Router as your Connect?

Also, have you removed the Wi-Fi credentials from the Sonos App>Settings>Advanced>Wi-Fi Setup?

If still not working I suggest that you power down for 10 secs the following devices, letting each one boot before powering down the next:

- Router
- Any Wired network switches;
- Google Wi-Fi
- Any wired Sonos devices;
- Any other Sonos products;
- All other devices that connect via Wi-Fi

Please retest and let us know.
I do not own a Google WiFi yet, but I have been researching it. It's not just a set of wireless access points, but a full fledged router replacement, with the primary GW hub acting as router. This means that you now have two routers in your network, your original one and Google WiFi. Without going into technical details, this causes problems, and not being able to connect to a router-connected device from a Google WiFi-connected device is actually expected behavior, since Google WiFi and your router create different subnets.

This is not unique to Google WiFi, these problems would occur when wiring any router in its default settings downstream of the original router. The problem is that most people are not aware that Google WiFi is a router.

More information on how to (and how not to) wire your Google WiFi: https://support.google.com/wifi/answer/7215624?hl=en&ref_topic=6243113

The simplest solution (without getting rid of GW) is to replace your original router by the primary GW device. If you need to hardwire more devices, use a dumb switch downstream of the GW.

Other options would entail changing DHCP, NAT and other routing settings on either devices, I don't know if you're up for that and I'm quite sure the Google WiFi mesh functionality is disabled when you disable routing.
I just wasted over 4 hours on the phone with Sonos and Google WiFi tech support. Unbelievable. Each google mesh unit is a router. The new Comcast, etc. modems now have built in routers. The dual routers confuse Sonos and results in dropped connections or devices not being able to find Sonos on your WiFi network. ALL YOU HAVE TO DO IS CALL YOUR INTERNET PROVIDER AND ASK THEM TO DISABLE YOUR ROUTER AND ENABLE BRIDGE MODE! Boom...problem solved. Hopefully the folks at Sonos will share this with their tech support team. You're welcome.
Userlevel 2
Badge +1
BIG challenge when introducing Google wifi to my established 12 Sonos Components over 3 floors.
After one intensive week trying to Connect Sonos to to GW, reading pretty much everything on Sonos community related to the topic, -
I resign, - reset all sonos products to factory settings,
establish a Brand new sonos account,
and reconnect all my sonos components to my «old» wireless network ( Get/ Norway).
Seems GW works well with all other devices with no connection to music streaming.
Returning GW products to my supplier and try Asus Mash.

Br
Halvor - Oslo


I have Google WiFi and Sonos working perfectly together. You just need to follow the setup John B described in the post immediately preceding yours.
Userlevel 1
Thanks. But I have tried that option. Sonos components keeping disapear in the sonos app....
Google Wifi 3 node mesh and new Sonos owner here. The issue I am having is similar. I have discovered that if my phone is connected to a different access point (same SSID) in the mesh than the Sonos One speakers the app "can't find" my speakers. If we are all on the same AP its all good. Really sucks as this limits their usefulness and I may have to return the speakers
John B is correct. Just turn off the wireless signal to your main router and everything will work fine. I had to sign into Spectrum and then manage setting, then advance setting. And there is was, tun off wifi.
I had trouble with Google WiFi and I could not connect. Once I turned off wireless on my main router, everything worked perfectly.

Thank you John B.
Badge
I don't have a main WiFi router. Only the Google mesh, and I'm having all kinds of connecting issues. Both with the bridge and without. Even reset every device and started all over. :8 it's getting really frustrating. Making our favorite product ever less and less fun.
Please state what you have connected to what. Do you have a separate modem?
Badge
There's no modern. I am going directly into my Google unit and then had an Ethernet cable coming out of that into the boost. Had issues with that configuration so I removed the boost and set up using WiFi method. Same issues.
Just to eliminate a couple of possibilities, could you reinstate the Boost, reboot your speakers and then check About My Sonos System in the app. Do speakers have WM:0 or WM:1 next to them?

What exactly are the issues?