Answered

Sonos and Google WiFi

  • 8 January 2018
  • 42 replies
  • 34617 views


Show first post

42 replies

In Settings/About My Sonos System. WM:0 means SonosNet (or wired), otherwise it's WiFi.

If a system is intended to be used in SonosNet mode, any stored WiFi credentials should be removed to avoid instability.
Incredibly useful information! Wish I knew this earlier before pulling out my hair for weeks. After a week the large system at home (15 Sonos devices) seems to be stable after I reset everything.
In Settings/About My Sonos System - what does the OTP setting indicate? Does that mean it is wired?
After a week the large system at home (15 Sonos devices) seems to be stable after I reset everything.
Factory reset the whole system? FWIW you should never need to do this, unless of course you're selling it. I have a larger system, 10+ years old, that's never been reset in its entirety.

In Settings/About My Sonos System - what does the OTP setting indicate? Does that mean it is wired?
One Time Programmable
Ignore it. It's just a microcode version on some controller or other. Some devices don't show anything in About, some show "OTP:" with a blank.

As for determining remotely whether a unit is wired, there are one or two arcane methods but the most accessible is probably the Network Matrix at http://x.x.x.x:1400/support/review, where x.x.x.x is the IP of any player (not a BOOST or BRIDGE). The coloured cells in the matrix body indicate active wireless tunnels, so wired connections can be inferred therefrom.
The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.

Hello, sir. What does keep everything downstream of main Google unit mean?

TIA
This suggestion didn't work for me. My setup was like this:

Modem -> Switch -> Google WiFi -> Boost (via google wifi LAN port).

Every time I tried to set it up, it seemed to go a slightly different way, always ending with nothing being found or unable to connect. Customer support had me change the setup to this, swapping google wifi and the switch:

Modem -> Google WiFi -> Switch (via google wifi LAN port) -> Boost.

This DOES work. But for various reasons, it breaks everything else on my network. I am not a networking guy, so I don't understand why those should be any different. Downstream is downstream, no? I tried this, to preserve my top-level setup, and mimic the working setup, but it also didn't work:

Modem -> Switch -> Google WiFi -> Another Switch (via google wifi LAN port) -> Boost.

The first and third setup don't work on my iPhone, my wife's Android, or my Mac. Can anyone explain how Sonos actually works that this should be problematic? I have a Boost and two connects, and have tried every combo (with and without the boost) to try and get these online, but only that second topology works consistently.

Any help or insight would be much appreciated.
This suggestion didn't work for me. My setup was like this:

Modem -> Switch -> Google WiFi -> Boost (via google wifi LAN port).

Every time I tried to set it up, it seemed to go a slightly different way, always ending with nothing being found or unable to connect.


I was able to fix this. On the devices where I wanted to access Sonos, I had to manually assign myself IPs on the DHCP subnet leased by the Modem/switch. I don't know why this works exactly, but the Google WiFi will honor those IPs to connected devices, rather than try to force them onto its own subnet.

In my case, my main network is 192.168.2.0/24, and Google WiFi was 192.168.86.0/24. When my phone connects to WiFi with DHCP, it would get, say, 192.168.86.5, and could not see Sonos. When I changed the settings manually to use 192.168.2.5 (and 2.1 gateway), I was still able to connect to Google wifi, but then everything worked.
Badge +1
The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.


hi John,
Well Explained! Planning on my router upgrade, so please humor me!
So in this scenario if I am using sonos net and android controller, I have to connect to a separate sonos net network and not google mesh wifi network?
Badge +1
The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.

Hello, sir. What does keep everything downstream of main Google unit mean?

TIA


Hi Tia,

In this context it means first and only connect the one\main google wifi pod to your modem. All other devices including SONOS connect to this google wifi pod. 😳
The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.


hi John,
Well Explained! Planning on my router upgrade, so please humor me!
So in this scenario if I am using sonos net and android controller, I have to connect to a separate sonos net network and not google mesh wifi network?
First, I would now recommend leaving DHCP on, on the original router, but that goes alongside turning off the wireless and wiring only the primary Google puck.

As far as the controller device is concerned, no, it can connect to the Google wifi network. You have the option with an Android device to connect to SonosNet, but this is not a requirement. The controller can talk to a Google puck, which can pass data to the primary Google puck (if it isn't the primary anyway) which passes the data over Ethernet to the wired Sonos device, and thereafter via SonosNet to any wireless Sonos devices. It isn't fundamentally different from how controllers talk to Sonos devices when the wifi is a 'traditional' type.

I would generally recommend using SonosNet mode rather than wifi only, although people have got it to work either way.
Google Wifi 3 node mesh and new Sonos owner here. The issue I am having is similar. I have discovered that if my phone is connected to a different access point (same SSID) in the mesh than the Sonos One speakers the app "can't find" my speakers. If we are all on the same AP its all good. Really sucks as this limits their usefulness and I may have to return the speakers

I seem to have the same issue here.

My Sonos setup broke down when I switched the Wifi network of the system to the Google Wifi mesh. I have two access points, with same SSID (network name and password), but the speakers are split across the two access points. Other speakers I have lost entirely. I can only control the speakers connected to the Google Wifi AP that my phone is actually connected to.

Has anybody verifiably set up a multi room Sonos system using multiple Google Wifi access points?

Worse, it now seems quite impossible to get back to the old Wifi network. No way of hardwiring a Sonos unit allows me to use Settings -> Advanced -> Wifi Setup.
Hi. Lots of people have made this work, but you will have a much better chance if you wire one of your speakers to a Google puck so that SonosNet is running.
Hi. Lots of people have made this work, but you will have a much better chance if you wire one of your speakers to a Google puck so that SonosNet is running.

Thanks.

I've got it working now, but had to factory reset every Sonos device, and build my rooms anew.

Transitioning the Sonos setup from a normal Wifi setup to the Google mesh setup was definitely not smooth. I was essentially stuck in limbo.
After adding a Google mesh network, I too struggled getting my Sonos Play:5 speakers back working on my network. Like tickletikkel, the path of success was to start over. I factory reset the two speakers and from my android app, had to remove my current sonos network. That last step was key. I didn't do that at first.

From searching in the help, the Sonos community and other sources online, I had several failed attempts to try to get the speakers setup on the network. Things did not come together until I did the two most important steps: (a) factory reset each speaker and (b) remove my current sonos network via the mobile app. Then, everything worked.

BTW, per John B's recommendation, I did try disabling my router's Wifi and DHCP, but that didn't work either. Besides, I have some computers in the house on wired connections so I need the DHCP enabled on the router. After I did the full factory reset and creating a new sonos network, with everything working, I re-enabled the older Wifi on my router and no issues. That makes sense, as now the speakers and the sonos network are associated with my google mesh network.

My lesson learned: start from scratch and stop fighting trying to get the speakers to be recognized from your prior setup.
Notwithstanding rlj61's comments I ought to just point out that it should never be necessary to factory reset everything, simply to change the network or SSID to which a Sonos system is connected. Power all the units off, wire one Sonos device, power them up again. A new SSID can then be configured into the system if required.

As for connecting a Sonos system in 'wireless' mode to a meshed WiFi over which one has no control in terms of channel allocations, it's simply not advisable. Sonos' recommendation is that where there are multiple access points they should all use the same channel, in order to optimise interconnection in groups (and stereo pairs, a special kind of group). Where different Sonos units 'home' onto different access points, on different channels, it can cause problems, as various reports here will confirm.
I just wasted over 4 hours on the phone with Sonos and Google WiFi tech support. Unbelievable. Each google mesh unit is a router. The new Comcast, etc. modems now have built in routers. The dual routers confuse Sonos and results in dropped connections or devices not being able to find Sonos on your WiFi network. ALL YOU HAVE TO DO IS CALL YOUR INTERNET PROVIDER AND ASK THEM TO DISABLE YOUR ROUTER AND ENABLE BRIDGE MODE! Boom...problem solved. Hopefully the folks at Sonos will share this with their tech support team. You're welcome.
Badge
This thread was extremely helpful for me. My setup is Spectrum modem -> Google Wifi -> Netgear switch -> Sonos Connect (ZP90). I then have a Sonos Connect:Amp (ZP100) and Play:1 in separate rooms. My previous setup had the ZP90 hardwired and the other two players on the wifi (not SonosNet). I was having problems discovering the two wireless players which I figured was due to them being on the Wifi. I initially tried removing the wifi network settings from the Sonos app but it took me several attempts to do this, and finally succeeded by wiring the Play:1 to the switch and then removing the wifi setting. I had to factory reset the ZP90 and ZP100 to get them onto SonosNet but eventually all three were functioning without the wifi connection (confirmed by seeing WM:0 in the About page for each player). One other thing I did which I'm not sure helped or not, was to ring Spectrum and ask them to disable Wifi on my modem.

Finally with this setup, I was able to do what I'd originally intended - discover all of my speakers in the Harmony Hub app so I could set up an activity to turn on my Pioneer Amp connected to the ZP90 and play music across all my speakers through my Echo using the command "Alexa, turn on Sonos". Only took a couple of evenings to get to this point.

Reply