Answered

Sonos and Google WiFi


  • Contributor I
  • 1 reply
Having an issue with google and Sonos.
First on the network I have several devices connected (hardwired) to the router. I have 2 Play 1's and a Connect hooked up. The Connect is hardwired to the router.
I turned off the WiFi on the router and connected the google WiFi mesh with 3 stations. All of my other devices connect fine.
The only way I can get the Sonos devices to work is to hard wire one Sonos into the google WiFi eventually all the systems connected.

Now the pone and computer running Sonos cannot connect to the Sonos network but my tablet can? Can someone help?
icon

Best answer by John B 12 January 2018, 00:27

The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.

View original

32 replies

Userlevel 6
Badge +20
Hi

Is your Google Wi-Fi 2.4 or 5GHtz, Sonos only support 2.4? If your Connect is wired to your Router, it will try to connect via the Sonos Net and not your Wi-Fi. Is your Google Wi-Fi wired to the same Router as your Connect?

Also, have you removed the Wi-Fi credentials from the Sonos App>Settings>Advanced>Wi-Fi Setup?

If still not working I suggest that you power down for 10 secs the following devices, letting each one boot before powering down the next:

- Router
- Any Wired network switches;
- Google Wi-Fi
- Any wired Sonos devices;
- Any other Sonos products;
- All other devices that connect via Wi-Fi

Please retest and let us know.
Badge +3
I do not own a Google WiFi yet, but I have been researching it. It's not just a set of wireless access points, but a full fledged router replacement, with the primary GW hub acting as router. This means that you now have two routers in your network, your original one and Google WiFi. Without going into technical details, this causes problems, and not being able to connect to a router-connected device from a Google WiFi-connected device is actually expected behavior, since Google WiFi and your router create different subnets.

This is not unique to Google WiFi, these problems would occur when wiring any router in its default settings downstream of the original router. The problem is that most people are not aware that Google WiFi is a router.

More information on how to (and how not to) wire your Google WiFi: https://support.google.com/wifi/answer/7215624?hl=en&ref_topic=6243113

The simplest solution (without getting rid of GW) is to replace your original router by the primary GW device. If you need to hardwire more devices, use a dumb switch downstream of the GW.

Other options would entail changing DHCP, NAT and other routing settings on either devices, I don't know if you're up for that and I'm quite sure the Google WiFi mesh functionality is disabled when you disable routing.
The approach that seems to work best for Sonos with Google WiFi (and I think this is consistent with what you are saying) is:
Turn off DHCP and wireless on original router
Wire main Google unit to router
Keep everything Sonos downstream of main Google unit. For Boost mode wire a Sonos component to Google. For Standard mode enter the Google wifi credentials into Sonos.
Connect controllers to Google wifi or (for Android controllers when system is in Boost mode) to SonosNet.
BIG challenge when introducing Google wifi to my established 12 Sonos Components over 3 floors.
After one intensive week trying to Connect Sonos to to GW, reading pretty much everything on Sonos community related to the topic, -
I resign, - reset all sonos products to factory settings,
establish a Brand new sonos account,
and reconnect all my sonos components to my «old» wireless network ( Get/ Norway).
Seems GW works well with all other devices with no connection to music streaming.
Returning GW products to my supplier and try Asus Mash.

Br
Halvor - Oslo
Badge
Sokrates2002 wrote:

BIG challenge when introducing Google wifi to my established 12 Sonos Components over 3 floors.
After one intensive week trying to Connect Sonos to to GW, reading pretty much everything on Sonos community related to the topic, -
I resign, - reset all sonos products to factory settings,
establish a Brand new sonos account,
and reconnect all my sonos components to my «old» wireless network ( Get/ Norway).
Seems GW works well with all other devices with no connection to music streaming.
Returning GW products to my supplier and try Asus Mash.

Br
Halvor - Oslo



I have Google WiFi and Sonos working perfectly together. You just need to follow the setup John B described in the post immediately preceding yours.
Thanks. But I have tried that option. Sonos components keeping disapear in the sonos app....
John B and edmountain...
Tried your tips once more.. deactivated both wireless bands and put the existing GET router in bridge mode FIRST...
Followed by cabel from one of my connect boxes to Google WIFI and changed wifi settings to GW.
Since then; Sonos and GW works, (as edmontain so correctly put it) perfectly together. Thanks from Norway!!!
Google Wifi 3 node mesh and new Sonos owner here. The issue I am having is similar. I have discovered that if my phone is connected to a different access point (same SSID) in the mesh than the Sonos One speakers the app "can't find" my speakers. If we are all on the same AP its all good. Really sucks as this limits their usefulness and I may have to return the speakers
John B is correct. Just turn off the wireless signal to your main router and everything will work fine. I had to sign into Spectrum and then manage setting, then advance setting. And there is was, tun off wifi.
I had trouble with Google WiFi and I could not connect. Once I turned off wireless on my main router, everything worked perfectly.

Thank you John B.
Badge
I don't have a main WiFi router. Only the Google mesh, and I'm having all kinds of connecting issues. Both with the bridge and without. Even reset every device and started all over. :8 it's getting really frustrating. Making our favorite product ever less and less fun.
Please state what you have connected to what. Do you have a separate modem?
Badge
There's no modern. I am going directly into my Google unit and then had an Ethernet cable coming out of that into the boost. Had issues with that configuration so I removed the boost and set up using WiFi method. Same issues.
Just to eliminate a couple of possibilities, could you reinstate the Boost, reboot your speakers and then check About My Sonos System in the app. Do speakers have WM:0 or WM:1 next to them?

What exactly are the issues?
Badge
Sure, I will try that. And the issue is that I can start music in one room...and it will go out. I can hear it start downstairs, and then it will move to another speaker...then a sub and then all go out again, and sometimes it takes a whole song before they all come on...and then if I hit to go to the next song, it starts doing it all over again.
It would be worth assigning fixed IP addresses to your Sonos speakers, assuming Google wifi allows that. It certainly won't do any harm.
Sokrates2002 wrote:

BIG challenge when introducing Google wifi to my established 12 Sonos Components over 3 floors.
After one intensive week trying to Connect Sonos to to GW, reading pretty much everything on Sonos community related to the topic, -
I resign, - reset all sonos products to factory settings,
establish a Brand new sonos account,
and reconnect all my sonos components to my «old» wireless network ( Get/ Norway).
Seems GW works well with all other devices with no connection to music streaming.
Returning GW products to my supplier and try Asus Mash.

Br
Halvor - Oslo



How did that work out? Struggling here with Sonos and GW atm...
Abel666 wrote:

Sokrates2002 wrote:

BIG challenge when introducing Google wifi to my established 12 Sonos Components over 3 floors.
After one intensive week trying to Connect Sonos to to GW, reading pretty much everything on Sonos community related to the topic, -
I resign, - reset all sonos products to factory settings,
establish a Brand new sonos account,
and reconnect all my sonos components to my «old» wireless network ( Get/ Norway).
Seems GW works well with all other devices with no connection to music streaming.
Returning GW products to my supplier and try Asus Mash.

Br
Halvor - Oslo



How did that work out? Struggling here with Sonos and GW atm...

Please tell us what you have and what is wired to what: modem, router, Google, Sonos
Hello John!

Thanks for reaching out.

I have - oddly enough - a connection now with sonos. Here is my setup;

Cable modem - GW Router - cable via switch to Sonos Playbase.
It seems like Sonos own network takes it from there. It just suddenly worked. Hope it stays that way. I struggle to reach sonos from my mac, but no problems from my Ipads or Iphone.
I hope it lasts cause it was kinda fragile here for a few hours...
That's the recommended solution, to wire a Sonos unit to a Google puck. Since Google's in-built router cannot be defeated in mesh mode you should ensure that nothing (other than the primary puck obviously) connects to the upstream device.
That's good. If that is just an unmanaged switch to give you more Ethernet ports, then there should be no problems. When you say you struggle from the Mac, do you mean it works intermittently or that it doesn't work at all? I assume Mac is connected over wifi?
John B wrote:

That's good. If that is just an unmanaged switch to give you more Ethernet ports, then there should be no problems. When you say you struggle from the Mac, do you mean it works intermittently or that it doesn't work at all? I assume Mac is connected over wifi?



Yes you are right. A stupid switch and an imac over wifi. Seems like the entire system has had time to negotiate itself to a good solution. Sonos works fine on the Imac also now.

If nothing horrible happens and it stays like this it is by far the best network setup I have ever had. All the lag between all my Sonos units are gone also it seems.
Fingers crossed!

Thanks John! Really appreciate your service!
I have lots of Sonos devices (20+) at three different locations. Each has Google Wifi setup. Each GW point is set up directly to the modem. Still lots of problems connecting to various music services (Pandora, Amazon, Apple Music). I've had this problem on 2 of 3 locations. This is a problem the Sonos should recognize and fix. It is sporadic, but happens again and again. My latest solution is to reset the entire network and every Sonos device. Pretty sure it is a problem is GW as the problem only appeared after I changed over to this WiFi system.
There is a recommended fix: use SonosNet/BOOST mode. Attaching Sonos to a mesh WiFi, Google in particular, introduces various complicating factors.
Thanks for the tip. Is there an easy way to tell how your devices are connected? I believe at one point I was in "mixed" mode with some devices connected each.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings