Answered

Sonos and ASUS Zenwifi AX and AX Mini

  • 14 October 2021
  • 5 replies
  • 49 views

Hi there,

I’m having a bit of a nightmare trying to get my Sonos system to work with my ASUS Ai Mesh set up. I realise this has been posted about before but none of what has been suggested in the other posts has worked and neither has spending a few hours on the phone to the customer care team.

The issue is speakers drop in an out of the Sonos app, not just in terms of audio but from the system set up screen. I have two Play3’s, a Play 1, Zimfonisk lamp, and 4 Books. Originally the system was set up on an ASUS AX Zenwifi mini AiMesh. I have tried the following to resolve this:

  • Disabled Airtime Fairness
  • Disabled QoS
  • Updated firmware
  • Plugged in an Play3 to my router for Sonos Net
  • Purchased a BOOST to create a Sonos Net
  • Created a fixed IP for every Sonos speaker as per this guide: 
  • Purchased an ASUS AX-XT8 to see if the firmware was any better in working with Sonos products as there was very little listed on these pages regarding the AX mini

...all of this to no avail. Nothing I’ve tried has resolved this problem despite the addition of the AX XT8 providing a great and solid connection throughout the house.

I’m at a loss right now so any help on this front would be greatly appreciated. 

Many thanks in advance.

 

icon

Best answer by ratty 14 October 2021, 13:41

View original

5 replies

What are the 2.4GHz channel allocations used throughout the house, for SonosNet and for ASUS?

Are you using multiple routers, i.e. is there an ISP router in addition to the ASUS?

Hi Ratty, thanks for the quick response. 

I’m running both 2.4GHz and 5GHz using CH4 and CH36 as my control channels respectively. Sonosnet is CH1. I’ve also tried using 6 and 11 as per the drop down options in the Sonos App.

There is an router provided by my ISP here in Portugal (NOS) which is made by Hitron and looks like this: https://us.hitrontech.com/support-only/chita-res-cable-modem-router/. My AX XT8 is plugged into it and running off it as the main node for the rest of the AX Zen mini’s to create the mesh.

 

I’m running both 2.4GHz and 5GHz using CH4 and CH36 as my control channels respectively. Sonosnet is CH1. I’ve also tried using 6 and 11 as per the drop down options in the Sonos App.

Channel 4 is a poor choice. It overlaps with channels 1 and 6 badly, introducing interference. You should only use 1, 6 or 11 for any WiFi at 2.4GHz, with a channel width of 20MHz.

 

There is an router provided by my ISP here in Portugal (NOS) which is made by Hitron and looks like this: https://us.hitrontech.com/support-only/chita-res-cable-modem-router/. My AX XT8 is plugged into it and running off it as the main node for the rest of the AX Zen mini’s to create the mesh.

Assuming the Hitron device is still in router mode (not modem-only) and the ASUS is still in router mode (not access point mode), then you have two routers, and hence two IP subnets.

All Sonos devices and controllers need to be on the same subnet. Probably the simplest option is to switch the ASUS mesh into access point mode. The alternative is to ensure that nothing -- other than the ASUS primary unit -- connects to the Hitron device.

Channel 4 is a poor choice. It overlaps with channels 1 and 6 badly, introducing interference. You should only use 1, 6 or 11 for any WiFi at 2.4GHz, with a channel width of 20MHz.

Thanks again for the quick response. At work so only able to get back to you now.

I figured I didn’t want to run any internet traffic on the same channel as Sonosnet. If I understand correctly are you implying that I should use the same channel for Sonos and my general internet?

If not will try switching to a channel well away from 1 - 11 but I believe I tried that already at Sonos phone supports request. Will give it a go and report back.

 

Assuming the Hitron device is still in router mode (not modem-only) and the ASUS is still in router mode (not access point mode), then you have two routers, and hence two IP subnets.

All Sonos devices and controllers need to be on the same subnet. Probably the simplest option is to switch the ASUS mesh into access point mode. The alternative is to ensure that nothing -- other than the ASUS primary unit -- connects to the Hitron device.

Nothing other than the ASUS primary unit has ever been connected to the Hitron device. And the Sonos BOOST is connected to the ASUS primary device.

I have nonetheless switched the ASUS mesh to access point mode just to see if it would work but the the whole network died so had to switch it back. 

UPDATE: 

In addition to all of the above settings outlined in OP I

  • Switched to Control channel 13 @ 2.4GHz and bandwidth to 20MHz
  • Switched to Contorl channel 48 at 5GHz and bandwidth to 40MHz

So far everything seems to be running well.

Thanks Ratty. Wish I had posted sooner!!

 

Reply