Sonos Amp (1st gen) keeps on disconnecting

  • 30 July 2022
  • 7 replies
  • 55 views

Userlevel 1
Badge +1
  • Avid Contributor II
  • 6 replies

I have 2 Sonos devices connected to the same router.

 

Issues:

  • Most mornings, when I want to listen to music, the Sonos Amp does not work but the Sonos One does work. Sometimes both stop working.

Testing:

  • After writing this post, I have decided to assign static IP’s to my 2 Sonos devices to see if there are any improvements. I have to wait a few days to confirm.

 

Solution (Annoying!):

  • I unplug the Sonos Amp and/or Sonos Play:1 but this is frustrating obviously I want to fix that. 
  • I cannot use ethernet cables as they are 5-10m from the router plus WiFi is supposed to work.

 

My systems (2 items):

  • Sonos Connect:Amp (1st gen) connected via 2.4 Ghz « Where most of the issues occur.
  • Sonos Play:1 connected via 5 Ghz
  • Both systems are updated.

 

Routers:

  • TP-Link Archer AX10 
    • Firmware updated
    • Wireless Router (EWAN) (note: I reckon Access Point does not work.)
    • I have 8 clients connected but most of the time maximum 4 are active mostly laptops and phones.
      • Most clients are connected to the 5 Ghz band while the Sonos Amp that is causing me the most issues is the only device connected on 2.4 Ghz. 
    • Advance Settings
      • QOS - [On for the 2 Sonos devices}
      • Port forwarding [OFF]
      • UPnP  [On]
      • IPTV/VLAN was on, no idea what this is, I just switched it off to test… [now:OFF]
        • IGMP Proxy [On]
        • IGMP Snooping [On]
        • IGMP Version [V2]
        • Wireless Multicast Forwarding [On]
      • OFDMA [On]
      • TWT [OFF]
      • Smart Connect [On]
      • Parent control [OFF]
      • IP & MAC Binding [On] Note: This was off but just switched it on to assign static addresses to my Sonos devices

  • TP-Link RE505X Range Extender
    • Only my devices in my bedroom are connected to it, none of my Sonos devices.

 


7 replies

Userlevel 7
Badge +21

A good starting point, if it isn’t the solution maybe we can find the issue. Let us know.

Full disclosure: I have no experience with the AX10.

At the time you took the AX10 snapshot was the ONE working? It’s curious that the CONNECT:AMP shows data traffic, but the ONE does not.

Are you using the same SSID/Password for 2.4 and 5GHz? If possible, try keeping both SONOS units on 2.4GHz by using different SSID/Passwords. Some people seem to have trouble if the SONOS system is split between bands, I don’t.

Userlevel 1
Badge +1

Yes ONE was working maybe I was just playing on the CONNECT:AMP at that time. 

 

I am using the same SSID for both bands, the SSID has space in between names not sure that would have any effect. 

Indeed, I thought about moving everything by forcing all the devices to 2.4 GHz but from what I recall I believe I have one device which is not 2.4 GHz compatible (I believe it is the Mesh extension for my bedroom.) 

 

 

Full disclosure: I have no experience with the AX10.

At the time you took the AX10 snapshot was the ONE working? It’s curious that the CONNECT:AMP shows data traffic, but the ONE does not.

Are you using the same SSID/Password for 2.4 and 5GHz? If possible, try keeping both SONOS units on 2.4GHz by using different SSID/Passwords. Some people seem to have trouble if the SONOS system is split between bands, I don’t.

 

I thought about moving everything by forcing all the devices to 2.4 GHz but from what I recall I believe I have one device which is not 2.4 GHz compatible (I believe it is the Mesh extension for my bedroom.)

Only the SONOS units might benefit with restricting them to 2.4GHz. You could leave other clients free to use either band. However, some routers do not allow data to cross over from 5GHz to 2.4GHz. This  could result in a phone using the 5GHz band not being able to communicate with SONOS when SONOS is using the 2.4GHz band. This can be very puzzling because, when phone is using 2.4GHz band the system works fine, but if the phone jumps to 5GHz, the phone looses contact with SONOS. This can seem very weird because SONOS usually fetches music directly from the source and will continue to play music without the controller.

Userlevel 7
Badge +17

Maybe not very helpful in this case (and maybe a bit off topic), but exactly how is preventing data cross over from 2.4GHz to 5Ghz a good idea on a network - that is made for devices to communicate with eachother? Why would an internet provider do this?

Userlevel 1
Badge +1

Update: I forced both Sonos to use the 2.4 Ghz by giving the 5 Ghz band a different name. FYI The Sonos Connect:Amp would only connect to 2.4 Ghz because older while Sonos One was always connecting to the 5 Ghz band. In addition, I have assigned static IPs to both devices. 

 

When connecting my phone or my laptop to the 5 Ghz I can still control the Sonos devices on the 2.4 Ghz without any issues.

 

So far the systems are much more stable. Fingers crossed that it works everyday for the next few days… 🤞

Userlevel 1
Badge +1

Maybe not very helpful in this case (and maybe a bit off topic), but exactly how is preventing data cross over from 2.4GHz to 5Ghz a good idea on a network - that is made for devices to communicate with eachother? Why would an internet provider do this?

 

Hi - I do not have this issue at all. If you do have this issue, then in the router configuration there might be an option depending on the brand you own that segregates the traffic between the 2 bands. It is called AP isolation on mine.

 

Regarding your question why you would do that is simple: To segregate traffic for security. You could have your sensible data on 5 Ghz (Work, bank, etc.) and use 2.4 Ghz for guests for instance. Most people don’t need this but that is one option. I hope that helps.

 

Take what I write with a pinch of salt as I am not a router expert. 

 

See the screengrab below if that helps for you:

 

Reply