Sonos Alarms causing issues


Badge
I have an alarm set for 7:30am that should play BBC Radio 2. The alarm goes off at the correct time and i get a notification on my iPhone. Some morning the notification just says "Cannot connect to speaker" other times i get "There is no alarm playing" and then on rare occasions i get the the correct message and can stop or snooze the alarm. Even with the two odd messages i can go straight into the Sonos app and stop the music playing without any issue so clearly it can see the speakers. Beam is hard wired through a switch to the router and then play:1's, One and Play:3 are all wireless. The Play:3 is where the alarm is set for and this stands right next to our SkyQ Mini box which acts as a wireless repeater as well so should be a strong signal. Any help/ideas?

2 replies

Userlevel 6
Badge +18
Hi, mark_herring. Welcome to the community. If it's that nearby the Sky Q box, that may be a source of WiFi interference. This is often the cause of audio playback issues. If those links don't work, not to worry, we can certainly get to the bottom of this for you. Following any further occurrence of this issue or changes in your setup, please submit a diagnostic and respond with the confirmation number. This way we can identify the cause. Many thanks in advance.
Badge
Edward,

Thanks for the reply and the welcome. So to answer your question about the Sky Q mini box it does indeed stand right in front of the Play:3 but we are not seeing audio playback issues. The alarm issue actually happens almost every morning. For example this morning the alarm went off at 7:30am as it always does. I get a notification on my phone saying an alarm has gone off and when I clicked it this morning the Sonos app opens, spins for a short time, and I get a warning message saying "Cannot connect to speaker". There are two buttons saying "Cancel" or "Stop alerts". What I have found is that if I click "Stop alerts" I then get a further notification saying alerts are turned off and it gives me the option to turn then on again. If I do that then I get a third notification saying an alarm went off at 7:30 and it asks if I would like to snooze, dismiss or cancel. This is the notification I should get the first time I believe?
I have run a diagnostic and the confirmation number is 239785525

Any help you can provide to resolve this would appreciated as it's really the only thing letting the system down at the moment. We are very pleased with the devices and the sound quality is nothing short of awesome.

Regards,

Mark

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings