Answered

Sonos 3 skipping to next track every 30/60seconds


I use iPhone Sonos app and stream from device or amazon music and it continues to skip to next track - this is not network issue as signal is full and device is adjacent to router etc. I’ve tried the ‘turn off auto sleep’ method but still happens. I’ve reset the phone the WiFi the speakers but it still continues. After paying nearly a grand for these speakers it’s infuriating that it’s not working. If anyone can give me other potential fixes that I can try I’d be incredibly grateful. Thanks for your time and help
icon

Best answer by Airgetlam 4 May 2019, 20:35

OK, let's hit a couple of things.

First, please read this: iOS issue. Pay particular attention to the information in the box at the top. I'd try moving the music to a computer and try playing from that, to see if the issue you're experiencing is indeed what is referenced in the article. It may be, it may not be.

Second, you indicated that your device is adjacent to the router. This isn't a good thing. You should have at least a meter / 3 feet in between your router and the speaker. Both are electrical devices, and can generate interference with each other. As indicated in the wifi interference FAQ, it's still possible to get interference depending on lots of outside sources that aren't in your home. Might be worth reading that, and perhaps trying a channel change on your router, or looking for other potential sources of interference.

They're only moderately priced speakers, but they do depend on a good wifi signal. However, if you wanted to, you could skip the wifi interference issues by connecting all of your speakers to your router with an ethernet cable. Then you'd only need to worry about duplicate IP address issues on your LAN.

But if none of that helps, I would recommend that you submit a system diagnostic within 10 minutes of recreating this issue, and either post the number here, or contact Sonos to discuss it. I tend to suggest the phone folks, they have more tools available, but are only available during business hours. Both the Twitter and Facebook support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
View original

3 replies

OK, let's hit a couple of things.

First, please read this: iOS issue. Pay particular attention to the information in the box at the top. I'd try moving the music to a computer and try playing from that, to see if the issue you're experiencing is indeed what is referenced in the article. It may be, it may not be.

Second, you indicated that your device is adjacent to the router. This isn't a good thing. You should have at least a meter / 3 feet in between your router and the speaker. Both are electrical devices, and can generate interference with each other. As indicated in the wifi interference FAQ, it's still possible to get interference depending on lots of outside sources that aren't in your home. Might be worth reading that, and perhaps trying a channel change on your router, or looking for other potential sources of interference.

They're only moderately priced speakers, but they do depend on a good wifi signal. However, if you wanted to, you could skip the wifi interference issues by connecting all of your speakers to your router with an ethernet cable. Then you'd only need to worry about duplicate IP address issues on your LAN.

But if none of that helps, I would recommend that you submit a system diagnostic within 10 minutes of recreating this issue, and either post the number here, or contact Sonos to discuss it. I tend to suggest the phone folks, they have more tools available, but are only available during business hours. Both the Twitter and Facebook support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
Oh I seemed to have clicked to save it’s all solved...I was trying to reply to say thanks...I’ll see how it works following tour advice. Thanks.
Happy to at least give you some directions to look in. If it doesn't work, feel free to post again, there are many of us who look at just new posts, and don't pay any attention to the "this is answered" flag 🙂

Reply