Question

Sonos 2 app doesn't work on Motorola g7 android phone.

  • 27 August 2020
  • 1 reply
  • 109 views

Hi, had the old Sonos app on phone for ages and no issue. Then got promoted to update to Sonos 2 app - followed instructions but app will not load, just hangs when you try and open it and phone gives an app not responding message - phone is on latest hardware/android updates and the old app worked just fine. Have tried uninstalling and reinstalling - nothing works. App fine on the wife's iPhone - clearly an issue with Sonos 2 and the android android platform. Worst thing is I can't reinstall the old Sonos software that actually worked. Anyone else got this problem or know how to fix? Tried changing all app permissions etc - it trys to open - but just hangs on a cream coloured screen 

Cheers

Ewan

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 6
Badge +16

Hi @rfpewan, Thank you for reaching out and welcome to the community. Thanks for bringing this up and we understand where you're coming from. Regarding your concern about the Sonos S2 App not working on your Motorola G7 device, I’d like to ask some things to further check on this issue.

  • Aside from the iPhone, do you have another android phone device which you can try as a controller for the S2 App so we can check if that will work?
  • What is the exact error message that you’re getting when going to the S2 App on the G7?
  • Are all of your devices connected on the same Wifi network?

I’ll ask you to submit a diagnostic report for us to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue. 

Let us know how you get on with the advice above.

We're here to answer any further questions you have.