Songs Skips -


Badge +1
Songs skip before reaching end. I've about had enough of this, and would have thought Sonos could amend this issue by now. Or if they have would have clearly communicated this by now. Yes... I know how to change the channels and have done that. Plugging my 3 or 5 into is not possible. Please resolve.

11 replies

Sonos staff do visit this forum but Facebook & Twitter might get you a quicker response. Your issue is not widespread otherwise this forum would be flooded with similar posts, once you have submitted a diagnosis and told Sonos the diagnosis number they will be able to help.

For the record I have only ever experience skipping when I have a network issue, totally unrelated to Sonos but has an impact on playback. I am sure many other users will confim how stable their Sonos systems are.
Badge +1
Thanks, but that's not helpful. I don't do Facebook and I don't do Twitter. And, according the Sonos, you can't submit diagnostics until they are requested from you regarding a support request that may have been submitted. And, while this forum may not be "flooded", there are a number of posts regarding skipping. Thanks for your help anyway.
Hi, for what it's worth, I am having the same problems and am going through Twitter but don't have hours to sit around dealing with this. It is annoying to say the least.
I'm having tr same issues also. Network is fine.
I am having the same problems. I also have reported problem. All I get back is if we have not heard from you in the next 48hours we will assume all is well. What a uwaste of time.
Badge +1
avimia wrote:

Songs skip before reaching end. I've about had enough of this, and would have thought Sonos could amend this issue by now. Or if they have would have clearly communicated this by now. Yes... I know how to change the channels and have done that. Plugging my 3 or 5 into is not possible. Please resolve.



Hey Avima, thanks for reaching out. We can happily assist here if you could submit a Diagnostic and reply here with the number. I'd also in the mean time recommend taking a look over these two articles on 'Reducing wireless interference' - https://sonos.custhelp.com/app/answers/detail/a_id/3650 and 'Audio playback stops or skips' - https://sonos.custhelp.com/app/answers/detail/a_id/309. Both of which offer some great troubleshooting.
If you're not sure how to submit a diagnostic, here's the link on that:

submit a system diagnostic,
Same issue here. Got a boost to solve it but even with boost the songs are skipping when playing from a playlist on iphone. I've only had sonos for a couple of weeks and this is frustrating after investing a lot of money in sonos for my business. submitted diagnostics 7884795
Same issue. Skipping most songs after about 3mins on a Sonos 5. No other Sonos connected. No boost, just wifi, which I've checked is working fine. Not streaming, just playing from tunes on iPhone music. Set up the speaker yesterday. Submitted diagnostics 8182265
Don't know if this will help anyone but it worked for me - a combination of SONOS support suggestions, community help, some basic WiFi knowledge and sheer grit and determination.
1) Download something like "WifiInfoView", a free network analysis tool
2) The tool will show any conflicts of channels with your devices and neighbours WiFis - my whole close was on channels 6 and 11, so I changed my WiFi to 4. Not perfect but I wanted 1 (the least used) for SONOS.
3) I connected one SONOS:1 to the router in Bridge mode and cleared the old WiFi settings off every SONOS product. So there was no way any speaker was using the WiFi - SONOS then creates its own network of repeaters from speaker to speaker independent of the WiFi - very cool and works well.
4) As I have speakers in quite a few rooms they act as their own repeaters and even get a good signal to the black spot in the kitchen.
5) I changed my TpLink powerline repeater (for the wifi only now) to channel 9 - so my Wifi is on channels 4 and 9, SONOS on 1.
6) My music library is on a Western Digital NAS drive and was always skipping when connected directly to my Virgin "SuperHub". SONOS told me the hub was forgetting where the NAS drive was between requests to stream the songs.
7) To fix this I connected the NAS drive to one of my Play:1's. Rather neatly, SONOS products can also act as an Ethernet hub - they pick up the SONOS wifi and the Ethernet sockets allow any device to connect to it! So now the NAS drive library is directly connected to SONOS *and* my desktop can still see it to back up to. (It's my backup disk for 3 PCs as well as being the music library)

I have not had a single song skip since I did all this and am now happy with the product. (Maybe not the awful new controller App, but anyway...)

Good luck - hope this helps!
I'm having the same problem and it is SOOOOOO frustrating. I'll try a few of these suggestions and see what happens....

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings