Songs skipping when iPhone locked



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

89 replies

Badge +1
Having the same issue on iPhone 8 Plus. A short time after locking my iPhone screen, the Sonos skips tracks. Sonos have totally screwed over existing customers with their implementation of airplay 2 and the loss of lock screen controls for the rest of us
Umm, I did say that an option was to play music off your computer or NAS (your library), which would avoid any iPhone locking issue and any music service fees. That may not be an acceptable alternative for you for whatever reason you may have, but it's an option for anyone who's running into this issue.
I don't have any solution to the problem, but I must say that I'm a little surprised that playing music stored on an iPhone is seen as a must have feature, since there are several other ways to play audio on Sonos. Maybe it's just my opinion, but playing directly from a music services, instead of downloading the music then playing it, would avoid this issues. As well, you can play audio directly from a computer or NAS on your network. I'd only play audio off my phone as a last resort personally. Like you say you don’t have a solution, so I’m surprised you wasted your time expressing your completely pointless opinion, of course people want to play music from their library! Why pay for a streaming service when you’ve got everything you want already!? *insert rolling eyes emoji*
I don't have any solution to the problem, but I must say that I'm a little surprised that playing music stored on an iPhone is seen as a must have feature, since there are several other ways to play audio on Sonos. Maybe it's just my opinion, but playing directly from a music services, instead of downloading the music then playing it, would avoid this issues. As well, you can play audio directly from a computer or NAS on your network. I'd only play audio off my phone as a last resort personally.
Yep, same problem here but looks like Sonos are aware. Works fine when the phone is unlocked, as soon as you lock it, about 30-60 seconds of play back, then a pause and the next song kicks in about 14 seconds into it. Was fine until app and system update I did this week. Still love the system though
I just purchased a pair of Play:1 speakers and I'm having exactly the same issue on an iPhone7, IOS 11.4.1. Setting up the system went smoothly and I was up and listening in no time. I have no issues with my router or wifi and my house is single level dwelling, ~1,600'. I work for a media company and have an iPhone / work profile setup on my phone which does not allow for disabling the "auto lock" feature as a security measure. To Sonos, if you are unable to resolve this issue within the next 30 days, I will be returning the speakers to Amazon. It's unfortunate because the system sounds good and had this worked as expected, I would have purchased more to place throughout my home. Regards, Dale R.
Hi All
I have recently bought a Play:1 and have connected my phone laptop etc up to it and the sound is awesome! However when playing music from my iPhone 5s with music downloaded on the device and after a while if not actively using the phone (like 5mins) the phone has gone to sleep and the Play:1 cuts off playing music unless I wake the phone back up. if im quick enough I can see the message that it cannont play because the "music library is offline" on my device.
I have reserved the IP on my router for the Play:1
I have turned off wifi assist on iPhone
I have turned off IPV6 on router as well
I have turned off low power mode on the iPhone
The router and iPhone and speaker are in the same room.
For the life of me I don't know what else to try, and am thinking about returning the product and swapping for a Bluetooth speaker instead.

Any Help and ideas are most welcome
Many thanks
Userlevel 7
Badge +20
Hi folks,

We're looking into an issue where streaming from iOS device's storage runs into issues with non-Sonos AirPlay devices. We'll update the thread when we have more to share, but in the meantime you can change your iOS settings such that your devices do not auto lock. To do so, head into the settings app and go to Display & Brightness, then set auto lock to never. Also, you can try disabling AirPlay on non-Sonos devices on your network.
I just started having the same issue after I updated the software today. WTF!!????!!!?
I’m having exactly the same issue, it only started when Sonos recently removed the control from the lock screen - Sonos can you fix your App please??
They are playing from the phones storage as they always have done. There use to be a control on the lock screen but it’s now gone. Leaving the phone unlocked is a pain and requires a settings change every time I wanna listen to music. The music share requires my computer to be running all the time so another work around rather than a true fix to the issue... not the best really... Latest update is a step backwards and not progress I’m afraid Sonos!
Userlevel 7
Badge +20
So I’ve been having issues with song playback for sometime now and it only happens when my iPhone is locked. When unlocked the tracks playback just fine... but the moment it locks the songs continuously skip. Serious pain in the ass! Music is streaming from my phone. Thoughts anyone?? WiFi is fine and full coverage around the house, 3 rooms with different speakers + sound bar and sub. Runs through a Sonos bridge which is directly connected to my router. Only happens when phone is locked, no other time.

Hi GavP,

What is the source of the audio files you are playing? If you are playing from your phone's storage, it will work best with your phone unlocked. Otherwise you can sync your phone's library with iTunes on a computer and set up a music share that is available at all times to the Sonos system.