Answered

Songs skipping before done

  • 15 November 2018
  • 52 replies
  • 881 views

Badge
For the love of god, Sonos, will you fix this? YEARS later?
icon

Best answer by Jeff S 15 November 2018, 20:07

Sorry, I thought I was on the Songs Skipping thread. I understand I should change my wifi channel to 1, 6 or 11, but I just installed a new mesh network router that chooses a channel with the least interference. And this problem persists from when I had the previous router that used the prescribed channels. Songs from my library skip, whether I'm telling Sonos to play "from my music library" or "from this device." Streaming services work ok.



Hi there,



Song skipping can be caused by many different factors. Most often, it is due to wireless interference from third party electronics.



Right now, we're looking into an issue that causes playback errors when streaming directly from the storage of iOS devices when there are non-Sonos AirPlay devices on the network and your iOS device goes into auto lock. We'll update this thread when we have more to share on this, but in the meantime you can get streaming going again by disabling AirPlay on any non-Sonos device on your network or by disabling auto lock in your iOS device's settings menu under display and brightness.



If you are getting song skipping from other sources, this guide has some great troubleshooting tips.



If you still have issues after trying the above guide, please submit a diagnostic report and reply here with the confirmation number.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

52 replies

For the love of god, Sonos, will you fix this? YEARS later?
For the love of god, how is Sonos supposed to know what you are referring to?
Badge
Sorry, I thought I was on the Songs Skipping thread. I understand I should change my wifi channel to 1, 6 or 11, but I just installed a new mesh network router that chooses a channel with the least interference. And this problem persists from when I had the previous router that used the prescribed channels. Songs from my library skip, whether I'm telling Sonos to play "from my music library" or "from this device." Streaming services work ok.
Userlevel 7
Badge +20
Sorry, I thought I was on the Songs Skipping thread. I understand I should change my wifi channel to 1, 6 or 11, but I just installed a new mesh network router that chooses a channel with the least interference. And this problem persists from when I had the previous router that used the prescribed channels. Songs from my library skip, whether I'm telling Sonos to play "from my music library" or "from this device." Streaming services work ok.

Hi there,

Song skipping can be caused by many different factors. Most often, it is due to wireless interference from third party electronics.

Right now, we're looking into an issue that causes playback errors when streaming directly from the storage of iOS devices when there are non-Sonos AirPlay devices on the network and your iOS device goes into auto lock. We'll update this thread when we have more to share on this, but in the meantime you can get streaming going again by disabling AirPlay on any non-Sonos device on your network or by disabling auto lock in your iOS device's settings menu under display and brightness.

If you are getting song skipping from other sources, this guide has some great troubleshooting tips.

If you still have issues after trying the above guide, please submit a diagnostic report and reply here with the confirmation number.
Sorry, I thought I was on the Songs Skipping thread. I understand I should change my wifi channel to 1, 6 or 11, but I just installed a new mesh network router that chooses a channel with the least interference. And this problem persists from when I had the previous router that used the prescribed channels. Songs from my library skip, whether I'm telling Sonos to play "from my music library" or "from this device." Streaming services work ok.
You've created a new topic. Reproduce the issue/behavior and subsequently submit a diagnostic report within 15 minutes and reply here with the confirmation number so that a technician can take a look into it.


@Jeff, You beat me to it. 🙂
Badge
Your confirmation number is: 1384249773.
Userlevel 7
Badge +20
Your confirmation number is: 1384249773.

Thanks for the report. Your router is creating 3 networks all on the same wireless channel. This is causing interference, and making it hard for your Sonos speakers to stay connected. They are all on channel 4, which overlaps with channels 1 and 6. It would be best to have your main network on channel 1, and the other 2 networks on 6, or vice versa.
Userlevel 7
Badge +21
The forum software is no help here, while Lawrene did give this topic a title that would have avoided the confusion, the forum hides it by default when opening the topic from the show new topics option, maybe other methods too.

Sonos staff... Any chance this could be passed to the forum software folks and they could adjust the initial page location so the topic title is shown?

Yes the topic title is shown in the small print in the Browser title bar but most folks ignore that.
Badge
It's my understanding that since the six Sonos speakers are directly on my Wifi's channel, not on a Boost, that they don't have their own channel. I know the WiFi has a main and a guest network; not sure about the third network you're seeing created. Are you seeing a way I could discern and change the channel the Sonos is using without changing the channel the router is using for the rest of my devices? The router says it's using channel 4 (with an arrow to 7, not sure the meaning of that) on 2.4GHz, which would be the Sonos' right? And channel 36 on 5GHz, which would be all the other devices. On the second node of the mesh router, it reports using Channel 8 (arrow to 4) on 2.4 GHz and channel 36 on 5GHz.
Userlevel 7
Badge +20
It's my understanding that since the six Sonos speakers are directly on my Wifi's channel, not on a Boost, that they don't have their own channel. I know the WiFi has a main and a guest network; not sure about the third network you're seeing created. Are you seeing a way I could discern and change the channel the Sonos is using without changing the channel the router is using for the rest of my devices? The router says it's using channel 4 (with an arrow to 7, not sure the meaning of that) on 2.4GHz, which would be the Sonos' right? And channel 36 on 5GHz, which would be all the other devices. On the second node of the mesh router, it reports using Channel 8 (arrow to 4) on 2.4 GHz and channel 36 on 5GHz.

In this case the 5 ghz network is less of an issue. I see coming from your router 3 networks. The main network, to which your Sonos speakers connect, a network called "Bob" and a network with no SSID name listed. In your router's wireless configuration page you should be able to set the 2.4 ghz networks to a static channel. I'd recommend setting the main network to 1, and the secondary network to 6, and the blank network should probably be disabled.
Userlevel 7
Badge +21
If none of the Sonos devices are wired to Ethernet then they are on your WiFi, Sonos made a change a while back so that a Bridge or Boost are no longer required to go to Boost mode, wiring any Sonos device will activate it.

I'd also recommend setting the 2.4 GHz channel your Sonos gear is connected to to a static channel (1, 6, 11) as the Sonos gear does not deal well with the WiFi channel changing while it is playing. Using the overlapping channels may appear to give you a quieter channel but the likelihood of that changing as neighbors use their WiFi is higher than on the clear channels.

Something to consider a bit later, given the grief the new mesh stuff is giving you why not switch to Boost mode by wiring a Sonos device to the hub of the mesh device and then being able to set the SonosNet WiFi channel to a clear one and not have to worry about what the new mesh stuff is doing.
Badge
Thanks, Stanley and Jeff. Those are good ideas to try. I'm still trying to master the new mesh network, its app is helpful and clear but perhaps not as clear as I thought. It does not reference that third network you see. I'll let you know how I proceed, and thanks for your patient consideration.
Userlevel 7
Badge +20
Thanks, Stanley and Jeff. Those are good ideas to try. I'm still trying to master the new mesh network, its app is helpful and clear but perhaps not as clear as I thought. It does not reference that third network you see. I'll let you know how I proceed, and thanks for your patient consideration.

No problem. Send along a new report if any issues continue and I'll check it out for you.
Badge
Also, this has been a problem since we got the Sonos system two years ago, hence my little hissy fit at the start of this thread. I hoped the new router would fix it, since the former router was 10 years old. No change. I'm drilling a hole in the wall for ethernet cable to set up the wired Sonos speaker. Need to get that squared away before husband comes home; it pains him to see holes drilled in the wall. 🙂
Badge
I thought this would be more intuitive, but I'm going to need walked through what to do next to make my Sonos system a boost system. One speaker is wired into the router. What next? Unplug all five others and restart? Do i tell them all to disconnect from wifi, or only the one plugged in?
No need to restart. Just wait about 5 minutes, and all of your speakers should just automatically switch over. You can check in the "about my Sonos system" page to see what your Sonos speakers are on. To borrow from an old post from "The LHC":

WM:0 means the devices are running on Sonosnet, with at least one wired component.
WM:1 means the device is running in wireless mode direct to your router's wireless network.
WM:2 means the device is connected to the Playbar using 5ghz wireless, ie it's configured as a surround speaker.

Once you're running on WM:0, I'd encourage you to go in to the settings for wifi data inside the Sonos controller, and "remove" the old info on your SSID. What can potentially happen would be "flapping" between the SonosNet and the wifi, which would potentially cause some issues.
Badge
You're so right! Everyone's on WM:0, and my SonosNet channel is 11. I don't see wifi data inside the Sonos controller; where will I find that?
Badge
I disable wifi on the one plugged in, right?
Gah. I'm not at home to look at that....and I run a Boost network anyway. If I remember properly, it's in settings/network/Wifi settings, and there should be a "remove" or "delete" button when you get to that area.
Userlevel 7
Badge +21
Once you have one speaker wired the Sonos should start automatically moving to Boost mode, usually done in a few minutes. Look at your controller and the Settings - About My Sonos screen. If all have switched over they will be showing WM:0 indicating they are in Boost mode.

Go to Advanced settings and SonosNet Channel and pick the quietest of 1, 6 or 11. Give the Sonos a couple minutes to adjust and you should be fine.

Once it seems stable you can go back to the Advanced Settings - Wireless Setup and if an option to remove the WiFi credentials (not sure of exact wording) appears click it and you'll be in Boost mode.

====

Another thing you can do with your new router, once all the above are done is set up static/reserved IP addresses for all the Sonos devices. Power down the Sonos devices once done, reboot router, power up your wired Sonos then at one minute intervals power up the rest. That seems to avoid IP related issues, in normal operation, during updates and returning from power outages. It isn't listed as mandatory by Sonos but a lot of us here swear by it as a starting point for a bunch of problems.
Badge
I will definitely do that, Stanley, thanks. I'm going to give it some time, since the option to remove the wifi credentials is not appearing yet in Advance Settings -- Wireless Setup. It shows an Alternative setup screen with a Continue button, but when I tap that it reverts to the Advanced Settings screen. How do I figure which channel is quietest of 1, 6 or 11?
Userlevel 7
Badge +21
To find the quietest channel download an app to your phone or tablet that monitors the WiFi and it will usually have a page that shows the quietest channel. If not you can watch the signals and pick the one that looks best.
Badge
Dammit! I did the set up static/reserved IP addresses for all Sonos speakers, rebooted router, 1 minute intervals to reset speakers. Now only the wired says WM:0, and all the rest say WM:1. Diagnostics Conf. No. 383580053.
Userlevel 7
Badge +21
Maybe the Ethernet Sonos and the WiFi Sonos are on different networks and couldn't see the WiFi to wired change?

If you can hook Ethernet to any other Sonos device and see if it switches modes. Unplug the Ethernet and see if it stays in WM:0 mode.

The forum Sonos Staff are likely gone home but if you want to try the twitter and facebook support are open 24x7 and may have another suggestion.
Do not disable wireless on the Ethernet connected speaker. That will disable Sonosnet and force all the others back to WM:1. Reactivate the wireless, let them all reset to WM:0, then reset the WiFi credentials (aka delete the SSID and password). This is very different from disabling the wireless.
Badge
You are sweet to reply, Stanley. No, I'm done for the day. I'll randomly unplug some stuff, plug it back in, take a reading, go to bed. Tomorrow is another day.