Answered

Songs on device skip on sonos one

  • 20 February 2018
  • 38 replies
  • 651 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

38 replies

System Preferences>Energy Saver. Choose which version (battery or Power Adaptor) and change the settings for Computer sleep. Also turn off (no check) "Put hard disks to sleep when possible"

Likely an issue with duplicate IP address for that speaker in the same room.
Userlevel 1
Badge
System Preferences>Energy Saver. Choose which version (battery or Power Adaptor) and change the settings for Computer sleep. Also turn off (no check) "Put hard disks to sleep when possible"

Likely an issue with duplicate IP address for that speaker in the same room.
thanks I turned that off.

It happens to other speakers too though. How would I check a duplicate IP address
Userlevel 7
Badge +19
Hi there, michael319. Thanks for posting and welcome to the Community. In most cases with skipping, it can be attributed to network connectivity and/or wireless interference. Based on the diagnostic report you are set up using a standard wireless setup. Because of this, each individual speaker needs to talk to the router before sending data to other speakers. In comparison, a BOOST configuration allows for Sonos devices to speak directly to one another. Check out this article that outlines the differences and benefits of each configuration. In most cases, a BOOST configuration (which is when any Sonos device is left plugged into the router directly via Ethernet) leads to a more robust Sonos system. This is because the speakers can "telephone" data over shorter pathways, rather than each speaker sending data over longer distances encountering more interference. According to the diagnostic report, the Kitchen and Bedroom are both having a hard time maintaining a steady connection to the Verizon router. Switching to a BOOST configuration could certainly address this.

Additionally, any information about your local network (i.e: make and model of your router and any extenders or access points) could help us understand exactly how Sonos is interacting with the network.

If you switch to the BOOST configuration, submit another diagnostic report and I'll be happy to compare results.
Userlevel 1
Badge
Hi there, michael319. Thanks for posting and welcome to the Community. In most cases with skipping, it can be attributed to network connectivity and/or wireless interference. Based on the diagnostic report you are set up using a standard wireless setup. Because of this, each individual speaker needs to talk to the router before sending data to other speakers. In comparison, a BOOST configuration allows for Sonos devices to speak directly to one another. Check out this article that outlines the differences and benefits of each configuration. In most cases, a BOOST configuration (which is when any Sonos device is left plugged into the router directly via Ethernet) leads to a more robust Sonos system. This is because the speakers can "telephone" data over shorter pathways, rather than each speaker sending data over longer distances encountering more interference. According to the diagnostic report, the Kitchen and Bedroom are both having a hard time maintaining a steady connection to the Verizon router. Switching to a BOOST configuration could certainly address this.

Additionally, any information about your local network (i.e: make and model of your router and any extenders or access points) could help us understand exactly how Sonos is interacting with the network.

If you switch to the BOOST configuration, submit another diagnostic report and I'll be happy to compare results.
thanks for that. I just connected to Ethernet and did wireless set up. I attached an image. Is it connected correctly? I put it on channel 1.
Userlevel 1
Badge
System Preferences>Energy Saver. Choose which version (battery or Power Adaptor) and change the settings for Computer sleep. Also turn off (no check) "Put hard disks to sleep when possible"

Likely an issue with duplicate IP address for that speaker in the same room.


My WiFi still disconnects when I close the lid of the laptop leaving the function of steaming through the Mac library pointless.

Any fix for that?
Userlevel 1
Badge
I need a longer Ethernet wire. Is this okay? Mediabridge Cat6 Ethernet Patch Cable ( 15 Feet ) - Soft Flex Tab - RJ45 Cord - Black ( Part# 32-699-15B ) https://www.amazon.com/dp/B00YPH0XT2/ref=cm_sw_r_cp_api_-MpKAb71FBTPJ
Userlevel 7
Badge +19
michael319: That should work without a problem. Let us know how you get on. Thanks!
Userlevel 1
Badge
michael319: That should work without a problem. Let us know how you get on. Thanks!

Okay every since I plugged my speaker to Ethernet I haven’t seen skipping. Also I been using music playing from my MacBook more instead of phone.

My phone WiFi isn’t great in the bedroom so it wasn’t a good choice for upstairs. But downstairs I do use my phone to play music to the sonos.

Here is my new diagnostic number. 1297992572

Only thing is. Since the new sonos update yesterday I been getting the attached error. But if I keep trying to play songs it eventually plays. So idk what that’s about.
Userlevel 7
Badge +19
Thanks for the update. At this point, I'd recommend giving our support technicians a call to troubleshoot this with you in real time. They are able to use a remote session and take a closer look at how data is being routed along the network.
Userlevel 1
Badge
Thanks for the update. At this point, I'd recommend giving our support technicians a call to troubleshoot this with you in real time. They are able to use a remote session and take a closer look at how data is being routed along the network.

Why would I call tech. I said it isn’t skipping. That error only popped up from playing songs after the sonos app update. It’s very rare.

What does my diagnostics this time indicate?
Userlevel 7
Badge +19
While you said the skipping did subside, you did say:

Only thing is. Since the new sonos update yesterday I been getting the attached error. But if I keep trying to play songs it eventually plays. So idk what that’s about.
From my perspective, it appeared that you would have liked some clarity on what the reason is for the error and how to make it go away. Apologies for any confusion caused.

Your diagnostic report does not show any problems regarding interference, but it does show problems attempting to access your Music Library on your MacBook Pro (numerous times - approximately 2 minutes prior to running the diagnostic report). While this normally wouldn't directly cause the 1002 error you posted, it certainly could be a side effect. This would warrant troubleshooting in real time with our technicians to get a closer look at the network and determine the root cause.
Userlevel 1
Badge
While you said the skipping did subside, you did say:

Only thing is. Since the new sonos update yesterday I been getting the attached error. But if I keep trying to play songs it eventually plays. So idk what that’s about.
From my perspective, it appeared that you would have liked some clarity on what the reason is for the error and how to make it go away. Apologies for any confusion caused.

Your diagnostic report does not show any problems regarding interference, but it does show problems attempting to access your Music Library on your MacBook Pro (numerous times - approximately 2 minutes prior to running the diagnostic report). While this normally wouldn't directly cause the 1002 error you posted, it certainly could be a side effect. This would warrant troubleshooting in real time with our technicians to get a closer look at the network and determine the root cause.
i think the reason was the songs wer still indexing becaus I updated the library on the Mac book. I’m going to keep an eye out.

I do want to thank you for the suggestion of the cable. It helped tremendously!
Userlevel 7
Badge +19
Keep us in the loop should you run into any other problems. I'm happy to help whenever I can. 😃