Answered

Songs not encoded correctly

  • 12 February 2019
  • 12 replies
  • 446 views

Hello
Sonos is connected in our school server using the desktop app and ethernet cable. All the songs have played once and then gives the error "Not encoded correctly" and stops playing. I have tried playing them from ipad with the app which I have not been successful as well. Any help will be greatly appreciated
icon

Best answer by Jeff S 15 February 2019, 19:49

I have submitted the support diagnostics just now and the confirmation number is 1276410157
Thank you


Hi there,

Thanks for sending in the report. The cause of the errors is not immediately clear from your report. I think it would be best to have our phone team take a deeper look at this one. Please give us a call, you can find our number here.
View original

12 replies

A few months ago. Sonos were investigating an issue, where some AAC and .m4a files reported this error when playing from a computer's hard drive. I think they fixed the issue. Just wondering if you are currently running the latest v10.0 of the Sonos App and that the speakers have been updated?

To see their version goto 'Settings/About my Sonos System' in the Sonos App.
Thank you Ken for replying.
Yes, we have updated the sonos app and it is running on the latest version
It's more likely to be a simple case of packet loss due to a basic networking fault. Reboot the network to ensure everything gets a fresh, unique IP address. If problems persist I would suspect a dodgy Ethernet cable.
The speakers will not detected by the desktop app if they were not on the network. We have tried rebooting the server sometime back but no luck.
Can I suggest you submit a Sonos diagnostic (see below link) and post the reference back here.

When you have posted the reference, I will try to flag up your post to the Sonos Support Staff to take a look, but can’t guarantee you will get an answer straight away.

Submit System Diagnostics

There is a 24/7 Sonos Support contact details here too:

Contact Sonos Customer Care/Twitter (24/7) etc.
The speakers will not detected by the desktop app if they were not on the network.
They could if there was an IP address conflict. Traffic would intermittently go missing.

As for potential Ethernet cabling issues they're often intermittent too.
Maybe get the IT department to reserve the Sonos IP addresses in the DHCP Servers Reservation Table to prevent any potential addressing conflict.
I have submitted the support diagnostics just now and the confirmation number is 1276410157
Thank you
I have checked with the IT Department and they have confirmed that there is no addressing conflict.
I have submitted the support diagnostics just now and the confirmation number is 1276410157
Thank you
I have flagged up this thread to support. Hope it gets sorted soon.
Thank you very much Ken and Ratty
Userlevel 7
Badge +20
I have submitted the support diagnostics just now and the confirmation number is 1276410157
Thank you


Hi there,

Thanks for sending in the report. The cause of the errors is not immediately clear from your report. I think it would be best to have our phone team take a deeper look at this one. Please give us a call, you can find our number here.

Reply