Question

Songs keep restarting songs over and over


I've owned sonos for a few years now. For some reason even with rebooting my wifi my songs restart from beginning over and over. I stream spotify, amazon, and pandora. It's driving me nuts! Please help.

36 replies

Check whether you've enabled repeat play.

https://sonos.custhelp.com/app/answers/detail/a_id/1060
Let me clarify. The song stops mid way through song and starts over. It does this over and over. It's maddening!
This is happening to me too. Just purchased the play:5. Did this just start happening or has it been happening for awhile?
I'm experiencing the same thing. As if Christmas music isn't annoying enough, it usually takes 4 or 5 cycles before we realize it's been the looping the first half of same song for the past 10 mins...

I'm running a single Play:1 (older gen) speaker and have experienced this happening while streaming music from Amazon Music, both an Amazon Playlist, an Amazon Station, and music from my library. There's no way to induce this behavior that I've found, and it's not on every song. It just happened on 2 songs and both times I was looking at my phone.
Visually in the Sonos app the track playback seems normal but the audio coming out of the speaker restarts at the beginning of the song, even when 1m34s into the track. Additionally when the end of the song is reached according to the app, the song continues playing (and then randomly restarting) and the app just shows that all 4:17 of the song has been played but it's not going to the next track.

Oh as I type this it happened again to a 3rd song, though it played 1 song successfully. That 3rd song restarted after ~10 seconds, then again after ~20 seconds, and again at exactly 2:30.

I've also been listening to long mp3 podcasts played from my device (android phone) and without any problem there.

So maybe it's unique to Amazon Music? Can I send a diagnostic file to Sonos somehow? I've seen this happen a few times over the past several weeks.
Sonos Controller Version 7.0, Build 34735162b. Play:1 is build 34735162c and hardware version 1.8.3.7-1
jgcook5 wrote:

Can I send a diagnostic file to Sonos somehow?


Via Advanced Settings, or Help on the Desktop controller. Post the confirmation number.
"I'm running a single Play:1 (older gen) speaker and have experienced this happening while streaming music from Amazon Music, both an Amazon Playlist, an Amazon Station, and music from my library. There's no way to induce this behavior that I've found, and it's not on every song. It just happened on 2 songs and both times I was looking at my phone.
Visually in the Sonos app the track playback seems normal but the audio coming out of the speaker restarts at the beginning of the song, even when 1m34s into the track. Additionally when the end of the song is reached according to the app, the song continues playing (and then randomly restarting) and the app just shows that all 4:17 of the song has been played but it's not going to the next track."

Exactly. Same issue in the app visually as well.
Its interesting this was an Amazon thing. I am going to look at this more as my issue may only lie with Amazon too. I am going to stream pandora and music from my library over the next few days to see the difference. If it is an Amazon thing then I would lay the blame there. However this doesn't explain why when I had the bose Soundtouch for about 2 weeks I streamed Amazon with no hiccups at all. So somehow the bose is more efficiently using the wireless? Not that that matters as the Soundtouch app is garbage.
I am having exactly the same issue described with my new Play:5. As the OP said: thoroughly maddening.

I'm curious though (OP mentions having used Sonos products for years), is this been a known or persistent issue with Amazon Music? They are my go-to library and Sonos might not be for me if the two don't play nicely.
Yes, this started happening to me too today. It is intermittent, and doesn't do it with every song. So far it has happened when streaming music from my laptop and from Amazon.
Ok, so this just started happening and is driving me CRAZY!!! I am attributing this to the recent Sonos update I just did but may be something else. Sonos please help! Very random and unpredictable.:(
Userlevel 1
Happening to me too. Only just noticed it. Had Sonos for years have 2 play 1s and 2 zp80s. Doing same thing randomly goes back to the start of a song and plays it again. Only pattern is streaming from amazon music (not unlimited)
Userlevel 1
Also doing it on Apple Music. Also tried to clear the queue and it won't let me it does nothing and then it has added a load of songs already in my queue earlier to the end of the queue. Oh dear. Have to say this is the first time since I bought this that i have experienced anything like this. Hope they fix it soon.
Reporting in that this is happening to me intermittently, seemingly only on Amazon music. It happened prior to upgrading to Amazon Unlimited, and also happens sometimes after upgrading, so that's not the difference...
Happening to me as well. Even my direct line via optical is cutting out ever now and again for about 8 seconds. The main problem is with streaming Apple Music though.
This is happening to me as well, primarily on Amazon music. Doesn't matter whether I control from my phone or computer. Completely unlistenable. Seems to be working OK with Pandora.
I am having this issue as well. It has been happening for about 2 months and only occurs when using Amazon music. I can listen to Pandora for hours or my own music library without any issues. Would love to know how to get this resolved!
Userlevel 6
Badge +3
Hey guys, this sort of issue is usually a result of network trouble, the buffer for the track runs out and instead of skipping it instead backs up to the beginning of the song. If this happens again, the troubleshooting to start with are the standard network issue steps, like checking for wireless interference, seeing what might be slowing down the network, and some basic steps there. We'd be happy to help if you'd like to submit a diagnostic from your Sonos system and reply back with your confirmation number here we can take a look.
Ryan S - No...the network is NOT the problem! It's obvious that many of us are having this problem recently. It has made Sonos useless since the first song in a queue keeps repeating, with none of the other songs in the queue playing.
Userlevel 6
Badge +3
Pegbody wrote:

Ryan S - No...the network is NOT the problem! It's obvious that many of us are having this problem recently. It has made Sonos useless since the first song in a queue keeps repeating, with none of the other songs in the queue playing.



If the first song in the queue repeats non-stop you might have Repeat One set up. That button is a three level toggle within the Queue on the top of the Queue menu, which lets you play the same queue over and over again, or just the same song again and again.

If you're having trouble, I'd be happy to take a look. Feel free to submit a diagnostic from your Sonos system and let me know the confirmation number.
Any resolution on this? It is happening to me as well and it is indeed driving me a bit crazy.
Userlevel 1
Same here. Using Apple Music on a Play 3: Occasionally a track will "start" with controllers showing time progression but no sound coming out of speakers, then the controller restarts the track, and either it plays the second time, or I get a "could not connect" message.
Userlevel 1
FYI: I uninstalled the Sonos controller on my Mac completely and reinstalled: inconvenient, but so far so good. As the problem did seem to be intermittent, I will update if it becomes an issue again.
I have tried all of the above and I am having the same problems. Used to work fine but problem started in the last week. Cannot even get through a single song. Problem seems to be only on Amazon....Pandora works fine.
Userlevel 3
Badge +3
SOoooooo... Does nobody actually read the thread? Did anyone actually read Ryan's helpful responses?

Reality is, this **is** likely a networking issue with your system. Ryan provided a pretty clear description of the problem and suggested that if you needed help in diagnosing your network problems, you could submit a diagnostic and they would look at it to see if they can help.

So posting "me too" isn't helping you or Sonos.

If you want help as to how to troubleshoot your network problems, lots of us on the board here will help... but a few details are helpful:

Is your system wireless entirely, or do you have a device connected through ethernet physically to router? (If you don't know why that matters we're happy to describe why.)

Have you shut down every device that connected to your network (printers, tablets, phones, computers, hubs, Sonos devices, etc.), the router and modem... then restarted the modem, router and then each device one at a time? If not... do so and you have the potential of clearing up any problems with addressing errors on your network.

Have you at least tried a different wireless "channel"? If wireless interference is an issue it can be helpful if you try to change your wifi router channel (use 1,6, or 11) via your router's admin interface... and if that is scary or confusing to you... Submit a diagnostic so Sonos staff can help you when they get a chance to look at it...
I have same problem but only with amazon not pandora. Amazon had been working fine until about a week ago. Rebooted modem and router still same problem amazon only
I know I'm not the most tech savy guy in the world, but I have tried everything Sharkb8t suggested before I posted. None of it helped. Seems if it was a networking issue it should affect all services. It doesn't. It is only Amazon. So I suppose the next step is to submit a diagnostic??????

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)