Song Not Encoded Correctly

  • 26 March 2016
  • 87 replies
  • 33700 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

87 replies

Userlevel 5
Badge +16

Hi @rbrown, for the purposes of testing this configuration, please don’t disable the Wi-Fi interface on whichever player is wired. 

The communication directly between these two devices is a part of what I’m looking at in your system.  

Userlevel 1
Badge +3

@Jean C. 

I ran some extra tests to be sure;

  • disabled wifi on all APs (including router)
  • shutdown the ethernet port for Beam upstairs

There is one song that nearly always skips after a few seconds, this time the song made it over a minute in (but still skipped eventually).  Ive been listening for about 5 minutes since, and ….well I was just about to say it seemed better, but no, another has skipped (I am kind of glad, because in theory these addiotnal steps I took shouldn’t make any difference).

Another diagnostic in case it helps: 1184413131

Userlevel 1
Badge +3

Hi Jean, I just connected the kitchen directly to the router and disabled wifi, the very first song I played skipped out with the error, diagnostic immediately after : 1254483636

 

Let me know if I need to test anything else.

 

@Stanley_4 , thank you, I agreed with your opinion to be honest regarding wifi setup, however if I have to change it I will.  I removed WIFI credentials from the app this morning, assuming that will then utilise SonosNet and therefore I would not have to mess around with my WIFI setup.  I did this but sadly it still had the same issue, many songs erroring.

Userlevel 7
Badge +21

With a multi AP network or one with a lot of new features you give up a lot by dialing it back to be compatible with Sonos gear. I’ve been much happier with wiring at least one Sonos device to my main LAN and moving from Standard (using your WiFi) mode to Boost (using the SonosNet wireless) mode.

That lets me exploit my WiFi system’s full capabilities with no Sonos restrictions. I do only use two channels for my APs though, keeping the best quality one open for my SonosNet connectioins.

Userlevel 5
Badge +16

Hi @rbrown thank you for the update and the additional information. 

If you have your Sonos players on the the WiFi network then you will want to keep your access points on the same channel.

If you have a player wired to the network then you will want to keep the Wi-Fi enabled on that player so that the the two speakers can communicate through direct routing to each other.

The fewer jumps the data has to make between the router and the speaker, the cleaner the playback will be in general.

I’ll keep an eye out for an update on your playback and any additional diagnostic reports from your system.    

Userlevel 1
Badge +3

Thanks for all the help and advice so far Jean.  Yes I have 3 APs and they are on channels 1,6,11 by design, so you say I should switch all to the same channel?  I can, however it not ideal as you know for wifi design/coverage/throughput.

My main router is a Mikrotik 951G-2HnD which has a wifi AP on chan 1, it is downstairs and should be what the kitchen connects to.

I have AP/switch upstairs which is a Mikrotik 941-2nD which is connected via ethernet to the router downstairs,  It is running on chan 6, and the Beam is ethernet connected to this.

I have a 3rd AP which is mostly used for outdoor devices, and it a Cisco AIR-AP1142N-E-K9 running on chan 11.

Let me know if you need any additional info on any of them.

 

I will try playback with kitchen directly connected and report back, and then do the same on wifi with the other APs shutdown.

No worries at all on the tests, I appreciate your assistance!

Userlevel 5
Badge +16

Hey there @rbrown thanks for running that test. It looks like your Cisco switch is also operating on a different Wi-Fi channel which can kinda throw a wrench in things. If possible you will want to have these operating on the same channel. each of your two speakers is now communicating directly to two different access points which may be a contributing factor in this.  Can you tell us any specs on your Cisco and Routerboard access points?

Can you also test audio playback with your Kitchen speaker wired directly to your main router? 

Is it possible to temporarily take down your switch and access points to test playback with only your router broadcasting? 

I realize that this is a lot to ask but it will help us zero in on where in your network the snag is so we can eliminate it.

Userlevel 1
Badge +3

I should add, even though the beam is now on wifi, it is still connecting to the same switch/ap as before, just via wifi instead of ethernet, so probably the STP is still affecting in the same way.  Perhaps if I switch off the beam entirely?

Userlevel 1
Badge +3

Morning Jean,

So I disconnected ethernet on the Beam and enabled WIFI.  Playing on the kitchen I am still seeing songs skipping.

I checked my switch configs and it is using RSTP, I am not entirely confident in setting up the STP so before I start playing with that, is there any other test we could perform to determine if its definitely related to that?

In case it helps, diag report for the tests this morning is 618560680

Userlevel 5
Badge +16

Excellent @rbrown I’ll await an update and additional data. 

Userlevel 1
Badge +3

Hi @rbrown From where I’m sitting the issue could very well be the switch. If the switch is managed, please check the settings to make sure that it is compatible with Sonos. 

Can you re-enable the Wi-Fi interface on your Beam and then detach the Ethernet cable and run a test with your players directly on Wi-Fi rather than a partially wired set-up?

How far would you say the Kitchen player is from the Router and could it be wired as a part of any further tests if necessary?

The switch is a Mikrotik 941-2nD, I’ll check tomorrow to ensure its compatible.

I can certainly enable WIFI and disconnect the ethernet yes, I’ll do that and report back.

The kitchen player is 4m from the router line of sight.  I can wire it for tests yes. 

I’ll report back tomorrow with the Beam on WIFI, and check out the switch settings.

Userlevel 5
Badge +16

Hi @rbrown From where I’m sitting the issue could very well be the switch. If the switch is managed, please check the settings to make sure that it is compatible with Sonos. 

Can you re-enable the Wi-Fi interface on your Beam and then detach the Ethernet cable and run a test with your players directly on Wi-Fi rather than a partially wired set-up?

How far would you say the Kitchen player is from the Router and could it be wired as a part of any further tests if necessary?

Userlevel 1
Badge +3

Hi @rbrown thanks for submitting a diagnostic report. 

I have a couple of general questions about your set-up so I can have a better understanding of your issue.

Is your Beam wired directly into your router or do you have a network switch?

Is there a particular reason why the Wi-Fi has been disabled on your Beam and how far from your Sonos One in the kitchen is it?

Have you rebooted your router since you have been experiencing this issue?

 

Hi,

 

My Beam is wired into a switch, which is wired into my router (Beam is upstairs, router is downstairs).

I disabled the wifi on the Beam because I figured it wasn’t using it.

Distance between the two devices is probably 5 meters or so, on different floors of course.

I have rebooted the router yes.

 

Please let me know if you need any other information, on the other thread I was told to put all APs on the same channel, and various other things related to wifi, but to be honest I couldn’t see that as the issue because even with all APs disabled except the router, I still had the issue.  FYI, I have 3 APs in the house, on channel 1,6,11.

Userlevel 5
Badge +16

Hi @rbrown thanks for submitting a diagnostic report. 

I have a couple of general questions about your set-up so I can have a better understanding of your issue.

Is your Beam wired directly into your router or do you have a network switch?

Is there a particular reason why the Wi-Fi has been disabled on your Beam and how far from your Sonos One in the kitchen is it?

Have you rebooted your router since you have been experiencing this issue?

 

Userlevel 1
Badge +3

Hi there @rbrown . Are you still getting the "track not encoded correctly" error when playing back audio from YouTube Music? If so, please submit a diagnostic report from your Sonos system ( Settings > Help&Tips > Submit Diagnostic ) Please include the confirmation number in a response so that I can take a look at what is going on here. 

Hi, I just did a quick test and the last 2 songs failed, diagnostic 1266361644

FYI I was asked in another thread to try with AirPlay, I haven’t had a chance to check that sadly.  Hopefully this diagnostic can help though, it’s roughly 20% of songs that fail, makes for very choppy listening and the songs can cut at any time.

Userlevel 5
Badge +16

Hi there @rbrown . Are you still getting the "track not encoded correctly" error when playing back audio from YouTube Music? If so, please submit a diagnostic report from your Sonos system ( Settings > Help&Tips > Submit Diagnostic ) Please include the confirmation number in a response so that I can take a look at what is going on here. 

Userlevel 1
Badge +3

This is happening to me a lot with YouTube Music playing on Sonos.  Sometimes a song works, and sometimes it doesn’t, so its definitely nothing with the encoding of the song since its intermittent with the same track.  Very frustrating.

same here: since I upgraded to Sonos App Version 10.6.1 I experience also skipping songs and ‘the song is not encoded correctly’ errors - looking at my Sonos System Error Log the errors started after the upgrade on my devices (Beam and One) - if Sonos Support tells me so, I can submit the diagnostics report

Userlevel 1
Badge +4

Same here… I get both “The song is not encoded correctly”, and Unable to add songs to the Q (1001)

Using Sonos Controller and Apple Music. And I gave up trying to play Deezer, Tidal, or Qobuz… To bad Sonos says they can support the CD Quality songs, Not in my house…. 233MBPS down from the Internet. No suggestions needed, I’ve tried everything for MONTHS UPON MONTHS UPON MONTHS.

Hello out there??? Sonos? Anyone?  I’m having this “song not encoded correctly” issue when trying to play Sirius XM.  Had this problem months ago and then the problem went away.  NOW IT’S BACK!!    

BTW my connectivity is great with plenty of bandwidth.

Any help out there? Thanks.

Userlevel 7
Badge +22
Another thread claims that the Amazon problem with "not encoded correctly" has been fixed (by Amazon). Anyone still seeing this now, please specify which music service and ideally an actual track name.
Userlevel 1
Badge
After last Sonos upgrade I am getting intermittent "not encoded correctly" from amazon albums that previously played perfectly. Please don't make some stuff up about this being my problem or information packet loss (implying the problem is my connectivity). This is just another of many disgusting arrogant technerds problems with the sonos system. Fix it !!! please.

BTW, to you newbies or disgusted oldies, I find that a good pair of Lenovo computer speakers for about $100 sounds 98% as good as a $400 pair of Sonos, and can play anything anywhere that your computer can broadcast. I am a classically trained pianist, not some dufus who doesnt have sensitivity to sound quality. There are great classical performances on Youtube for which a $200 TV soundbar is perfectly adequate.
(see Bernstein conduct Bruckner's ninth, or collections of Sibelius tone poems.).

I really do like sonos sound quality, but they desperately need quality control over their engineers..the quality
control at sonos is hapless..and the controller app is disgusting (dark grey on black slidebars, no file system, no bluetooth capability .... etc etc_
a simple 3rd party app I use on Linux is so much better)
I no longer recommend sonos to friends.
Just to add some detail: same issue happens when (1) I start music from within the Sonos controller on my Mac, and (2) when I try to play music from Pandora. So I don't think the problem is Alexa or Amazon Music.
My Sonos is suddenly unable to play music from Alexa/Amazon music. It starts streaming part of a song, then cuts out after a second or so. Later on, it might play a second from the same song, or try moving to the next one. It tells me the music is not encoded correctly, even though I have been streaming Amazon music for years...

Diagnostic information sent: 2140827513.
Thanks. I was adding it from TuneIn, and Sonos was playing it via Alexa, but I kept getting the message when tapping on it via iPhone or iMac. This morning I’ve looked at two versions within My Radio Stations and one of them is working now. Not sure how but I’ve deleted the offender and all seems good. Cheers!