Answered

Snooze function stops during first snooze period


Userlevel 2
Badge

Alarm comes on.  Notification appears. I hit the Snooze icon.  A notification confirms the snooze and when the music will come on again.  But the music doesn’t come on again.  Anywhere from 3 to eight minutes in, the system just forgets it’s doing a snooze.  Doing testing, the snooze works properly maybe once out of 10 tries.  Spent two hours with customer support - chat and phone.  They had me change the SonosNet channel (“Could be interference”).  Had me unplug everything, including the router, to reset.  The alarm has worked fine for 14 years, then just stopped working a week ago.

I’m on S1.  I have a hybrid system with an ancient Connect:Amp and Connect, plus a new Amp purchased last year (when they scared us into upgrading) and two Play:1s.  I also have a CR200, but the problem happens whether I’m using the CR200 or an Android phone.  And it happens regardless of which “Room” I set for the alarm.

Any suggestions appreciated.  My next move is to try to isolate the problem by removing all components from the system then testing one at a time.  I’ll report back.

icon

Best answer by Corry P 6 May 2021, 11:38

Hi @gleapman 

Thanks for all your work!

Any music services? That’s weird, to say the least. One would have made sense, but this definitely needs investigation.

Please get in touch with our technical support team at your convenience. Thank you.

You may want to refer them to this thread to avoid explaining it all again - if you’re on a phone call, ask them to search this forum for “first snooze” and it’s the first search result.

View original

10 replies

Userlevel 6
Badge +16

Hi @gleapman 

Thanks for your post!

Please swap the ethernet cable connecting your Patio device to the network - the Connect:Amp there has been reporting an issue with the cable since at least January.

 

Userlevel 2
Badge

Corry,

I appreciate you digging into the case.  I swapped out the cable for a shorter one.  (Both test fine on my cable tester.) That did not fix the problem. I also moved the ethernet cable to the Amp: House and that didn’t help either.  With the replacement cable plugged into Connect:Amp: Patio, I ran a diagnostic - confirmation number 1673443329.  You’ll see the only components I have online are the Amp and Connect:Amp.

I’ve run a bunch of different tests today with different combinations of components and where the cable is plugged in.  I’ve powered down then powered up the router and the components before several of the tests.

Next up, a factory reset of the Amp:House, then powering up only that, connecting and testing the snooze.

Thanks again.  I’ll let you know.

Userlevel 2
Badge

Did a factory reset of the Amp, plugged in the ethernet cable, then created a new system with just that one component.  Same problem with snooze.  Did the same with a Play:1 and still had the problem with snooze. 

Here are the diagnostics.

Amp - 1424726970

Play:1 - 1813496001

Userlevel 2
Badge

Breakthrough (but not a solution).  One thing I hadn’t tried is a different music source on the alarm.  All previous tests used Pandora.  When I switched to the chime, the snooze worked.  I then tested it with a Sonos Playlist, and it worked.

These tests were on the original system, with just the Connect:Amp: Patio and the Connect.  First I ran another test with Pandora and it didn’t work.  But it did work with the chime and playlist.  After several tests with various music sources, I ran the diagnostics - confirmation number 1813327307.

I’ve been using a paid Pandora service as the alarm music source for more than ten years with no problems.  What’s extra strange is that the alarm comes on with the Pandora music source.  Then partway through the first 10-minute snooze, the Zzz and “Stop Alarm” button disappear from the display on the CR200.  Obviously, I’d prefer to use Pandora as the music source.  Please let me know if Sonos will work on a fix.

I added back the Amp: Home and Speaker:1 to the system, and a test of an alarm/snooze with the chime and playlist through Amp: Home worked correctly.  (A good thing since my wife didn’t want us sleeping on the patio.)

Userlevel 6
Badge +16

Hi @gleapman 

Thank you for your testing.

I’m seeing a few issues relating to SSL and DNS on the speakers - could you please switch your router off for at least 30 seconds to reboot it? Thanks.

If that doesn’t help matters, I recommend removing your Pandora account from Sonos and adding it back on again. You can see how on our Remove a music service account from Sonos page. Please then test again, thanks.

 

Userlevel 2
Badge

I tried all of the suggested tests and the problem persists.  I also combined all of them by removing Pandora, unplugging all of the Sonos components, rebooting the router, then powering up the Sonos components and adding back Pandora. For many years I had reserved addresses on my network for the Sonos components.  I deleted those reserved addresses and rebooted the router.  Still no change.  Let me know if you want me to run the diagnostics again.

If the SSL or DNS issues can be addressed locally, please let me know what you’d like me to try. 

Thanks again.

Userlevel 6
Badge +16

Hi @gleapman 

The reboot of the router should have been enough to clear up SSL issues, but you can try changing the DNS servers in your router settings to those of Google (8.8.8.8 & 8.8.4.4) - though how to do this will vary according to your particular router. Reboot your router after doing so.

I’m not convinced these were the causes of the issue, however - just things worth addressing, in case.

Could you please test using another online source for your alarm (a radio station, for example) for a week or so until you’re convinced it’s only Pandora causing the issue? If this turns out to be the case, I recommend you get in touch with our technical support team, so they can properly document the situation and investigate. We also have some test accounts with Pandora that we can try on your system. Thank you.

Userlevel 2
Badge

I’ll get in touch with technical support after additional testing.  I just wanted to document the latest findings in the thread.

I did the tests you requested, trying other music sources.  This is strange.  I mostly used Sonos Radio to test several sources.  (I did a few with TuneIn stations.)  When I used the stream of any over-the-air radio station, snooze worked properly every time.  When I used any of the music streaming stations, snooze failed every time.  I didn’t keep count, but I think I did more than a dozen tests, getting the same results every time.

After all the tests, I submitted diagnostics - confirmation number 1428602671.

Userlevel 6
Badge +16

Hi @gleapman 

Thanks for all your work!

Any music services? That’s weird, to say the least. One would have made sense, but this definitely needs investigation.

Please get in touch with our technical support team at your convenience. Thank you.

You may want to refer them to this thread to avoid explaining it all again - if you’re on a phone call, ask them to search this forum for “first snooze” and it’s the first search result.

Userlevel 6
Badge +16

@gleapman

You’re getting ethernet errors on Patio again - 14 in one minute. I recommend throwing that cable away. If it’s connected to a switch, you may want to investigate the cable that connects the switch to the network.

I’ve found your existing case and added a link to this thread there. Please use your existing case number when getting back in touch (if you’ve forgotten it, I can send you it in a private message).

 

Edit: if you’re convinced the cable is OK, can you try another port on the device?

Reply