• 23 October 2021
  • 4 replies


I am generally very pleased with my Sonos setup and it has revived my passion for good sounding music. I usually stream from my MacBook and generally have no issues, apart from when I need a break or a gap in listening. After a break I find it difficult to start listening again, Sonos just won’t seem to wake up? I am using Apple streaming and the only way I seem to be able to start listening again is to quit the Apple Music app, quit the Sonos app click on the airplay icon in Apple Music and select my room. This works but I’m wondering if I need to change a setting somewhere so that I don’t have to go through this lengthy process.






Best answer by Corry P 26 October 2021, 10:59

View original

4 replies

Looking online, there are quite a few Airplay issues with the MacBook and plenty of things to try to resolve the problems. Here is one sample link I found (but there are many others, if you perhaps Google the issue):

Userlevel 7
Badge +17

Hi @Burtqwert 

Welcome to the Sonos Community!

If you initiate playback from the Sonos app (after adding Apple Music to Sonos, if not done already) you will find that resuming playback is more reliable (the speaker gets the stream directly from Apple rather than via your MacBook).

How to add a music service to Sonos

I hope this helps.

Thank you @Corry P 

I agree, it is more reliable, I seem to enjoy the Apple Music interface design and usability more than the Sonos app. I just thought I would ask around though to see if I had missed anything in settings or something. It works just fine on my phone and iPad so I guess I’ll put it down to my Mac getting a little old.


Cheers for the help

my experience is that AirPlay streaming from my iPad is much more convenient than from my MacBook Pro because the iPad stays active where the MBP may ‘go to sleep’ - you basically do not need the Sonos App to stream from the Apple Music App - you can directly select the AirPlay speakers on your iPad