Answered

Sky Q remote not recognising Playbase

  • 26 October 2021
  • 7 replies
  • 36 views

When I play music through my Playbase I use the Sky Q remote to control the volume & it works perfectly.

When I have the TV on I cannot get the Sky Q remote to play sound through my Playbase. I have been through settings on Sky Q but it only seems to recognise the Sonos Playbar. I have tried to click on Playbar but the Sky Q remote still does not change the volume.

Connected to Sony 65AG9BU 4K OLED TV through optical audio output.

Please can anyone help? Thank you

icon

Best answer by Corry P 28 October 2021, 10:14

View original

7 replies

Userlevel 7
Badge +17

Hi @Lily 60 

Welcome to the Sonos Community!

Until I read your post, I wasn’t aware that the Sky Q remote was even programmable. If you don’t get any advice from our community members here, I recommend you try Sky’s own support forums or support options.

As I see it, the Playbase has no reason to ignore IR signals from the remote just because you are watching TV, so I have to assume that the Sky Q remote is aware that the TV is on and stops transmitting IR as it believes HDMI-CEC will do the job instead (CEC doesn’t work over optical, so the volume command only gets as far as the TV). I assume there will be a setting relating to IR always being on in the Sky Q settings, somewhere.

I hope this helps.

Hi Corry. 
Thank you for responding to my question. 
The Sky Q remote has only recently stopped playing sound through TV. Perhaps there has been an update that no longer recognises Sonos Playbase, due to Playbase being discontinued. Sky Q does give Sonos Playbar as an option with sound system when going through Sky Q settings. If that’s the case I would be very disappointed because the Playbase is perfect to sit our TV on & the sound is very good, especially with the sub we have attached. 
I will follow your advice & look at Sky Community but is it possible that you can check why Sky no longer recognises the Playbase?

Userlevel 7
Badge +17

Hi @Lily 60 

I can assure you that no such update has happened. Or can happen.

I’m not sure what you mean by the remote “no longer recognises the Sonos Playbase”, as it doesn’t need to. Unlike most media products that do have remotes, Sonos devices learn the codes of other remotes - there are no Sonos remote codes for your Sky Q to use/select. However, a Playbar and a Playbase are indistinguishable from the point of view of the Sky Q box/remote, so I recommend you try that setting. For what it’s worth, the Playbar is also discontinued - it makes no difference.

I’m also not sure what you meant by “the remote stopped playing sound through TV”. Do you get no audio at all from Sky, via the Playbase? Or is it that you cannot control the volume with the remote? Regardless, the remote doesn’t play audio through the Playbase.

Assuming the remote does transmit InfraRed when the TV is off, all I can really recommend is to go through the remote programming steps in the Sonos app. Instructions are on our Control Sonos home theater with your TV remote help page. It doesn’t really explain why it works when the TV is off, however, so Sky are the best people to talk to, I think. I have interacted with many customers that have Sky Q and I have never encountered this before - perhaps Sky have done something to the remote firmware recently.

If none of this helps, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

 

Good morning Corry. 
Thank you for your quick reply & helpful advice. 
Playing music through Sonos is not a problem & we enjoy the very good sound on all our products. Problem is getting sound from TV through the Playbase. We will try setting up our TV & Playbase again. 
Thank you. 

 

Userlevel 7
Badge +17

Hi @Lily 60 

Understood. That makes it a situation I am more familiar with!

In that case, I recommend you follow the steps on our Sonos home theater product does not output sound help page.

Checking the optical cable’s connection is a good place to start. Please also check the cable for kinks or damage - optical cables are not fond of kinks.

It may help to reboot the TV by unplugging it from power for a few minutes. Standby does not have the same effect.

If you have no luck, please submit a diagnostic while the Playbase should be playing TV audio, and reply here with the number given. Thanks.

 

Hi Corry. 
Success. Unplugged, rebooted, TV & Sonos, up & running. Whichever gremlin invaded our system has gone. Just completed Trueplay & looking forward to better sound from TV tonight. 
Thank you for your patience & helpful advice. 

Userlevel 7
Badge +17

Hi @Lily 60 

Fantastic - that’s good to hear! Thank you for updating us here too.

You are very welcome!

Reply