Sky Fibre Broadband & Sonos

  • 24 April 2021
  • 6 replies
  • 61 views

Userlevel 6
Badge +16
  • Headliner I
  • 998 replies

Hi all, and a shout out to the sonos gurus as I’m stuck and pi**ed off.

Had BT broadband and Sky TV (Q and Mini Box), all good and sonos on mesh network. Boost lived on 24 port unmanaged switch.

Moved to Sky Fibre yesterday (Friday 23rd April 2021) and I can’t get any of my devices in the app.

I took the Boost and plugged into router directly and managed to add the Move in the app (V2) but nothing else - even on my iMac it’s not connecting.

I think my only option is to factory reset all my sonos kit which is a fair amount of resetting - would rather not take that path but it’s F**ked!

The Playbar and two ones (SS) still work on the TV via optic but can’t see or control anything.

I’ve attached two screen dumps of Sky router settings - this is how I had my BT set and best to separate channels in my opinion.

So my gurus, you know who you are - please help as I just can’t fathom this out and with my Philips Hue lighting having the same issue (fingers crossed that’s fixed) then my poor old head is melting under the lava of frustration.

 


6 replies

Did you reboot everything after the router change?

For Sonos units that means disconnecting power, waiting ~15 seconds, then reapplying power. 

Userlevel 6
Badge +16

@ratty you need to get a life, you live on the sonos community ;o) “Only joking”

I did at start whilst Boost was on switch -  haven’t tried since connecting Boost directly to Sky Router.

I’ll give it a go tomorrow mate as this is doing my brain in and like I said my Hue lighting was down and took me ages to fix that, had to reset it all and add all the lights, dimmers and motion sensors etc.

I’ll get back here when I’ve tried reboot, but for now thank you.

By tomorrow the problem may have cleared spontaneously, as the Sonos units will probably have requested new IP addresses from the Sky router of their own accord.

 

@ratty you need to get a life, you live on the sonos community ;o)

I don’t post as much now. I did of course recognise the Minion.  

Userlevel 6
Badge +17

Hi @Dave 

Factory resetting your system is unlikely to help matters. The fact that you were able to set up the Move is probably to do with the fact that the Move will not make use of SonosNet and thus connects to your WiFi.

As Sky Q boxes will repeat a Sky router’s WiFi, but not WiFi from another brand, I suspect your phone/tablet may be connected to that and causing problems (but not between it and the Move, which is probably connected to Sky Q too). The fact that your system is currently online to our servers supports this (unless you’ve fixed it all by now).

To test if this is the case, please unplug the Sky Q box from power and wait for your phone to reconnect to WiFi, then open the Sonos app.

 

Userlevel 6
Badge +16

@Corry P 

If you noticed I have changed the wifi ssid on both channels in the Sky router and phone is connected to Grant-5 (5GHz) So not on Sky Q wifi - tell me if wrong?

Opened up the sonos app this morning and it’s showing all devices except the Move now.

I have Boost in back of router but wish to move it back to switch - don’t know what is going on and very frustrated.

How do I get the Move back online?

Userlevel 6
Badge +17

Hi @Dave 

If you noticed I have changed the wifi ssid on both channels in the Sky router and phone is connected to Grant-5 (5GHz) So not on Sky Q wifi - tell me if wrong?

I would need a diagnostic to know anything for sure. A Sky Q box will repeat your Sky WiFi, regardless of what you’ve named it. While splitting the bands to have different SSIDs helps Sonos stay connected to your WiFi, it does nothing to prevent your Sky Q box from repeating your WiFi signal and doing so in such a way that any device (your Move or your phone) that connects to it cannot find the rest of the system (that is not connected to Sky Q), or, for that matter, the rest of your network..

Opened up the sonos app this morning and it’s showing all devices except the Move now.

Your phone will now be connected to your router’s WiFi, but the Move is still connected to the Sky Q box. For me, this is more confirmation that I am correct.

I have Boost in back of router but wish to move it back to switch - don’t know what is going on and very frustrated.

Please move the Boost back to the switch - that shouldn’t be a problem.

How do I get the Move back online?

I’ve come to the conclusion that the only way you’ll be able to prevent the Move from connecting to Sky Q is to disable Sky Q’s broadcast of 2.4GHz. This is done by the hidden engineers menu. To access this use the Sky remote control. Press Home and you should see a menu with the 'Settings' option highlighted. Press 0,0,1 on the remote (with Settings highlighted) and then 'Select'. This will open the engineer's menu and in here you can disable the 2.4GHz broadcast. As long as Sonos doesn’t know the 5GHz credentials, the Move now won’t connect to the Sky Q box. If you need to remove the 5GHz credentials from Sonos, you can do so in Settings » System » Network » Networks. The Sky Q box will now only use 5GHz for streaming On Demand TV - be sure to test that it still performs adequately. 

As your phone may still connect to Sky Q 5GHz (and you probably want your phone to still connect to 5GHz for the better performance), if you ever can’t connect to Sonos the first thing to do would be to toggle WiFi on your phone off and on while closer to your router than to your Sky Q box.

I do recommend, however, that you get in touch with our technical support team, who have tools at their disposal that will allow them to verify that what I am suggesting is happening is happening.

 

Reply