Answered

Skipping tracks halfway through songs....


I play songs on my iPhone and they skip halfway through, I hate this system!!! Any fixes? The last update has made it worse.
icon

Best answer by Misfit 11 June 2019, 20:46

View original

34 replies

Userlevel 1
Badge
Having the same problem with 2 Play:1's and 1 Play:3. Sonos used to work great and so I purchased additional speakers. Recently it has become useless for playing music stored on a device. It happens on both my iPhone 8 and my iPad. (Both are new) I have tried disabling the auto lock, still skips songs. I have changed the wireless channel on my router (1, 6, & 11), still skips songs. Nothing else in my house has changed. Sonos used to work, now it does not. Do not tell me to purchase a NAS, do not tell me to keep a computer on at all times to act as a music server, do not tell me to use a streaming music service that I have to pay for, and do not tell me I need to re-configure all my other devices so that Sonos can perform it's most basic function. I want to play the music I have already purchased and I want to play it from my phone/ipad, like Sonos advertises, and like I used to be able to. This all seems to have started happening after an update. I have submitted a diagnostic report, the confirmation number is #366289417.
Userlevel 1
Badge
So one of the main reasons I purchased 2 Play 1’s and a Play 3 was the ability to reliably stream music directly from my phone to one or multiple speakers in different rooms. They worked great for several years, best wireless speakers I ever had. Then I suddenly started having issues with them. Now I’m told one of the main functions behind my decision to purchase the speakers is being removed and in order to use the speakers as marketed I will have to replace them or spend hundreds of dollars to add on additional devices. Absolutely ridiculous and infuriating. I suppose next Sonos will announce they no longer support the original speakers. Had they shown an effort and expertise to fix problems and not blame everything on the consumers setup I had planned to buy many and place them throughout the house. Unfortunately I have lost confidence in Sonos and their ability to support their devices.
Badge
Do you have Crossfade selected? If so try unselecting it and see if that helps. I have the same issue, it seems to be when I am adding tracks to the playlist while it is playing as well as adding music to play next. I think this is very labour intensive for the iPhone.

I am using the iPhone 7+ not sure if this is an issue with the Apple phone? But as soon as I unselected 'Crossover' it resolved the issue for me. I notice that the crossover option doesn't seem to work very well on the app, so if you have got that selected it might be worth unselecting it.
Hi Jeff,

Ive seen your copy paste response. When does SONOS expect a software update that will fix this issue? I use my apple tv all the time so I do not want to disable my airplay. Nor should keeping my computer on wasting electricity of spending hundreds on a NAS be a solution.

Especially since SONOS markets itself as a premium audio company. Id expect the products to work.

Also any update on when SONOS will enable youtube in the primary app? I like listening to 1 hour mixes or customer streams.

Thanks
We have a 100% Apple household: iPads, iPhones, Macs, airport express, time machine, Apple TV. Only non-Apple device connected to the WiFi is the Sonos.

It used to work fine, but now from 2 different iPhones, it skips songs. I assume it’s after one of the firmware updates.

We luckily only got a PLAY:1, so that is getting replaced with an Apple HomePod. What a pity.

Oh, and btw a NAS solution is a insane solution for music you play on the go. For TV shows and movies it’s ok, but you want to take the music with you using Bluetooth in your car, on your headset or at your work, and not store it 2 different places, just because Sonos has a firmware issue.
😞
I am likewise experiencing this issue. Completely absurd. I’m insulted.
Don't hold your breath, people. I've had a sonos system for years and they've never been able to fix this problem. I doubt they ever will. Playing songs from an iphone should be the main priority. They'll keep asking you to get error reports and blah blah blah. But nothing ever changes. Basically, don't bother playing songs that live on your iphone directly from your phone that you can carry around with you and manipulate (you know like you expect to do since 2007?). Sonos is 12 years behind the times.
Hi Jeff,

Ive seen your copy paste response. When does SONOS expect a software update that will fix this issue? I use my apple tv all the time so I do not want to disable my airplay. Nor should keeping my computer on wasting electricity of spending hundreds on a NAS be a solution.

Especially since SONOS markets itself as a premium audio company. Id expect the products to work.

Also any update on when SONOS will enable youtube in the primary app? I like listening to 1 hour mixes or customer streams.

Thanks

Has this been rectified? I agree with Jeff 100%
Are you kidding me?!? Sonos is removing the only feature I ever used: “On this iPhone”. The feature why I bought 3 of your expensive devices??

if I was treating my customers like you do with yours, I would not have any.

Is this really true?
Userlevel 7
Badge +20
I play songs on my iPhone and they skip halfway through, I hate this system!!! Any fixes? The last update has made it worse.

Hi there,

Can you test out a source of music other than your phone's storage? Do you have any playback issues? If not, the issue is likely one that we're investigating where streaming from an iOS device's storage is interrupted when the device goes to sleep or into auto lock. You can try disabling auto lock in your phone's settings under Display & Brightness, or try disabling AirPlay on any non-Sonos devices in your home.

If you have audio cut outs on sources other than your phone, please submit a diagnostic report after you hear a drop, then reply with the confirmation number.
Userlevel 7
Badge +20
Having the same problem with 2 Play:1's and 1 Play:3. Sonos used to work great and so I purchased additional speakers. Recently it has become useless for playing music stored on a device. It happens on both my iPhone 8 and my iPad. (Both are new) I have tried disabling the auto lock, still skips songs. I have changed the wireless channel on my router (1, 6, & 11), still skips songs. Nothing else in my house has changed. Sonos used to work, now it does not. Do not tell me to purchase a NAS, do not tell me to keep a computer on at all times to act as a music server, do not tell me to use a streaming music service that I have to pay for, and do not tell me I need to re-configure all my other devices so that Sonos can perform it's most basic function. I want to play the music I have already purchased and I want to play it from my phone/ipad, like Sonos advertises, and like I used to be able to. This all seems to have started happening after an update. I have submitted a diagnostic report, the confirmation number is #366289417.

Do you have any interruptions when playing from sources other than your iOS device's storage? If so, check out this guide for some troubleshooting tips.

If you only get audio interruptions when playing from iOS device's storage, there are only a couple things you can do as we continue the investigation. You can disable AirPlay on non-Sonos devices, or offload your library to a device other than your iOS.
Userlevel 1
Badge
I don't have any problems using my MacBook Pro to stream music that is stored on the MacBook Pro to the Sonos speakers. I have tried channel 1, 6, & 11 on my router with no changes to the skipping problem. I have a large router and get excellent signal strength throughout my house, however it continues to skip even while I'm sitting in the room with the router. I thought the app freezing issue was fixed, but I spoke too soon. The app freezes every time the phone is locked or auto-locked. I have to kill the app and re-start it every time, even if only to adjust the volume. I'm glad to hear you are investigating these issues, which is why I'm trying to give you feedback to track it down. I never used to have this problem and it seems to have occurred for me around the same time as everyone else is saying. Can't say for sure when it happened because I normally use Pandora quite a bit and I'm out of the country a lot of the time, but I first noticed the issue early this year.

I'd rather not run around shutting off airplay to all my devices every time I want to stream some music, unless you need it for troubleshooting. I'll just go back to Pandora and hope you guys come up with a solution. Thank you.
Userlevel 4
Badge
I'm having the same problems constantly as well. Was super excited about getting this system and filled the house with a One, 5, Player, and Sub but having multiple issues daily with connectivity, skipping cutting out, etc. I shouldn't' have to restart my router multiple times each night. Or re-open app over and over. The Sonos community seems great but the system itself is frustrating
Hi - I was having this problem playing either from our households two iPads or two iPhones but not from other sources like my laptop. I only had the problem with playing music that was on my devices - not streaming from Pandora, etc. So I did two things - turned off cross fade (which I didn't want to do - I don't like that small moment of silence between songs) and also went into settings and set Auto-Lock to 'never'. This has solved the problem for me until someone (not sure if it's Apple or SONOS) fixes the root cause. Hope this helps.
I just experienced this same issue while streaming Spotify on my Google Home. It occurs halfway through the song titled "Walla Walla" by Glass Animals. At some point between mins 1:57 and 2:10 it skips to the next song. It's wierd. I couldn't disable Crossfade as suggested above because Spotify disables some settings when I'm streaming on WiFi speaker. This is a wierd and annoying bug. I hope Spotify fixes the issue soon.

P.S.
The song doesn't skip when i switch music play to my phone. I use a Google Pixel 2.
Same problem with my system diagnostic submitted no. 272139715. One suggestion was to go to settings on iOS - display and brightness - set auto lock to NEVER. Crossing my fingers as so far all OK.
Take that all back, it is happening again, never completes a song, nothing to be proud of Sonos.
Thanks ChiFlyer, I have already tried the method you have suggested but with no succes, It worked for about 15 minutes but the problem returned.
Userlevel 2
I'm in the same position as everyone else. I have stopped using my sonos completely due to this frustration. I was planning to extend my sonos system though out my house. This problem put a big end to that.
I have the same issue, can also confirm that this feels like an update issue. Ive had SONOS for 3 years now, and IIRC I never had a problem playing music from my iphones storage. I used to play music all the time for entertain, and no issues. For me this issue has creeped up more and more over the last 6 months.
Userlevel 7
Badge +20
Hi folks,

With the introduction of AirPlay 2 support a few months back, streaming from the storage of an iOS device will likely have playback issues if you have non-Sonos AirPlay devices active on your network. You can either disable AirPlay on and non-Sonos devices on your network, or disable auto lock on your iOS device to get streaming from your iOS device's storage working.

My advice is to download your music library to a computer or NAS drive, then set up a music share. This will allow you to stream your music library without interruptions when you have non-Sonos AirPlay devices active, and even if your iOS device goes to sleep, or offline entirely. Take a couple minutes now to save yourself the hassle of streaming interruptions.
Ok, so I tried a fix, not suitable for all. I connected the Sonos using a wired solution directly to our Time Machine (an Apple WiFi router with built in hard disk) using a network cable. I then disabled the WiFi on the Sonos (PLAY:1), and it hasn’t skipped a song since.:8
Badge
Having the same problem. Really annoying.
My multiple Play 1's have been excellent for years and i have been looking recently at upgrading to Play 5 and soundbar. But then.....from today..... i have joined the many of you sonos fans with tracks skipping before they are finished.

Three months ago I upgraded to Sky Q but other than that nothing has changed to my system but sonos updates. Same router, signal booster, ipad and iphone and same location. Both Play 1's are effectively unusable!!

I always played through the ipad not iphone. So whats changed other than now having useless speakers??

What can we do? I have turned off airplay on skyQ but no change to the problem. Come on SONOS make this right or lose customers wholesale across the country.

I think you should understand if this becomes common knowledge you don't have a business!
Same problem here. Nothing in my home is using AirPlay. Songs skip, or stop playing. Essentially, my Sonos is useless to me currently.

Reply