Question

since 10.2, no deezer search results

  • 2 June 2019
  • 4 replies
  • 79 views

so, heres a new one
Sonos system updated to 10.2, happy enough for updates, they occasionally make things better.

on this occasion, I'm getting no search results when searching in the sonos app, no album artwork in now playing screen and no add to favourite tracks or remove from favourite tracks and playlist and never play again buttons, no refresh of tracks picked for you, currently the only way it will play out something that I want to listen to is by doing it all in the deezer app then adding a favourite track which then appears in the sonos app.

Playback of any selected track from browse is fine but its awffy frustrating to have to search and add music this way, find myself using sonostube as this has no problems searching youtube for music but i pay for my deezer subs and would rather have that available.

Setup:
plusnet router, no changes since last working
station mode, channels monitored and changed manually on a weekly basis, all the neighbours have 'smart' wireless routers and this needs done.


So far, i have tried:
reauthorizing deezer on sonos,all goes as it should, no fix
removing/adding deezer service with a full system restart(router/phone/sonos) between remove and add, no fix

i might try a factory reset on my P:1, set it up as a new, standalone system and add my deezer account to it, will report back here but is anyone else seeing this?

For reference, heres a diag 679397778 taken within 120 seconds of a no results search, is there an issue there or can anyone give me the local player command to view diags, I can read them myself but 5 months is a long time to remember http commands when you don't use them anymore 😉

4 replies

Is this just an issue with your Deezer Music Service ...I know that Amazon, Google and most other music services are working okay. Have you tried powering off/on all your Sonos devices... leave them off for at least 30 seconds and then see if that fixes the issue.
Deezer is working for me. If a full network restart -- to refresh all IP info -- doesn't cure it, I'd suspect a wider DNS problem.
yup, ive FR the P:1 and set it up as a separate system as above but no dice, theres still no results, just the usual coincidence that the issue appeared IMMEDIATELY upon completion of the update and nothing else in my network has any connectivity issues including playback from fav tracks and playlists on the sonos system.

Have rebuilt my network from a reset of the modem forwards, only other thing i can really try is setup on an alternative network and try it, no way to update the dns servers on the plusnet hub/bt homehub 5. Next door has sky and we have each others wifi codes for emergency use, i will try and give a report back.

Also, found my work sheets with all http commands, now able to look at the diags directly myself, yay, just got to wait about 3-5 hours for my laptop to boot.
Most of the diagnostics have been withdrawn from user view on the grounds of security. Evidently thousands of Sonos players were visible on the internet after thoughtless port forwarding.

Over the years I have occasionally found that BT's DNS service has glitched, hence I also use Google as fallback.

Reply