Sharp Aquos - no sound coming from Sonos bar

  • 16 March 2017
  • 17 replies
  • 17234 views

I have a Sharp Aquos (LC-65LE654U). I have connected Sonos Bar directly to TV using digital optical cable, however, there is no sounds coming from my Sonos. If I stream music from Sonos (no involving TV) then I can hear sound. It is properly connected to wireless and is otherwise functioning correctly.

I have looked for an "external speakers" mode on my Sharp TV but cannot find any such mode in my menu system. Please help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

17 replies

Not familiar with the Sharp settings, but you need to be sure that both the TV audio settings as well as any device (cable box, game console, DVD player, etc) is set to Dolby Digital audio. If the TV is passing anything higher, like DTS, etc, then the Sonos Playbar won't be able to interpret the data properly, and give you silence.

At least you're sure the device is working, since you've tested music through it, but you may want to also double check to be sure that the optical cable is fully seated/clicked in at both ends. I was having issues a while ago, after I had moved, and finally figured out that I hadn't got the cable all the way in to the back of the TV set.
Just thought of one more thing that I missed. When you're poking around in the settings of the Aquos TV, make sure that the output is set to "Fixed", if that's an option. The other option would be variable, which would change the volume of the optical port output with the TV's volume control, so if you turned down the speakers to hear only the Playbar, you'd also be turning down the volume being sent out to the Playbar.

Good luck!
Thanks Bruce. I did find the Fixed vs. Variable output and have changed that. Still struggling to find anything indicating Dolby Digital option. Really like the Sonos sound (with music) but am incredibly frustrated that I can't get it to work with my TV.
Let me go poke around in the online manual for that particular TV, and see if I can figure out where it might be.
Thanks Bruce. Very kind of you.
OK, looks like page 4-21 is where they cover that information, and there isn't anything in that menu that defines the type of output that TV has. I'd recommend turning off the "surround" option, though. And in my poking around in that same area, albeit on another page, I found a place to update the firmware of the TV, I'd recommend doing that, just in case a newer version might be better.

But since there's no settings in the TV, then I'd recommend going into the source device's audio settings. Is it a cable box? or something else? Whatever you have feeding the TV, that should be set to either stereo or Dolby Digital as well.

I note on page/section 9-2 under "problem - no sound" that they seem to indicate that whatever the device is needs to be connected to HDMI-2. At least, that's my interpretation. Check to make sure which HDMI port you're using. It does say, however, in this area that it supports both PCM (stereo) and Dolby Digital, so you may be fine by checking the input device and making sure you're connected to HDMI-2. And don't ask me what the difference is between HDMI 1 and 2. From the specs page, HDMI 1 looks like it's more capable, but at this point, I'd be willing to try anything.

That's all I can see from the manual, which I found here:

http://files.sharpusa.com/Downloads/ForHome/HomeEntertainment/LCDTVs/Manuals/65LE654U_55-48-43-LE653U_OM_EN.pdf

Let us know if it doesn't work, there are a lot of smart folks here who have more knowledge than I do, and might be able to help.
I am having the same problem. My Sharp is older and the player worked last month before I moved. Now its not recognized. The optical cable works (red light), the sounder works with music services, but does not work with sound. there is no HDMI 1 or 2. There are 9 outputs and I am using HDMI 6 for television as I used previously when the soundbar worked. Any thoughts?
I am afraid I don't understand the comment 'I am using HDMI 6 for television'. Could you clarify? - sorry if I'm being dim.
There are 9 input options, i am using input number 6 HDMI along with optical
Sorry,.... but in what sense are you using an HDMI input along with digital output? HDMI 6 is presumably on the TV? If so, what is it cabled to?
Well John, similar to the response posted above by Airgetlam, I am simply describing the input and output that I am using. The input is, and has always been, HDMI while the output to Sonos is via the optical cable as it has always been as well. Thanks for your time John, but it seems you do not understand the initial concern.
You didn't make much of a job of explaining your setup. (nine outputs?), and your issue is quite probably not actually the same as the OP's (in cause, although possibly in symptom). So I won't bother suggesting any ideas.
Thanks again John. Tweeting with actual Sonos support now. Tweeting support should be everyones 1st stop to fix a problem https://twitter.com/SonosSupport
And for those buying a television Sharp should be your last port of call
Thanks again John, Sharp Aquos is one of the best, have had this set for 15 years and its worked splendidly with my Sonos players for 8 years without a hitch. Once again, people seeking reliable knowledgeable help, tweet support before the forum, forum is a waste. https://twitter.com/SonosSupport
I’ve been tweeting with sonos support for the past few days with no resolution. I can get audio for music but not the tv. We have been back and forth. Is there an adapter to hook an hdmi cable to tv instead of audio output?
Your confirmation number is: 1720410330

Same issue. This is the TV I have too.