Answered

Samsung remote won't control volume


I just bought a UN65K8000F and a Sonos playbar. I can get the sound working, but the remote control won't register to change the volume up and down (only the sonos app works). Please help!
icon

Best answer by lanman1 4 February 2018, 20:11

Figured it out. The instructions are perfect, the issue is that the IR signal comes from the one connect box and not the remote. In my case, the one connect box is in a closet with all the AV equipment. Unfortunately, the one connect for the 2017 TVs does not have an IR out for extenders so I will have to buy an IR repeater to go from the closet back into the living room. I guess Samsung doesn't expect you to use their universal remote with a sound bar.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

29 replies

Are you trying to do this with a Samsung Smart remote? If so it won't work because the Smart remote is not an IR remote and the Playbar only understands IR signals.
Is there a workaround? Would a universal remote for the TV help?
This may help

https://support.sonos.com/s/article/2413
Userlevel 2
Badge
Alas, I have the same issue as the OP and unfortunately, John, the info at that link is applicable only for an older version of the Samsung TVs. The remotes with the new versions don't communicate via IR and the TVs no longer come with an IR blaster. 😕
I have a Samsung 55KS800 and I've been suffering the same problem and frustration. However, following a guide on this site I now have my smart remote volume buttons controlling the Playbar volume.

1. In the TVs setup window, go to Universal Remote and add a new ‘Home Theater System’. Choose JVC. Select Optical for the connection type. Select ‘yes’ for power test.
I had to add it to my HDMI 1 connection which is actually my Humax box. This now adds a JVC Bluray player icon onto the ‘source’ bar. I can still watch whatever is be shown on my Humax box but now have both a Humax icon and a JVC icon. (see the note below)
This apparently will turn on the IR blaster for that remote.
2. Select the JVC Home Theater device in the universal remote setup and then select to add a JVC Bluray player to it.

Then go to your Sonos app and under Settings > Room Settings > (Name of your PLAYBAR) > TV setup you can add a remote and configure that smart remote to work with Sonos.

To check the Smart remote is emitting an IR signal look at the end of the remote through your phone’s camera.

Note: If I select Humax as my source the volume keys on the smart remote have no effect on the Sonus playbar. However, if I select JVC as my source, still receiving the picture from my Humax box, but now the Smart remote volume controls turn the Playbar up and down.
Userlevel 2
Hi All. I've managed to find a solution to this with my Samsung 49KS7000. In Smart Remote Set-Up, I set up a New Home Theatre and I manually typed Sonos into the list and chose Optical as the source. The TV will then ask if the Playbar powers off. Nothing will happen to the Playbar but continue on as if it worked. Now go back into Universal Remote and go to the newly created Sonos and select use with Cable/Satellite Box or Blu-Ray device.

In this instance, I paired mine with my Sky box, and now I can use the normal TV remote, the Sky Remote or the Smart Remote to control the Playbar. Also, going to the input and renaming it back to Sky from the newly created 'Sky-Sonos' meant I only had a Sky logo on the input. Hope this helps!
I also have just bought Samsung 49KS7000 and could not get the smart remote to control the playbar. I followed AwesomeAJ's instructions and now it works. Brilliant, well done man!
Thanks AwesomeAJ
no idea what i just did, but awesomeAJ's suggestion worked. paired it with my comcast box.
AwesomeAJ for president! This worked perfectly for my ATT Uverse box.
Userlevel 2
Has anyone worked out how to pair it with two different video sources on the Samsung? I have just bought a QLED QE55Q7F and so has managed to get the volume control working from the remote but only for one of my inputs (Sky on HDMI 3). If I add it to the second (an XBox on a HDMI 4) it seems determined that is me telling me the 'home cinema' is now on HDMI 4 and it stops working on the sky input
AwesomeAJ's suggestion worked for several setup boxes and Samsung UE55J7U500. Moreover I made similar approach to Apple TV also, where identify Apple TV as setup box then remaining is similar story. Only remaining is how I can do similar approach to smarthub app in TV?
I also followed AwesomeAJ's instructions, & it worked for me too - he/ she is awesome! However, although the volume was now working for live TV theough my Samsung Smart TV, my Samsung Blu-ray stopped working. The TV still recognised it, but it wouldn't play discs. I finally resorted to to IT Crowd solution of turning everything off at the mains, inc TV & Soundbar, waiting 30 secs, & turning everything back on. And ta-dah, the blu-ray started working again. If anyone has a problem with other devices (set top box etc) after successfully getting the volume to wotk via the Smart remote, they may want to try this simple fix before going for a more complicated fix.
AwesomeAj fixed everything on my end too!! Way to go homie, smart af lol
Badge
I need me some awesome AJ. So, i have a samsung frame tv UN55LS003AFXZA. It has the white one remote. I have the tv plugged into coax which is for an over the air antennae. I do not have a cable box or satellite etc. The only tv we watch is the over the air HD feed or netflix, hulu, amazon, vudu, All provided by the tv itself. I have the sonos playbar connected to the tv and i recieve sound but i am unable to control volume through the samsung remote, which is all i ask for..... please someone help. I have tried all of the above stuff and still nothing. What am i doing wrong??? Ron
AwesomeAJ solves my problem too! Right on
Badge
Just a little confused, can you advise if it will control terrestrial tv also, do you need to pair it with another device? I would like the volume control on the remote to change the volume on the playbar for normal tv, talktalk tv and blu ray?
Maybe a step by step procedure may help as I found it confusing.
Thank you
Martin
I was able to set up the remote to control the Sonos volume per AJ's tips... but my bigger question is, has anyone been able to get the Sonos volume indicator to display on the TV? All I can get mine to display is the Optical Icon indicator when I change the volume level... Is there a way to make it display a volume level on screen? It's still kind of annoying not being able to see volume levels on screen.
Not possible. The optical connection is a one way connector, so information can pass only from the TV to the PLAYBAR/PLAYBASE. There's no messages that can go back.
AwesomeAJ’s instructions worked for me as well. Thanks AAJ!
AwesomeAJ is still awesome! Thanks for the instructions.
AwesomeAJ, works now! Great help.
This seems straightforward but I simply can't get it to control my playbar. I previously had the playbar working with my old samsung tv, I wonder if that config changed something with the IR codes on the playbar. I tried going back through the remote config in the sonos app but the playbar doesn't detect anything from the samsung remote. I tried this using both a sonos home theater and a yamaha home theater in the universal remote setup.

What am i missing???
AwesomeAJ for president! This worked perfectly for my ATT Uverse box.

I can't agree more!
I have Samsung FrameTV 55". I just followed the following (from Sonos troubleshooting):

Follow the steps below to configure your Samsung One Remote to control the PLAYBAR or PLAYBASE:

Go to the Home menu on the Samsung TV, scroll left and select Sources.
Select Universal Remote. If this is your first time setting this up, you will be asked to set up your Universal Remote. Select Start.
Before we add the Sonos PLAYBAR or PLAYBASE, you will first need to complete the remote set up for your cable, satellite, or Blu-ray player. Click “New Device” and select the device you are adding.
Once you’ve added your other devices, select New Device > Home Theater System.
Type Sonos in the search box and select it, then select Optical for the input.
You will be asked to do a power test. Click the Power Test button which will then ask you if it worked, select Yes and then Done.

That was it - it works. As others have stated - you won't see the volume numbers when you put "+" or "-" yet you will see an input message in the lower left-hand screen.