samsung remote + sonos arconly turnig volume down while tv sound

  • 5 November 2021
  • 12 replies
  • 51 views

Hi, 

i recently bought my Sonos stuff and have serious issue with tv remote and Arc soundbar.

I programmed my remote without any issues (immidietly) but while sound input “Tv” only volume down is working (no volume up and mute).

on Spotify and sonos radio everything works well.

 

can you support?


12 replies

I believe what you’re referring to here is ‘by design’ - if you actually play some audio through the Arc speaker you should find that you can use both the volume up and mute buttons to control your speaker.

When there is no audio playing you cannot volume up - and the reason for this is, if you were to power off your TV and then (just as an example) dropped your remote down the back of the settee and sat on its volume up button - it would then most likely turn on a extremely high volume and make you jump. So for this reason, the volume up button is disabled when no audio is playing.

So just play the TV audio through the Arc and you should then (hopefully) see the buttons will be back to working normally.

Hi,

 

it is not like that.

I mean when input is set to “TV” only volume down is working.

yesterday it works for a second with volume up, but not working again…

Userlevel 7
Badge +17

Why did you program you remote? It should work automatically when the Arc is connected to the HDMI-ARC port on the TV (with the CEC protocol).

Actually I have constant ARC issues so ordered optical to hdmi converter that is one.

second- you can adjust volume while Spotify listening

Actually I have constant ARC issues so ordered optical to hdmi converter that is one.

second- you can adjust volume while Spotify listening

I always thought that the optical/HDMI adapter was supplied (in the box) with the Sonos Arc - have you checked if that is the case? Unless something has changed?

edit:

Note: If you have the ’remote’ working via HDMI-CEC, then just don’t bother with programming it via infrared aswell - you might be sending signals twice and confusing the TV - I would choose one or the other.

Hahaha,

 

you saved my 30euro- it was inside :)

anyway, still have primary problem

Hahaha,

 

you saved my 30euro- it was inside :)

anyway, still have primary problem

Try moving the Arc slightly further away from the TV and perhaps also see what happens if you toggle off the IR Receiver in the Arc’s settings in the App, before deciding to try the Optical adapter.

Maybe then also try setting up the remote again with the Arc too, but don’t forget to toggle the IR Receiver back on to do that.

TV’s or other room light can interfere with IR reception. As a test you can use index cards or strips of cardboard to block light from certain directions. I once had an issue that seemed to cure when I stood in a certain spot in the afternoon. It turns out that sun reflected off the wall opposite the IR sensor, interfering with IR reception. When I stood in that path, IR worked fine.

Really appreciate your support but:

  1. I will not move arc further away from TV- come on :)
  2. I will try to turn off ir reciver with hdmi, but I do not predict success. Error is “hdmi arc noise”
  3. buzz- I do not have ir interfere if is working with Spotify and not with tv…

Really appreciate your support but:

  1. I will not move arc further away from TV- come on :)
  2. I will try to turn off ir reciver with hdmi, but I do not predict success. Error is “hdmi arc noise”
  3. buzz- I do not have ir interfere if is working with Spotify and not with tv…

The point of switching off the IR is the volume control will just use HDMI-CEC and not both CEC and IR at the same time.

It is not working at the same time.

sonos software “knows” what to do.

despite both options on it is working only once, like it should

It is not working at the same time.

sonos software “knows” what to do.

despite both options on it is working only once, like it should

…or it could be the case that one command is cancelling out the other, especially if your TV ‘mute’ on your remote behaves like a toggle button.

…No harm in trying these things.

Reply