Samsung Q80B + Beam Gen 2 Lip Sync Issue

  • 22 September 2022
  • 6 replies
  • 44 views

I just bought an entirely new set up for our living room. I have heard awesome things about Sonos, so I decided to spend the extra money on the Beam and Sub. I got home and was entirely thrilled to set up my new outfit.. I found that when I watched normal cable (we have Spectrum) that there is a lip sync/audio delay issue.. The beam is connected to eARC, and TV’s/Sonos delay settings are set to “0,” but I still have a slight lip sync issue.. It is driving me NUTS, enough to take both the soundbar back to the store. 

Apparently I am not the only one with this issue, and I have tried most of the recommended troubleshooting techniques such as setting the audio to “pass-through,” enabling eARC, lowering audio delay to 0, resetting both TV and Sonos. Can someone for the life of me provide a solution?


6 replies

Buzz - could you explain why there is always going to be a delay? Is it a Sonos issue or a TV issue?

It’s not a fault, it’s a deliberate SONOS design decision.

There will always be brief interruptions in the data flow. The SONOS design keeps up to 32 audio players time aligned, and up to five speakers in a surround system time aligned. It’s no big deal if web page or email delivery is irregularly delayed for a few or even 10’s of milliseconds. If delivery to a speaker is delayed, there will be immediate audible consequences. SONOS injects a network latency and an additional data cache for local library files. The 75ms latency for audio injects some slack in the timing such that the system can recover from routine network delays without audible consequences. 

Since a surround system will always be in the same room, and the components use a direct, more predictable 5GHz or wired connection, the latency can safely be reduced to 30ms.

Of course this is a Sonos board, so I might be prejudiced, but it sure seems like if it were an issue with Sonos, you’d be seeing this issue manifested across all TV manufacturers and model numbers. 

I’d certainly be checking for updates to the TV’s firmware, and then forcing it to reboot by unplugging it from the wall for five minutes. But beyond that, I don’t have anything more specific for you. Perhaps someone else will chime in. 

I don’t use Spectrum’s cable, just their internet, so I don’t see this…but then again, if you’re using the Arc connection between your TV and the Beam, there should not be any appreciable lip sync issues. Not the case, however, if you’re using the analog (RCA) connection. 

Since you haven’t suggested what TV you’re using, it’s hard to look up a manual for possible suggestions, but in general, I’d start by looking at the audio settings on the Spectrum box first, and then move on to the TV’s audio settings. It is extremely unlikely to be anything on the Sonos. 

It is interesting that you say you’re not the only one, I certainly haven’t seen this posted in these forums as a common issue. But that doesn’t alter the fact that you’re experiencing an issue. Have you tried to call Sonos Support directly to discuss it?

 

Airgetlam - the TV is a Samsung Q80B. I’ve called Sonos, and they blame Samsung, and Samsung blames Sonos.

There will always be a 30ms latency with BEAM. Most people can accept this, maybe you cannot.

In general I find that TV and audio companies are quite lax with respect to lip sync. The movie industry solved this many, many decades ago. I notice that the movie channels on cable systems have the best lip sync, local programs are the worst and lip sync in general varies from channel to channel and program to program. Based on comments I see, lip sync is probably better in Europe than the US.

Buzz - could you explain why there is always going to be a delay? Is it a Sonos issue or a TV issue?

There will always be a 30ms latency with BEAM. Most people can accept this, maybe you cannot.

In general I find that TV and audio companies are quite lax with respect to lip sync. The movie industry solved this many, many decades ago. I notice that the movie channels on cable systems have the best lip sync, local programs are the worst and lip sync in general varies from channel to channel and program to program. Based on comments I see, lip sync is probably better in Europe than the US.

I don’t use Spectrum’s cable, just their internet, so I don’t see this…but then again, if you’re using the Arc connection between your TV and the Beam, there should not be any appreciable lip sync issues. Not the case, however, if you’re using the analog (RCA) connection. 

Since you haven’t suggested what TV you’re using, it’s hard to look up a manual for possible suggestions, but in general, I’d start by looking at the audio settings on the Spectrum box first, and then move on to the TV’s audio settings. It is extremely unlikely to be anything on the Sonos. 

It is interesting that you say you’re not the only one, I certainly haven’t seen this posted in these forums as a common issue. But that doesn’t alter the fact that you’re experiencing an issue. Have you tried to call Sonos Support directly to discuss it?

 

Reply