Answered

Samsung Q7 and Beam

  • 13 April 2021
  • 1 reply
  • 51 views

I am just adding this, because this doesn’t work, at all.

QA55Q7FAM - Firmware updated
Sonos BEAM - HW 1.23.1.11-2.2 OS: S2 Ver: 13.0

  • The device is correctly connected to the Beam and HDMI 2 (Arc) on the connection box.
  • HDMI is not detected nor is it selectable (it doesn’t exist) in the Samsung TV Sound options, so “Audio Out/Optical” Selected.
  • The Expert settings are Bitstream (In) and Dolby (Out)
  • The TV can “see” the beam as a media server in the source list.
  • Sonos App shows “Audio In: No signal” and HDMI test fails.
  • I have tried two different HDMI cables and both work for other applications.
  • I disconnected the connection box for 15 minutes and reconnected without the Cable Box, so only BEAM was connected, with no change in behaviour.
  • The BEAM works as a ApplePlay 2 device just fine

I am not seeing any available options for connecting this device and conclude the combination simply doesn’t work. This was not a discount TV to buy.

What’s the answer?

  1. The HDMI (ARC) port on the Q7 is broken?
  2. The BEAM is junk, blame SONOS
  3. The Q7 is junk, blame SAMSUNG

Have SONOS actually offered any guidance on this matter?

icon

Best answer by Jennine 13 April 2021, 11:07

After chatting with support online, then a call to the 1-800 number, this problem has been solved.

It seems that device boot and connection order is the key.

  1. Power off and unplug the Q7, Connection Box and Sonos BEAM.
  2. Remove all HDMI cables from Connection box and Sonos BEAM.
  3. Turn on TV. When TV asks for Connection box, power it on and it will connect automatically.
  4. Under settings menu option “General, External Device Manager” activate  “HDMI+CEC”
  5. Power on Sonos BEAM.
  6. Connect Sonos BEAM to the Connection box via HDMI 2 (ARC)
  7. TV should now show Sonos BEAM on the source list and show a weird pattern on TV because it is connected to the Sonos BEAM as a source.
  8. Change TV Input Source to whatever your input source really is, start Netflix or whatever.
  9. The Sonos BEAM should also show as the output device automagically as “Receiver (HDMI)”
  10. Check the Sound options, where Sound Output Menu has a new option selected called Receiver (HDMI)
  11. Under Expert options, select “HDMI Input Audio” → HDMI and “Digital Output Audio” --> Dolby Digital
  12. Reconnect your cable box to the Connection Box

The key here, is that the boot and connection sequence is what causes the “Receiver (HDMI)” sound option to get activated in the Q7 setup menus.

I hope I remembered everything during this rewrite.

A big thanks to the customer support folks who did real time diagnostics as we worked through this issue - you know who you are :D

 

 

 

View original

1 reply

After chatting with support online, then a call to the 1-800 number, this problem has been solved.

It seems that device boot and connection order is the key.

  1. Power off and unplug the Q7, Connection Box and Sonos BEAM.
  2. Remove all HDMI cables from Connection box and Sonos BEAM.
  3. Turn on TV. When TV asks for Connection box, power it on and it will connect automatically.
  4. Under settings menu option “General, External Device Manager” activate  “HDMI+CEC”
  5. Power on Sonos BEAM.
  6. Connect Sonos BEAM to the Connection box via HDMI 2 (ARC)
  7. TV should now show Sonos BEAM on the source list and show a weird pattern on TV because it is connected to the Sonos BEAM as a source.
  8. Change TV Input Source to whatever your input source really is, start Netflix or whatever.
  9. The Sonos BEAM should also show as the output device automagically as “Receiver (HDMI)”
  10. Check the Sound options, where Sound Output Menu has a new option selected called Receiver (HDMI)
  11. Under Expert options, select “HDMI Input Audio” → HDMI and “Digital Output Audio” --> Dolby Digital
  12. Reconnect your cable box to the Connection Box

The key here, is that the boot and connection sequence is what causes the “Receiver (HDMI)” sound option to get activated in the Q7 setup menus.

I hope I remembered everything during this rewrite.

A big thanks to the customer support folks who did real time diagnostics as we worked through this issue - you know who you are :D

 

 

 

Reply