Samsung One Remote Sonos Playbar No Control

  • 3 August 2017
  • 33 replies
  • 11604 views


Show first post

33 replies

Userlevel 2
hi,

this works for me - for the first time - but it has a big problem: I use an Apple TV on hdmi1 which is the only externals source to my Samsung frame tv. as soon as I complete your step nr. 3 it works with my soundbar, but then I can no longer control the apple-tv...

is there really no solution at all? Sonos?

please help or I'll have to return the soundbar... because having to switch remotes every time I start using the Apple TV is no option.


regards,

l
Thank you, thank you, thank you! Same issue(s). Samsung Q7F. Was losing my mind before this (and almost took Sonos back to BB).

I've got a Samsung Q7F which also uses the One Remote. After experiencing much frustration with trying to get it to control my Playbar, I discovered the following solution:

Go to the "Source" menu and choose universal remote

Add a new device and choose home theatre system

Choose "Pioneer" from the list of brands then the optical connection

On the next screen, it will perform a power test. Run the power test, and then choose "no" when it asks if your home theatre system turned on or off. Every time you perform a power test and press no, it'll enable a different set of One Remote commands to control volume. Most of these seem to be using RF signals, but some of these configurations are IR, which is what you'll need to control the Playbar. I had to retry the power test and press no four times until it loaded the fifth Pioneer configuration, which used IR.

The easiest way to see whether the remote is firing IR volume commands is by opening the camera app on your phone, pointing the remote straight at the camera and pressing one of the volume buttons. If the remote is firing IR commands, you'll be able to see a purple light in the corner flash in addition to the red light on your phone screen.

Once your One Remote is firing IR commands, you can get the Playbar to learn the remote control commands in the "Room Settings" part of the Sonos app.


Weird. I have the QE55Q7F.
I toggled through all 6 Pioneer configs and none of them makes the control shoot an IR signal.
Instead I tried to look at the connect box with my camera, and guess what... It fires IR signal at 3 places when you press volume up/down. But the actual control does not. :@

Does that mean you're forced to have the ugly connect box on display? Or do you @lostinthecity have a model without the external connect box? Or do you have it "in open air", aka not in a closed shelf?



EDIT: SOLVED finally.

Extremely unintuitive. But I did as lostincity wrote above, but I could not see if the remote fired any IR signals during the "power test". I had to complete the wizard for every input to be able to see that the control fired IR signals.

Hopefully it can help someone else until Sonos gets in touch with Samsung to fix their presets found in their TV's. It really surprises me that the actual SONOS preset in the samsung wizard doesnt do this.

So if you have the new 2017 aluminium one remote, do this:

1. Go to "source". Choose to add universal remote.

2. Choose Home Theater. Choose Pioneer. Choose it for Optical. Press "No" on the power test 4 times, press yes on the fifth test.

3. Choose Home Theater. Choose Pioneer. Choose it for HDMI(whatever other source you have to your TV). Press "No" on the power test 4 times, press yes on the fifth test.

4. Now after adding this Pioneer preset to ALL sources you use, the remote will finally send IR signals.

5. Since this is Pioneer IR signals you have to remap the IR commands in the Sonos app, under settings.
I'm suffering the same problem with my Samsung Q7F.

After some experiments, I was able to individually setup and control both input device (set-top box) and the playbar. But as soon as the set-top box is (virtually) connected to the playbar in the remote setup wizard, the remote only emitted IR at either the remote or the connect box. It looks like the "One Remote" cannot be programmed to emit IR at the "One Connect Box" to control your input device (like set-top box) and emit IR at the One Remote to control the volume at the playbar simultaneously. I verified this using a smartphone camera. So if the connect box is hidden behind a cabinet with your set-top box, you are out of luck.

I really do like the simplicity of the one remote. But I guess Logitech Harmony is still the only solution that is really working properly.
I was able to get the volume control working on the Samsung Q7F, by doing the Pioneer trick along with using an IR cable connected to the IR OUT (or EX LINK for my 2018 Connect One box). Using the IR cable, you can place the transmitter somewhere in front of the sound bar, without having to have the actual Connect box in front of it. Took me over (5) hours to figure this out. Hope it helps others. Samsung should be supporting the Sonos out-of-the-box.
Userlevel 1
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q7F 75" (2018 model, QE75Q7FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on DVB-S2 (Satellite), HDMI1 (Apple TV), HDMI2 (PlayStation 4) and Apps (Netflix, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Cheers!
I used this guide from this side and I have got the white remote and a Samsung the Frame UE55LS03N

1. Go to "source". Choose to add universal remote.

2. Choose Home Theater. Choose Pioneer. Choose it for Optical. Press "No" on the power test 4 times, press yes on the fifth test.

3. Configurate remote to work with Sonos Playbar:
Start the Sonos App in mobile
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup and run the guide.

Good luck!
Hi! Have a playbar connected via optic cable to a Samsung The Frame 55 with the white remote. The TVs connect box is hidden. I had the remote working, but disconnected the screen to hide cables. After that no IR- signals!!!

Hesitant to the Pioneer solution. Didnt need to use that before.

Pls help!

Yea doesn’t seem to work when the Samsung TV is turned off. Seems the remote doesn’t beam IR signals if the TV is off. I tested by beaming the remote at my phone camera. It definitely beams different signals when TV is on versus off.

Reply