Answered

S1 no longer working

  • 13 November 2021
  • 27 replies
  • 232 views

Badge

A month ago this worked.  Today it does not.  The SONOS S1 app on my mac disappeared, so downloaded the updated one.  But it will not connect to the system.  

MacOS 10.13.6

 

Sonos Systems

  • BEAM
  • Sonos Boost
  • First gen connect systems

Sonos S1 Controller for Mac 11.2.13  Build 57923010

 

Fast.com WIFI speed:  540 Mbps

Was all working fine September 2021.  

 

Have powered all it off, then pulled the power for the BEAM, then tried to start it all as an S1 system but no luck:  “Sorry, we can’t connect to Sonos” from Sonos S1 app on MacOS.

 

Complete iTune library on the MAC, portions on iOS devices.  Able to use IOS devices to drive entire system from music library on IOS devices but that is a subset of the larger music library.  Need the MacOS Sonos S1 app to work at least sufficiently to connect the music library…..

 

Two folks spent 4 hours each on this for 8 hours, multi reboots, can’t get it to work, what will resolve this issue?  And why does it seem like we need to spend 10-20 hours a year on Sonos maintenance??

icon

Best answer by Mykari 13 November 2021, 20:25

View original

27 replies

Describe your network for us. How does the Mac connect?  

Badge

Wirelessly

And the first query?

Userlevel 7

Check for updates for the MacOS. 

Badge

Sorry -- not following your question -- what do you mean by first query?

Badge

There are no OS updates for my system -- 10.13.6 is the latest in the 10.13.XX releases.

 

The network: the router, a WiFi mesh, etc?

Badge

Yes, the router is a WIFI mesh

Badge

Have completely reset the router twice so far this morning -- hard reset of unplugging and waiting 30 seconds to clear all residual data, etc.

 

Userlevel 7

Did you try restarting your Mac?

Badge

Yes, as mentioned above, everything here has been powered down and reset at least twice.  Including the Mac.  I thought I read to not have S2 devices online while doing this so the BEAM has been powered off and remains powered off currently under the assumption that I need to fix the S1 issues to the older devices and boost and then would power the BEAM back and up and it would work.

Badge

In case useful, I submitted diagnostics to Sonos  “Your confirmation number is: 1421497701.”

It might help us if you were to respond to ratty’s query, telling us which router you have, what type of mesh network you’re running, etc. 

It would be helpful if we were to know how your Sonos system connects, too, so far you’ve only told us that your Mac connects wirelessly, but we have no idea how your S1 system connects. For instance, it might be helpful if you were to temporarily wire a single Sonos device, presumably your BOOST, to your base router, but it might be instructive to us if it already was, which may point to a completely separate issue. Or, it would be helpful to know if the BOOST was wired to a satellite, rather than the base of your mesh system, where then the make of the mesh system again becomes significant. 
 

 

Badge

Thanks.  The Boost is hard-wired to the mesh system.  They sit next to each other.  They sit about 36 inches from the MAC itself.   It is an EERO Mesh router.  No satellite involved.

Badge

EERO Mesh details if useful: 

WiFi connectivity

eero: Tri-band WiFi radios, simultaneous 2.4GHz, 5.2GHz, and 5.8GHz wireless 2x2 MU-MIMO, beamforming, IEEE 802.11a/b/g/n/ac | eero Beacon: Dual-band WiFi radios, simultaneous 2.4GHz and 5GHz wireless 2x2 MU-MIMO, beamforming, IEEE 802.11a/b/g/n/ac

Wired connectivity

eero: Dual auto-sensing Gigabit ports for WAN and/or LAN connectivity | eero Beacon: None

Smart home connectivity

Thread 1.1 Border Router, Bluetooth® LE 4.2

Processor, memory and storage

700 MHz quad-core processor, 512MB RAM, 4GB flash storage.

Generation

eero Home WiFi System 2nd Generation – 2017 release

Ok, that does help. 

First thing, try moving the BOOST at least a meter away from that base Eero node, but leave it wired together. You should never wire the BOOST to one of the satellites. 

I’m not terribly concerned about the Mac at this moment, as long as it can see the internet, it should be able to see the Sonos system. However, if you’ve factory reset any of these devices, you will need a iOS or Android device to re-add things back to your system. 

When you open the current S1 app, does the BOOST show up when you look at ‘about my Sonos system’ in the settings area? If the BOOST does show up, does anything else show up as well? If it doesn’t show up, power it down, remove the Ethernet cable, and temporarily connect your Beam with an Ethernet cable, and then open the controller, and see if the Beam shows up? This should tell us if indeed there is an issue with the BOOST.

Just to confirm, you have not tried to apply S2 to any of these devices, have you?

Can you be more specific about your “First gen connect systems’? What are they, what purpose are you using them for? 

 

Oh, another piece of useful information would be what channel is in use by the Eero system, and what channel is in use by SonosNet?

Badge

We can get to all the pieces from the IOS controllers/sonos apps across multiple iphones and ipads, just not from the MAC OS app. 

We are unable to hardwire the BEAM to to the base Eero node as it is fairly solidly connected to a wall upstairs in a bedroom.

We cannot see anything from the MacOS S1 app -- We get the black screen of “Sorry -- we can’t connect to Sonos”.  When checking “About My System”,   Only the Sonos S1 with build information shows up.  Build 57923010, version 11.2.13, etc.

I’m  not aware of resetting any of the Sonos devices.  The system (minus the bedroom BEAM system which is powered off), is working in two separate rooms with different speakers and currently streaming Music Choice, so those parts all seem to be working together...

Correct, we have not applied any S2 to any devices.

We have two first gen connects -- maybe 5X5X3 inches, white cubes, from our original investment in SONOS.  The model number in the bottom just says “CONNECT”.  

I’m not currently sure how to answer your channel question -- can you clarify?  the Wifi has a local name and that name is what used in all our devices..

Thanks,

 

 

 

Badge

Note, to clarify, when the BEAM system is powered on, we can use AirPlay to drive the Sonos system in all 3 three rooms from the ipad music library, and we can also stream music from Music Choice.  Always using the S1 app, no S2 anywhere that I am aware of.   But when the BEAM is powered down, then there is no music source for the older CONNECT systems.  

We did power the BEAM back up to get music at this time via that method.

I have moved to the  BOOST a meter away from the EERO.

Bit of a long shot, but maybe worth checking;

https://support.sonos.com/s/article/2058?language=en_US

Badge

Thanks.  I confirmed the the Sonos S1 Controller.app is listed and Allows incoming connections.  I did delete the original S1 Controller.app listed there and re-added it to see if that would help.  So far, no change but maybe eventually that might be helpful. :-)

So, while I’m not 100% sure here, if you have your Mac connecting to a different Eero than the BOOST is wired to, it’s possible that it specifically won’t be able to ‘see’ the Sonos system, while the iOS clients, which appear to be able to see the Sonos, would be connecting to the Eero subnet that the Sonos is on.

The thing that is confusing is your statements around ‘wifi’ and Eero. How many ‘WiFi signals are there? Is everything on Eero, or is Eero running in parallel with your WiFi? What signal are your iOS devices that can see the Sonos connected to, what signal is your Mac connected to?

Since you’re able to control via iOS, and not the Mac, then it’s not important which channels are in use, that was a potential issue inly before I understood that the iOS devices are working, and it was only the Mac hat was not.

Can you wire the Mac temporarily to the same Eero device that the BOOST is wired to, and see if it connects at that point?

Userlevel 7

I see a “Best Answer” tagged to this thread. Has your issue been resolved? 

Badge

Hi, Ok, I turned off the wifi to the MAC and connected the Mac to the ethernet flowing through the Eero system, That did not seem to change anything.  The Sonos app still reports it cannot connect to Sonos but internet, mail, etc, all working with the direct connection.

Sorry, networking is my weakest technology area as it has just tended to work and I may use terms interchangeably which are not truly equal.  Prior to doing this, all devices were on on the same wifi network from the Eero.   I would assume they are still all on the Eero, with the MAC now directly wired to it and the wifi disabled, while the rest of the devices -- ipad, CONNECT, etc., are on the wifi network broadcast by the Eero.

Badge

As I should have maybe not turned off the wifi on the MAC, I turned it back on -- same network as all devices in this thread.  I restarted the S1 App and after about 30 seconds I received a white screen with a black check mark that this Sonos App is now connected to your Sonos System.  I clicked “Done” in the bottom right hand corner and that took me to the familiar black screen of “sorry, we can’t connect to Sonos”.  So maybe something changed slightly?  But the result is still that the MacOS S1 app doesn’t appear to be connected to anything despite the first white background message….

Reply