Answered

RTSP / UDLD error with Meraki

  • 5 February 2019
  • 4 replies
  • 235 views

Badge +1
I am struggling to get a PLAY-ONE to come up on a wired interface over my home network. I have a home network that uses MERAKI switches and router:

Switch is MS-120BLP

The issue I am seeing is when I try to bring the PLAY:1 online on a wired port.

Every time I try to connect the PLAY:1 I get UDLD errors from the switch network and the entire home network goes into meltdown. I cannot find a setting for the switch port that connects to the PLAY:1 that keeps it up and does not kill my home network

I have been toggling RTSP ON and OFF on the Meraki switch but there does not seem to be a setting that works

Any ideas ?
icon

Best answer by ratty 6 February 2019, 14:57

STP is not active if the Play:1 is connected to the local WiFi in "wireless setup".
View original

4 replies

It sounds as though the UDLD could be fighting with Sonos' STP. The Play:1 will be sending out STP BPDUs.
Badge +1
Yes I have been fighting the issue for a few days but have recently discovered that the Play:1 is working on the house WiFi and with that I have no BPDU issues
STP is not active if the Play:1 is connected to the local WiFi in "wireless setup".
Unless you specifically need it for a connection (living room surround sound), I have disabled Wireless in all my Devices that have wired connections. Especially with the Beam, that solved the loop issue causing the network to melt down.

You can do this under Settings -> Room Settings -> (Selected Room) -> Advanced Room -> Wifi - Select "Disable WiFi"

Note: You must be hardwired to disable wifi

Reply