Router, AP & Sonos


Badge
I have had an issue with the songs app not being able to connect after roaming between my router and AP. I’ve got the following setup

Vodafone router. wired devices are:
1. Sonos speaker
2. Powerline adapter - in turn connected via the other adapter to a 4 port unmanaged switch which has TV, blu-ray and NAS connected
3. Ethernet port on the wall. This is then wired via un-managed PoE switch to the AP - A Ubiquiti Unifi AC Pro

With this setup, I found that with a ‘fresh’ setup, i.e everything powered off, then the sonos app can see the speaker when connecting via wifi from the vodafone router. Roaming to pick up the AP, no problems either. Moving back to the router, then the connection is lost.

After some testing, I was convinced this was the router. To get around the issue, I plugged my old Netgear DGN2000 into the router and used it to provide the wifi. No issues with roaming at all.

Yesterday, I decided to swap out my ‘two box’ solution and installed a TP-Link VR600. Unfortunately, the same issue occurs. Again, using the Netgear for the wifi, solves the issue.

I’m at a loss as to what the problem can be!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

19 replies

For the controller to discover the players requires IP multicast traffic. Make sure the Unifi AP is correctly configured to forward multicasts/broadcasts from the wireless segment.
Badge
Hi ratty,

Thanks for your reply. I'm not having an issue with the AP, it's when I roam back to the router the issue starts. So, not sure if this is an issue with the AP 'holding' on to something, or the router. I've disabled IGMP Snooping in both the AP and the router, based on other posts I've found.
So a newly started controller will find the players when the device is attached to the AP? In that case the AP's passing multicast.

What exactly happens in the controller when you switch back to the router WiFi?
Badge
Yes, that's correct. So, in terms of 'testing': whilst connected to router wifi, open controller select & play a track - OK. Roam to the AP. Stop/start track - OK. Roam back to the router, the controller loses connection, searches for the speaker, then comes back with the issue that it can't find my component. I can go back to the AP again and the controller connects OK. Back to the router, no connection

With the Vodafone router, it never reconnected. With the TP-Link, I think (need to do more checking) that it worked again after about 10 minutes.

Even if I reset the controller at this point and try to set up the connection, it still fails.
Is the AP connected back to the router via powerline? If so what make/model? Some have been known to interfere with certain types of traffic. (Sonos doesn't officially support powerline, for various reasons.)

But if the controller loses touch when migrating back to the router something else may be going on. Some network components which 'bridge' in fact mangle the MAC addresses of attached devices, substituting a virtual MAC. This can cause problems when a device moves back and forth between each side of the 'bridge'.

Have you done a complete network restart, just in case a duplicated IP has slipped in somewhere?
Badge
Hi,

No, the AP is wired via an un-managed switch back to the router.

If I do a complete restart, then it works until I roam again and the issue re-occurs.

What I can't quite work out is if I turn off the router's wifi, then turn on the DGN2000's wifi (which is wired to the router), everything works again - no need to reboot anything. It's almost like the router can't communicate from the WLAN to the LAN after I roam back from the AP.
It does seem as if you've isolated the problem to the Vodafone router. Apologies for possible red herrings over the Unifi AP.

What happens if, having moved back from the AP, you turn the phone's WiFi off and on again?
Badge
Hi,

The issue is the same if I turn off/on the phone's wifi. Still no connection.

So, just so I'm clear, the issue is the same if I'm using the Vodafone or TP-Link router. I have to connect the Netgear to either router and use its wifi to get things working. Hopefully the below explains?

Doesn't work
VF or TP-Link Router (wifi on) -> wired to Sonos
VF or TP-Link Router (wifi on) -> wired un-managed switch -> wired to AP

Works
Netgear DGN2000 (wifi on) -> wired to VF or TP-Link Router (wifi off) -> wired to Sonos
Netgear DGN2000 (wifi on) -> wired to VF or TP-Link Router (wifi off) -> wired un-managed switch -> wired to AP
So the Netgear is the silver bullet? Interesting. Out of interest, is it configured as an AP i.e. with DHCP server off?
Badge
Essentially, yes. The DHCP is turned off.
What happens if you substitute the Netgear for the Unifi AP?
VF or TP-Link Router (wifi on) -> wired to Sonos
VF or TP-Link Router (wifi on) -> wired un-managed switch -> wired to Netgear DGN2000 (wifi on)
Badge
That's one I'll have to try at the weekend as the switch is in the loft! Not one I've strictly tried before. Before I bought the AP & switch, I did have the Netgear connected up in a different room and 'wired' back to the router, but through powerline adapters - so not quite the same. I DID have issues with this, so ended up buying one of those wifi repeaters to fix the problem. Given Sonos doesn't support powerline, I put it down to these at the time.
Badge
Not tried the moving the Netgear yet (one for tomorrow), but a quick test using the "Standard" setup tonight yielded the same result. So, I'm thinking less WLAN/LAN issue on the router and more some sort of routing issue. It's like the controller doesn't know where to find the speakers.

After about 5 minutes, the controller pops back into life and I can connect OK.
Substituting the Netgear for the Unifi AP will provide another data point. Is it an iPhone we're dealing with? If so try disabling WiFi Assist.
Badge
Hi,

I'm using android phones, plus windows client for the sonos controllers.

So, I disabled the Unifi AP and set up the Netgear in its place. The result was the same - roam to the netgear, roam back and no access. I also tried setting up the vodafone router again and instead of connecting the Netgear to it for the wifi, I connected the TP-Link router (DHCP off etc.). Again, same problem. With this set up, I also experienced not being able to get an IP address on my phone after roaming back, so it wasn't just sonos. There seem to be similarities/oddities how the vodafone and TP-link routers behave.

At the end of all that, I'm back to the Vodafone router and using the Netgear for wifi. TP-Link will be returned whilst I work out what to do next!.
Intriguing. So when the two WiFis are the Unifi and the Netgear then hand-off is okay, but with anything else it goes pear-shaped.

It is, as you say, possible that both the Vodafone and TP-Link are funny. They may trigger some higher level behaviour in the roaming device's network stack which the Unifi/Netgear do not.

Of course these disparate APs were never really designed with roaming in mind, though often it will work. One tends to get more certainty with APs of a single manufacturer, such as the latest mesh WiFis obviously ... or indeed SonosNet, to which an Android can attach. I find that a central, powerful router produces less hiccups.
Badge
I think my next move is either try my luck with a new Netgear modem/router and see if that works with the Unifi AP, or to buy another Unifi AP and connect that to the Vodafone router.

Unfortunately, with the position of the master socket, the router is at one end of the house and so little chance of getting a single router to cover everywhere I need.

Thanks for your input on this.
Maybe a single centrally placed AP would service the whole house then? The router's WiFi could always be turned off.

If running an Ethernet cable to a central AP is difficult, another possibility is to use a central, band-shifting wireless extender.
Badge
The Unifi AP is positioned upstairs and pretty much covers 2/3rds of the house with a strong signal, even on the ground floor. This has been wired in professionally. I think getting another one more centrally will be difficult given the configuration of the walls. Sounds simple, but all I need is a wifi router/AP in the lounge to cover the dead spots!