Rooms dropping out/disconnecting from controller

  • 12 April 2016
  • 53 replies
  • 22397 views

So I have a 3 room set up.

Lounge - Playbar + 2x P1 for AS
Kitchen - 1 xP3
Master Bedroom - 1 x P1

Recently when I have gone to control the speakers through any phone it is only showing the lounge, and without the SS.

The kitchen still plays whatever was in the queue if I press play on the physical speaker but I can't adjust/change the music.

This is consistant across multiple controllers and we have tried disconnecting and reconnecting to the sonos system .

Can anyone provide any help in this matter? Happy to submit diagnostics

Regards

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

53 replies

Having same issues. Rooms dropping off, unable to control Sonos from Android phone some of the time but not all of the time. Have tried to reboot modem, router, speakers, reinstall Sonos app on phone. Still having problems. Diagnostic #8265972
Hi,
I have the same issue. I have a 3 room setup with 1 play 5 (cable connected) and 2 play one's (one cable, one wireless). Cables connect through a Devolo PLC.
All has been working fine, but once in a while the play one's drop, but never the play5. I did not configure fixed ip addresses. Rebooting router or sonos fixes it only temporarily
I have a feeling it specifically happens after updates.

Diagnostic sent : 8271196

Thanks!
René
I've been having all the same symptoms, dropping connection and losing rooms. I just updated my router and changed the wireless channel from 6 to 11, will see if this fixes the problem.
Finally my issue was caused by defect powerline controllers. Substituting them resolved the issue.
Badge
Hi can someone help: this is getting very frustrating: my sonos is irritating falling in and out. can somesome help. I am using google wifi through my house: the sonos has a dedicated network and it still drops out. The diagnostic number is 1702555890
Userlevel 7
Badge +20
Hi, Zulloft. Thanks for providing that diagnostic. Your system is split across multiple access points and your WiFi environment is write with interference. I think it might be best that you get in touch with our support team via telephone. We are keen to have this resolved for you. Please give us a call at your convenience and we will sort this out with you. Many thanks.
The autocorrect didn’t seem to like the word “rife” :)

For the record, neither did mine. It really wanted it to be “rifle” on my system.
My Basement is dropping off the app. When it is showing on the app, I get consistent sound for a while and then intermittent sound when playing the TV. Diagnostic#1398448735
Userlevel 7
Badge +20
My Basement is dropping off the app. When it is showing on the app, I get consistent sound for a while and then intermittent sound when playing the TV. Diagnostic#1398448735

Hi lag256,

Sorry for the delay. It looks like your speakers are losing connection to your wireless network occasionally. This is likely due to wireless interference from nearby wireless signals. There are a couple other networks in range on the same wireless channel as your main network, including one that does not have a name. Please try changing your router's wireless channel to 6 or 11 and see if things improve.
Badge
I have a 3-room setup:
#1: 1 x Connect (wired) to HiFi
#2: 2 x P5 & 1 x Sub
#3: 2 x P1
Room #1 works fine until I activate #2 and/or #3
Diagnostic#: 1046467361
Userlevel 7
Badge +19
I have a 3-room setup:
#1: 1 x Connect (wired) to HiFi
#2: 2 x P5 & 1 x Sub
#3: 2 x P1
Room #1 works fine until I activate #2 and/or #3
Diagnostic#: 1046467361

...And then what happens? Do you get an error message? Do the rooms drop or disappear? Are you grouping the rooms together or playing different sources in different rooms? Simply sharing the rooms and giving a diagnostic number will not give us enough to help. The more details we have, the better we can assist.

Not sure if this is helpful, but the diagnostic report you submitted points to physical electronic interference problems with the Lounge Connect which could lead to connectivity problems to the rest of the Sonos system if grouped. This would create audio dropouts and connectivity errors. Is this what you are experiencing?
Badge
I have a 3-room setup:
#1: 1 x Connect (wired) to HiFi
#2: 2 x P5 & 1 x Sub
#3: 2 x P1
Room #1 works fine until I activate #2 and/or #3
Diagnostic#: 1046467361

...And then what happens? Do you get an error message? Do the rooms drop or disappear? Are you grouping the rooms together or playing different sources in different rooms? Simply sharing the rooms and giving a diagnostic number will not give us enough to help. The more details we have, the better we can assist.

Not sure if this is helpful, but the diagnostic report you submitted points to physical electronic interference problems with the Lounge Connect which could lead to connectivity problems to the rest of the Sonos system if grouped. This would create audio dropouts and connectivity errors. Is this what you are experiencing?


Thanks for the reply and sorry that I was a bit tight with information. No error message, only drop-outs for some seconds in room #1, regardless of the group-settings of the rooms.
What can cause the physical electronic interference problems in the Lounge setup (which is room #1)?
Userlevel 7
Badge +19
No worries, Andreas_26. Typically, physical electronic errors come from the immediate surroundings of the Connect. For instance, I have seen numerous occasions where users place their Connect on top of their home theater amp. This causes a number of problems because the antenna for the Connect is located towards the bottom of the unit, right up against the large electronic device responsible for powering the HiFi speakers. Mind telling us about the surroundings of the Connect?

Typically, we want to give the Connect a little "breathing room" of 6-8 inches of space between other large/powerful electronic devices. Thanks!
Badge
Thanks Keith, this worked!
Moved the Connect onto the next shelf level > no dropouts anymore :)
What puzzles me is that these problems only occured when rooms #2 and / or #3 were active.
Userlevel 2
So I have a 3 room set up.

Lounge - Playbar + 2x P1 for AS
Kitchen - 1 xP3
Master Bedroom - 1 x P1

Recently when I have gone to control the speakers through any phone it is only showing the lounge, and without the SS.

The kitchen still plays whatever was in the queue if I press play on the physical speaker but I can't adjust/change the music.

This is consistant across multiple controllers and we have tried disconnecting and reconnecting to the sonos system .

Can anyone provide any help in this matter? Happy to submit diagnostics

Regards
Userlevel 2
Multiple drop-outs and frozen controller issues over the last week or so. Mostly control system with iPhone X and IPad Air 2. Especially when trying to continue music from a Spotify starred stream. Diagnostic submission number 1223360522
Userlevel 7
Badge +26
Hi smr, to start with, I'm seeing more interference than I'd call acceptable, so I'd start with changing the wireless channel on your Sonos system to try and clear that up. If you can check what channel your router is on, it's best to split them up as much as possible. Spotify isn't too network intensive, but cutouts can be caused by wireless interference, and when you have more people around, like for a party, it can get even worse.

If you're still having trouble, the best way to clear things up quickly is to give us a call on our support line, that way a technician can take some time to work with you directly and help sort out what's happening.
Badge
Thanks Keith, this worked!
Moved the Connect onto the next shelf level > no dropouts anymore :)
What puzzles me is that these problems only occured when rooms #2 and / or #3 were active.


I was maybe a little too fast with my verdict. It still doesn't work properly. Diagnostic information number is 2072144236.
I was maybe a little too fast with my verdict. It still doesn't work properly. Diagnostic information number is 2072144236.
If your Sonos system is operating in Standard setup I would try and switch over to SonosNet.


Once your system is successfully configured in a BOOST Setup, it is recommended that you remove the WiFi password from your Sonos system by performing the following steps:

Sonos app for iOS or Android: From the More menu, tap Settings > Advanced Settings > Wireless Setup. On the Wireless Setup screen, click the button that says "Reset". Then click "Done" on the next screen.
Sonos Controller App for Mac: Click Sonos > Preferences > Advanced > Wireless Setup. On the Wireless Setup screen, click the button that says "Reset". Then click "Done" on the next screen.
Sonos Controller App for PC: Click Manage > Settings > Advanced > Wireless Setup. On the Wireless Setup screen, click the button that says "Reset". Then click "Done" on the next screen.


https://support.sonos.com/s/article/3209?language=en_US


Do you have any Repeaters, Wireless Extenders or Powerline Adaptors in use?
Badge
I was maybe a little too fast with my verdict. It still doesn't work properly. Diagnostic information number is 2072144236.
If your Sonos system is operating in Standard setup I would try and switch over to SonosNet.


Once your system is successfully configured in a BOOST Setup, it is recommended that you remove the WiFi password from your Sonos system by performing the following steps:

Sonos app for iOS or Android: From the More menu, tap Settings > Advanced Settings > Wireless Setup. On the Wireless Setup screen, click the button that says "Reset". Then click "Done" on the next screen.
Sonos Controller App for Mac: Click Sonos > Preferences > Advanced > Wireless Setup. On the Wireless Setup screen, click the button that says "Reset". Then click "Done" on the next screen.
Sonos Controller App for PC: Click Manage > Settings > Advanced > Wireless Setup. On the Wireless Setup screen, click the button that says "Reset". Then click "Done" on the next screen.


https://support.sonos.com/s/article/3209?language=en_US


Do you have any Repeaters, Wireless Extenders or Powerline Adaptors in use?


Yes, wireless extenders and powerline adaptors (my Connect is connected to one powerline adaptor).
Do you have any Repeaters, Wireless Extenders or Powerline Adaptors in use?

Yes, wireless extenders and powerline adaptors (my Connect is connected to one powerline adaptor).

Powerline Adaptors aren't supported by Sonos, for a reason, whereas Repeaters and Wireless Extenders tend to drop data packets critical to Sonos' functionality. I'd recommend to switch to SonosNet. Unplug all Extenders and Powerlines beforehand, afterwards you can plug them back in.
Badge
Do you have any Repeaters, Wireless Extenders or Powerline Adaptors in use?

Yes, wireless extenders and powerline adaptors (my Connect is connected to one powerline adaptor).

Powerline Adaptors aren't supported by Sonos, for a reason, whereas Repeaters and Wireless Extenders tend to drop data packets critical to Sonos' functionality. I'd recommend to switch to SonosNet. Unplug all Extenders and Powerlines beforehand, afterwards you can plug them back in.


Done everything you said: Moved the Connect away from my Stereo, disconnected powerline adaptors, wired up my Connect and (after all) bought a Boost and operate everything on SonosNet - it is even worse than ever before.
In case anybody is interested in my diagnostics: 67875769
😞
Userlevel 7
Badge +19
Andreas_26: If you are still having troubles, might I suggest giving our support technicians a call to get this resolved in real time. They can set up a remote session and get a closer look at the network connectivity. Thanks!
Badge
Andreas_26: If you are still having troubles, might I suggest giving our support technicians a call to get this resolved in real time. They can set up a remote session and get a closer look at the network connectivity. Thanks!

The support technician wasn't able to help me neither, but thanks (ref. 00243504).
I moved the Boost into my lounge now and hard-wired with Cat 7 to my router in the basement.
After 5 hours of simultaneous streams in all rooms I had no dropouts anymore.
Hence, the Boost investment wasn't in vain after all.
Thanks again and cheers! 🙂
Same here please see ticket 1161385095. Songs also change