Answered

Room containing only Sonos Port stops

  • 22 January 2022
  • 5 replies
  • 74 views

Badge

When I stream multi-room including my study (where the port is the only device) several times a day the music will stop in the study with no error visible in the app (but continue playing in the other rooms).  when I check the app, the study is no longer selected.  If I add the study back again it works for awhile (sometimes minutes sometimes hours) before that room falls out again. 
 

it doesn’t seem to matter what streaming music service  I use although I use SiriusXM most frequently. 

 

All of my devices are Wi-Fi connected and I’ve done some basic troubleshooting (Wi-Fi signal strength measuring, google mesh testing, reset router and all mesh devices etc.) without changing the nature of the problem. 
 

 

where can I start to troubleshoot this - is there an error log someplace I can check?

 

if you have access to support diagnostics, my confirmation number is 220085643.

 

thanks!!

 

 

icon

Best answer by Ken_Griffiths 23 January 2022, 02:32

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

Have your tried unplugging the Port from power for a couple of minutes and reboot your router and phone?

Are you able to directly connect a Sonos device (not a Sub or surround) to the main router with an ethernet cable?

Badge

I should have mentioned that I’ve power cycled all of the Sonos devices (6 one SLs, a Sub, an Arc, and the Port). As well as all of the network gear in the house (FIOS quantum gateway, 4 google wifi mesh points and 1 google nest Wi-Fi router and 3 google nest mesh points).

 

I don’t think I powered anything off for a couple of minutes, but I did follow the recommended power cycle order for the google system.  

 

I would estimate that the Port was probably was disconnected from power for about 30 seconds. I didn’t reboot my phone as part of that process, but I have updated the phone recently which requires a reboot (last weekend).  I’ll power the port off for longer and reboot my phone to see if it changes things.

 

I could run an Ethernet drop from my telecom closet to the basement and then snake a cable to one of the rooms, wire a jack and run a cable to any device I want to… but it wouldn’t be easy. I don’t have an easy way to connect a current member of my Sonos ecosystem via Ethernet to my network. 
 

I’d prefer to find a way to definitely track down root cause and then fix it.  Are there any logs or troubleshooting tools that are available to the end user? 

@Lynnn,
Perhaps see this earlier forum thread relating to Google Nest and other WiFi mesh networks, as that suggests wiring one Sonos device only to the main mesh hub/router to setup all the Sonos devices to run on a SonosNet signal rather than the Google WiFi:

https://en.community.sonos.com/troubleshooting-228999/troubleshooting-sonos-on-wifi-6856334?postid=16520976#post16520976

Badge

This issue is mostly resolved! Thanks to all who have helped to fix it. 

Sonos support suggested that I disable Autoplay on the Port Port line-in settings.  I’m still working on root cause, but the issue has not recurred in several hours

Presumably something has changed (I was running the Port with Autoplay enabled for a long time with no issues).  It appears that some event occurs and the Port detects an autoplay event and activates the line in on the Port which is pointed at my turntable.  Line-in is not being fed any signal since my turntable is powered off and my receiver is pointed at a source to which nothing is connected.  I’ll start working on tracking down that issue next.

 

It has been quite a journey. 

I contacted Sonos support, but they pushed me to move my devices to a wifi channel that was less “busy”.  I contacted  Google support to confirm my configuration and to rule out congestion on my 2.4 GHz channels (since you can’t AFAIK disable auto channel select/balancing on the mesh products nor can you manually select a channel). Google then recommended static IP reservations for some of the Sonos devices. 

 

I then re-opened my case with Sonos, recommended  I connect a Sonos device directly to my router so that we could move the Sonos devices to Sonosnet.  I resisted this idea, because I don’t have an Ethernet drop close to any of my Sonos devices and I invested in Sonos gear to avoid running cables… and pushed for troubleshooting tools or errors of any type.  Sonos support was able to find some errors where the port might have had network errors, but none we time correlated with my issues.

 

I eventually bought a Boost from Sonos and a 25’ Ethernet cable placing it halfway between my port and the router.   My port is only about 50 feet from the router and about 8 feet from the mesh wifi point. When this didn’t change the problem support recommended that disable I disable IGMP on the router.  Subsequently the problem was still occurring but with no network errors.

 

We reviewed the problem again and the disabling Autoplay was suggested. I will update once I understand the root cause better.

 

thanks!!!

I hope this works for you, but I have my doubts. 

The way you implemented the Boost sounds rather strange, although I may have misunderstood. If the problem occurs again please come back for more guidance.