Required update interrupted: Error code 6

  • 6 November 2015
  • 8 replies
  • 1419 views

I've tried updating off iOS and off Mac El Capitan and get same "try again" message with Error code 6 explanation. This code is not included on error page.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

Userlevel 4
Badge +3
I've tried updating off iOS and off Mac El Capitan and get same "try again" message with Error code 6 explanation. This code is not included on error page.

Try restarting your router and all Sonos products by unplugging the power cables for about 10 seconds. If you're still unable to update Sonos, send a diagnostic afterwards and reply here with your confirmation number.
I have had the same issue and tried the above. Would be great if you could help me thanks
Badge +1
Hi Janish,

Diagnostic shows that your Playbar is already up to date but your Sub is not and looks stuck on an older software version.
I would advise to factory reset your SUB, then to re-add it as a new product from the Sonos application ("add a plaer or sub" option).
Once the SUB added, there should be a new update prompt : please let us know if the update keeps on failing.
Dear support, I am getting Error code 6 while updating Sonos Connect. I have reset the device to factory settings, changed DHCP options and rebooted the device several times. Please advise.
It might be helpful if you were to submit a system diagnostic which would give them more information about your system, and what the potential issue is. Be sure to post the number that you get here, so they know what they're looking for.
Dear support, I have number of the diagnostic report i have sent: 8379465
Userlevel 7
Badge +19
Hello, mponsie. Thanks for posting and for the diagnostic report. The report you submitted was either corrupt or incomplete. This typically happens when there are problems routing data through Sonos and the local network. Your best bet would be to give our technicians a call. They are able to work with you in real time and set up a remote session. That will give the technicians a closer look at the network and hopefully get you back up and running. Our contact information can be found here.
Hey Team Sonos! I apologise for resurrecting this thread but with the new 9.2 update I am unable to update one of my Play:1, which is throwing an error 6. I was able to update a second speaker I have by unplugging both from the outlets and reconnecting power to only one of them. Repeating that process with the second speaker fails continuously. I have already submitted a diagnostics report with ID 554673014.

Is there something I'm missing? Looking forward to hearing from you!