Remote won’t control Beam with TV on

  • 7 August 2019
  • 6 replies

I have my tv remote configured to control the beam and it works when the tv is off. However, when I turn on the tv it won’t control the sound on the beam. When I press the volume up or down the tv just says “not available” because I set the tv audio to external speaker. It seems like the the tv IR is over riding the beam. I searched the forum for similar questions but couldn’t find anything. Anyone know how to fix this?

6 replies

Userlevel 1
You could try to reprogram the remote so it no longer controls the TV, then once that is done you can program the remote to work with the Beam in the Rooms settings within the Sonos app. I believe its More, settings, room settings. This will stop that remote from being able to turn on and off the TV though.

If you would like another option I would need to know how the BEAM is connected to the TV, is it using the using the HDMI to ARC or the Optical adapter?
Userlevel 5
Badge +13
I get the same thing on my TV for a second when I first send an IR signal to my Beam. Seeing how it's just for the initial command and nothing after that, it doesn't bother me. Either way, check out this Sonos article, it should help.

Eliminate annoying TV messages when using a remote
Thanks for these replies. I will try these. BTW Shake it is connected via Optical. I realized I should have put that in my original post.
Userlevel 1
Then do try the reprogramming of that remote. Does your TV have an ARC port?
No. My tv is a Samsung plasma 2008
Userlevel 6
Badge +15
Could it be that the On and Off have got out of sequence?

My Harmony universal remote shuts down the tv and my BT freeview box on a press of the “all off” button. After that I can’t control volume on my Playbase when playing music (until I select Sonos as a device).

I wonder if you’re seeing a similar thing on your setup?