Answered

Recent Update has all Sonos Devices dropping connection


Hello All,

 

I have a Sonos setup in my home with a Play5, 3 Sonos One, and a Sonos Port connected to powered monitors. I have successfully run with no issues for years on my Netgear Orbi Mesh.

Since the last Sonos update, each speaker drops connection randomly every day or so. The only way to recover is to power down and reboot the device. I show no issues in the network or router, have done packet tracing etc (Im an engineer) and there is no anomaly in any other device on the network (PCs, TVs, cell phones, etc). Even though it was a waste of time, I reset and re-setup all devices on the network, but the problem persists ONLY with the Sonos devices and the Sonos app.

 

Anyone else seeing similar issues?

icon

Best answer by ratty 9 June 2022, 19:31

View original

15 replies

Do you have static reservations for your IP addresses? The most common cause of post-update problems is IP duplication.

Userlevel 7
Badge +18

My system seems pretty stable, and has been for some time. 
 

As far as your problems, if you’re looking for some help a bit more information would help. Which update? Are you running wired or wireless? Wifi or SonosNet? Have your neighbours changed wifi channel, causing interference in your system? Have you rebooted your router as well as all speakers?

Do you have static reservations for your IP addresses? The most common cause of post-update problems is IP duplication.

Yep, all static IPs.

Is the Sonos system connected to the Orbi WiFi? Or is there a Sonos component wired (preferably to the Orbi primary node), putting the system onto SonosNet? 

My system seems pretty stable, and has been for some time. 
 

As far as your problems, if you’re looking for some help a bit more information would help. Which update? Are you running wired or wireless? Wifi or SonosNet? Have your neighbours changed wifi channel, causing interference in your system? Have you rebooted your router as well as all speakers?

 

Thank you, but I'm not looking for troubleshooting help. I have already isolated this to Sonos device connectivity to WiFi using IP packet analyzation with a sniffer. The data has proven there is no issue with the network, devices on the network or from any interference. The disconnect is being caused by the Sonos devices themselves…. locking up and needing a reboot to reconnect, which is indicative of a firmware or OS issue, which is exactly what was recently updated.

The system has never had an issue until this last system update, and nothing else has changed.

I’m looking to see if there are others experiencing this issue.

Thank you, but I'm not looking for troubleshooting help.

...

I’m looking to see if there are others experiencing this issue.

There have been no significant reports, and if folks were seeing their players drop off the network regularly you can be assured this board would have lit up. 

 

Thank you, but I'm not looking for troubleshooting help. I have already isolated this to Sonos device connectivity to WiFi using IP packet analyzation with a sniffer. The data has proven there is no issue with the network, devices on the network or from any interference. The disconnect is being caused by the Sonos devices themselves…. locking up and needing a reboot to reconnect, which is indicative of a firmware or OS issue, which is exactly what was recently updated.

The system has never had an issue until this last system update, and nothing else has changed.

I’m looking to see if there are others experiencing this issue.

 

Actually, it is indicative of duplicate IP addresses, something we have seen thousands of times over the last 15 years.  These happen when the router loses track of its IP allocation table due to a crash or a reboot, and starts handing out IP addresses that are already in use.  The symptoms often show up after an update, because an update causes Sonos devices to reboot, and they all request a new address upon startup.  So the sooner you stop insisting it is some widespread error in the Sonos firmware, the sooner we can get it fixed.

Reboot/power cycle the following, in this exact order, waiting till each comes up before moving to the next:

Router/modem

Switches/hubs

Wired Sonos devices

Wireless Sonos devices

PC/Laptops/streaming devices

Printer and other peripherals

You can also switch WiFi Off/On on your phones/tablets

After that, you can eliminate the problem entirely by going into your router setup and reserving IP addresses for all you Sonos devices.

 

Userlevel 7
Badge +18

@Craigster did say he’s running with static ip’s. He hasn’t said whether he’s done a sequential reboot, starting with his router. (He also said he’s not looking for help.)

 

Thank you, but I'm not looking for troubleshooting help. I have already isolated this to Sonos device connectivity to WiFi using IP packet analyzation with a sniffer. The data has proven there is no issue with the network, devices on the network or from any interference. The disconnect is being caused by the Sonos devices themselves…. locking up and needing a reboot to reconnect, which is indicative of a firmware or OS issue, which is exactly what was recently updated.

The system has never had an issue until this last system update, and nothing else has changed.

I’m looking to see if there are others experiencing this issue.

 

Actually, it is indicative of duplicate IP addresses, something we have seen thousands of times over the last 15 years.  These happen when the router loses track of its IP allocation table due to a crash or a reboot, and starts handing out IP addresses that are already in use.  The symptoms often show up after an update, because an update causes Sonos devices to reboot, and they all request a new address upon startup.  So the sooner you stop insisting it is some widespread error in the Sonos firmware, the sooner we can get it fixed.

Reboot/power cycle the following, in this exact order, waiting till each comes up before moving to the next:

Router/modem

Switches/hubs

Wired Sonos devices

Wireless Sonos devices

PC/Laptops/streaming devices

Printer and other peripherals

You can also switch WiFi Off/On on your phones/tablets

After that, you can eliminate the problem entirely by going into your router setup and reserving IP addresses for all you Sonos devices.

 

I'm not insisting anything, I simply asked a question. Your answer… and arrogance… is not helpful…. I suggest you read in detail before you just repeat the same answers that everyone else does which have nothing to do with the question asked. Of course, everyone uses DHCP, right? And its the root of all issues…. wrong in this case. I don't use DHCP and never would…. if you really understood networking and security you would know that DORA doesn’t apply… even if you know what DORA meant… but you probably felt great in front of others that don’t know any better.

 

Yes, in 15 years, every issue was user configs and routers… never Sonos firmware or devices. Enjoy your little bubble and your lack of reading comprehension and technology skills.

 

Please close the thread.

I don't use DHCP and never would

That’s strange, since Sonos relies on DHCP. 

That’s strange, since Sonos relies on DHCP. 

 

Methinks the poster doth protest too much.

I’m not a network guru, so I have absolutely no idea what DORA is. Does it replace DHCP?

Looking at Google, it could be:

DevOps Research and Development

Department of Regulatory Agencies

A children’t cartoon (that I’m way too familiar with) 

Is it one of these, or is it something else, that replaces DHCP with some other networking standard?

I’m not a network guru, so I have absolutely no idea what DORA is. Does it replace DHCP?

It’s an acronym for the DHCP message exchange. https://en.wikipedia.org/wiki/Dynamic_Host_Configuration_Protocol#Operation

That’s the DHCP that the OP says they don’t use.  

Userlevel 4
Badge +3

 

Thank you, but I'm not looking for troubleshooting help. I have already isolated this to Sonos device connectivity to WiFi using IP packet analyzation with a sniffer. The data has proven there is no issue with the network, devices on the network or from any interference. The disconnect is being caused by the Sonos devices themselves…. locking up and needing a reboot to reconnect, which is indicative of a firmware or OS issue, which is exactly what was recently updated.

The system has never had an issue until this last system update, and nothing else has changed.

I’m looking to see if there are others experiencing this issue.

 

Actually, it is indicative of duplicate IP addresses, something we have seen thousands of times over the last 15 years.  These happen when the router loses track of its IP allocation table due to a crash or a reboot, and starts handing out IP addresses that are already in use.  The symptoms often show up after an update, because an update causes Sonos devices to reboot, and they all request a new address upon startup.  So the sooner you stop insisting it is some widespread error in the Sonos firmware, the sooner we can get it fixed.

Reboot/power cycle the following, in this exact order, waiting till each comes up before moving to the next:

Router/modem

Switches/hubs

Wired Sonos devices

Wireless Sonos devices

PC/Laptops/streaming devices

Printer and other peripherals

You can also switch WiFi Off/On on your phones/tablets

After that, you can eliminate the problem entirely by going into your router setup and reserving IP addresses for all you Sonos devices.

 

I'm not insisting anything, I simply asked a question. Your answer… and arrogance… is not helpful…. I suggest you read in detail before you just repeat the same answers that everyone else does which have nothing to do with the question asked. Of course, everyone uses DHCP, right? And its the root of all issues…. wrong in this case. I don't use DHCP and never would…. if you really understood networking and security you would know that DORA doesn’t apply… even if you know what DORA meant… but you probably felt great in front of others that don’t know any better.

 

Yes, in 15 years, every issue was user configs and routers… never Sonos firmware or devices. Enjoy your little bubble and your lack of reading comprehension and technology skills.

 

Please close the thread.

@Craigster Sonos will never accept they have goofed up

something and are trying to insist it’s a networking issue when it’s not. There is a 57 page long post of users reporting dropouts since 14.6 update was introduced way back on 19th April 2022. Following this update, many users are having audio dropouts randomly and the only thing that helps is a reboot of all devices. With regards to DORA , Sonos team it stands for Discover, Offer, Request and Acknowledge. It’s a simple IP allocation technique used in a server client model when a client is requesting an IP. @Craigster you aren’t alone here, unfortunately we are at the mercy of engineers who are claiming the dropouts to be a network configuration or wireless interference problem when it’s not. FYI, the link for thread is as below:

Please add yourself in the thread and hopefully we can help each other come up with a solution as @Sonos hasn’t been able to fix it yet..

@kuwarrulz_11 you may wish to recruit others to your cause, but the OP said they had “a Play5, 3 Sonos One, and a Sonos Port”. No Arc. No surrounds or Sub. In short, nothing to do with the thread you referenced.

Reply