Answered

Problems after update 10.0

  • 31 January 2019
  • 9 replies
  • 1215 views

After the update I have problems with the sonos app. On one phone it works on the other one it doesn't Of the 6 sonos items only 1 can be found. Th rest can not be seen by the app. Does any one has the same issue(s)?
icon

Best answer by melvimbe 31 January 2019, 19:42

This sounds like IP address conflict. After your speakers reboot (which will happen during an upgrade) the router assigns them new IP addresses. Some routers have a tendency to assign IP addresses that it already assigned to other devices in your home, creating conflicts.

To resolve, unplug your Sonos speakers, reboot your router, then add back the Sonos speakers. For a more permanent solution reserve IP addresses for your Sonos speakers in your router's configuration.
View original

9 replies

Userlevel 7
Badge +21
This sounds like IP address conflict. After your speakers reboot (which will happen during an upgrade) the router assigns them new IP addresses. Some routers have a tendency to assign IP addresses that it already assigned to other devices in your home, creating conflicts.

To resolve, unplug your Sonos speakers, reboot your router, then add back the Sonos speakers. For a more permanent solution reserve IP addresses for your Sonos speakers in your router's configuration.
I’m going to try this right now! I installed NEST cameras yesterday. Could that be part of the problem?
It might be, although I'd lean more towards Danny's suggestion.

You can see more information about wifi interference here.
I did exactly what you suggested but it didn’t work. Maybe because i also have an apple time capsule.
Thanks for all the suggestions btw!!!
Then I'd recommend that you submit a system diagnostic, and either post the number here, or contact Sonos to discuss it. There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.
I rebooted the Time Capsule and the problem disapeared!!! Thank you all!!!!
I just did the 10 update and all of my music services have disappeared. This pretty much happens with every update. It only lets me access a few of the folders from my music library on my PC. Any thoughts on how to fix?
Userlevel 7
Badge +20
I just did the 10 update and all of my music services have disappeared. This pretty much happens with every update. It only lets me access a few of the folders from my music library on my PC. Any thoughts on how to fix?

I'd recommend rebooting your router and each of your Sonos speakers, then checking again. If the music services are still missing, send along a diagnostic report and reply here with the number.

Reply