Problem with Playbase audio and TV

  • 16 August 2017
  • 6 replies
  • 847 views

Audio currently works when I am playing music through the app, however, the only way to get audio from the TV is when TV speakers are turned on (rather than audio system) and the sound from the Playbase conflicts with the TV speakers

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

I'm sorry, that doesn't make much sense to me, but I think it's more because there's not enough information for me to form a mental image of your setup. What kind of TV is it? Is it connected to the Sonos Playbase with an optical cable, or in some other fashion?

I think, without knowing anything about your TV, that there's a setting in the Audio section of the TV where you need to turn off the TV speakers, but allow the optical connection to work. I'm guessing that you haven't yet turned off the TV's speakers, and so are controlling the volume by turning up and down the TV's speakers. Often, turning off the TV's speakers will allow you to just control the Sonos' volume, without changing anything on the TV. While you're in that section of the TV's settings, I'd be looking to see if there's something that allows you to switch from "variable" to "fixed" on the output as well. You really want the Sonos to be in charge of the volume settings, not the TV. And also look for something that can be set to Dolby Digital or PCM. If it can allow anything else, that's probably going to impact your experience. Dolby Digital is preferred.

And frankly, anything that you have connected to the TV needs to be looked at as well, whether it's a cable box, game console, DVD player, etc. All need to be told to restrict the output to Dolby Digital

Can you clarify what you mean by "the audio system"? I'm unclear what that means in your case.
Apologies for the confusion. The tv is a SONY Bravia, and when I meant audio system I had just meant to clarify the difference between the TV speakers (it is the menu option in the TV settings menu) and the Playbase. I just tried switching from TV speakers to Audio system and it worked, however the playback is choppy or inconsistent at best. When I switch back to TV speakers the audio quality is consistent. I'm currently navigating through the troubleshooting menu for audio playback stops or skips - however, different inputs (apple tv vs set top verizon fios box) or different channels do not seem to work. Also, the cable looks to be in good condition and I see the red light. I will keep trying the trouble shooting methods outlined
I would also double check that you have the latest firmware on the TV. I seem to recall that Sony released an update earlier this year for that issue, although it may or may not have been for your model.

Good luck!
I have the same problem.....and I have been told that sonos is aware of it...and is working on a fix.....it is not the tv.....until the fix is in...your only option is to turn the tv offf, or change the channel...and go back to what you were watching.....
I have same issue on certain FIOS channels. I have Sony Bravia TV connected to Sonos Soundbar. All have latest software updates. Certain channels have sound and other have no sound or have a delay in sound turning on. If I change Sony setup to play TV speakers sound is fine (no sound from Sonos). Feels like a known Sonos and Sony bandwidth connectivity issue.
Randy,

It may behoove you to submit a system diagnostic, and post the number here, for the folks at Sonos to look at. They'll be able to look at data in there that might help pinpoint the issue.