Question

problem connecting to iTunes on NAS

  • 4 June 2017
  • 6 replies
  • 954 views

Userlevel 1
Badge +2
I have Sonos controller on my Macbook and it can read the local iTunes library. I purchased a Sinology NAS and copied the iTunes library to the NAS. I removed the path to the local iTunes library on the Macbook and now I cannot connect to the NAS iTunes library, probably because I am using the incorrect path name?? Have iTunes installed on a top level "music " directory. I am a newbie here and a little out of my depth. Can anyone advise the correct path I should use. The only path that Sonos will let me connect to is //diskstation/music/iTunes, but then iSonos says it cannot find the track.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 6
Badge +5
You can check the path name by dropping into the finder, selecting the Go menu and then selecting "Connect To Server" - or simply hold down ⌘ and then type 'k'. A window should pop up looking for a destination. Type SMB://diskstationname/folder/etc into the top bar of the window. See if you can connect via the specific path you're looking to use with the sonos (then enter login and password as needed). If successful, the NAS share should mount on your desktop or in a Finder window (depends on how you have set up your Finder preferences).

If that works from your macbook, you may have a different issue on your hands, i.e. the sonos cannot communicate properly with the NAS. That may be due to the Synology being set up for SMB2 by default. But let's see first how far you get connecting to the NAS using the MacBook.
Userlevel 1
Badge +2
Hi Constantin
I can see the NAS from my Macs Finder by browsing for servers or by choosing a previous server connection. The following server address works: afp://neilf216._afpovertcp._tcp.local but not smb://neilf216._afpovertcp._tcp.local
Userlevel 6
Badge +5
Careful, you seem to be mixing and matching protocols. First, confirm that SMB is running on the NAS by reviewing its network preferences. Then try using a path like SMB://neilf216/xyx where xyx is the name of your share.

the other stuff (_.afpxxx) is AFP specific.
Two thoughts. 1. The Windows controller allows you to browse for the folder, so no need to type a pathname. Does the Mac controller not do the same? 2. My Synology NAS music folder answers to the name \\DISKSTATION\music. (I think those slashes are the right way round, but can't check at the moment.) I'm not sure why your would have problems with that, but maybe just my ignorance on SMB sharing.
Userlevel 1
Badge +2
Replying to both. Yes smb in enabled on my NAS.
Sonos will not accept smb://neilf216/music - but I can map smb://neilf216/music on the Mac and see contents.
\\diskstation\music doest work - "unable to add folder to your library
I have contacted Sonos tech support and they are on the case!
Userlevel 1
Badge +2
OK - I fixed it. Sonos accepts //neilf216/music/iTunes.
Thanks for the help.
I think Sonos is awesome - being able to control music with a phone, tablet when my laptop is off is great.
But the sound is terrific!
Cant wait to buy more speakers!