"Problem authorizing spotify"...or any music services

  • 16 October 2016
  • 1 reply

For a couple weeks now, I am unable to access any music services through my Sonos iOS app. I've tried removing all the music services and rebooted my iPhone as suggested by one of the threads here. However when I now launch Sonos and attempt to add Spotify or Pandora etc, I get an error authorizing any of my accounts.. It wouldn't even bring me to the login page of Spotify.. How do i get around this? I've even tried restarting my router like ten times.. That does not work either..

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +20
Welcome to the community, Kavyakolisetty. Try this: Go to Settings on the iOS device. Then go to your current connected WiFi network. Then tap the letter "i" in the circle. Then change DNS to:, Reboot the phone (turn it off for 5 seconds). If this doesn't work, please submit a diagnostic and respond with the confirmation number. Thanks in advance.